Bug 16733 - Support newer VIA chips
Summary: Support newer VIA chips
Status: NEW
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/other (show other bugs)
Version: XOrg git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-16 06:19 UTC by Bernhard Rosenkraenzer
Modified: 2008-07-21 01:21 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
VIA's patch (129.88 KB, patch)
2008-07-16 06:19 UTC, Bernhard Rosenkraenzer
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Rosenkraenzer 2008-07-16 06:19:24 UTC
Created attachment 17701 [details] [review]
VIA's patch

VIA has released a patch to support newer (chrome9) VIA chips at linux.via.com.tw.

It doesn't break any existing code, so it should be safe to add to experimental builds.
Comment 1 Erik Andren 2008-07-16 06:51:22 UTC
Some of the comments embedded in this code are pure comedy :)

/* Strange thing happen! Faint. Code bug! */

/*DONE. Need we call function copy_to_user ?NO. We can't even
touch user's space.But we are lucky, since kernel drm:drm_ioctl
will to the job for us.  */


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.