Bug 17265 - problems with xfwm4, cairo and randr 1.2
Summary: problems with xfwm4, cairo and randr 1.2
Status: RESOLVED DUPLICATE of bug 17261
Alias: None
Product: cairo
Classification: Unclassified
Component: xlib backend (show other bugs)
Version: 1.6.4
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Carl Worth
QA Contact: cairo-bugs mailing list
Depends on:
Reported: 2008-08-22 14:29 UTC by Yves-Alexis
Modified: 2008-08-23 03:25 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Description Yves-Alexis 2008-08-22 14:29:44 UTC

I have a weird problem which is hard to debug. This is the third bug I
open, first ones were against xfwm4 and murrine:


I'm using Xfce 4.4.2 on a laptop, and murrine engine 0.60~svn.

When I plug a VGA screen and do xrandr --auto, everything works fine and
I get the external screen as clone mode. Then I want to use the second
screen to extend my desktop, I do:

xrandr --output VGA --right-of LVDS

Then, the screen on the right correctly gets of clone mode, but nothing
(or so) is displayed there. I can see the mouse pointer, but that's all.
I use compositing on inactive and moving windows, so I tried disabling
compositing on xfwm4, and it worked, I could see the window on the right

As murrine is a RGBA-enabled theme engine, I tried to switch theme, and
use xfce engine, with compositing, and it works too. So I reported the
bug against murrine, and Cimi helped me a bit. I tried Clearlooks, Crux
and Industrial themes, which are all cairo-based (which xfce engine is
not), and it doesn't work on any. Cimi thinks this can be related to
cairo or intel xorg driver.

I have a related problems, where all “text” widgets (menus, menubar,
labels etc.) and “composited” widget disappear from time to time, at
resume. Sometime just putting the laptop to sleep again and having it
back fixes the problem, so I'll try to see with intel driver maintainers

Cheers and thanks for all the work.
Comment 1 Yves-Alexis 2008-08-23 03:25:51 UTC

*** This bug has been marked as a duplicate of bug 17261 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.