Bug 17291 - [845G] Fatal server error lockup: server never start
[845G] Fatal server error lockup: server never start
Status: RESOLVED DUPLICATE of bug 17756
Product: xorg
Classification: Unclassified
Component: Driver/intel
git
x86 (IA32) Linux (All)
: medium blocker
Assigned To: Wang Zhenyu
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-25 02:39 UTC by Emmanuel Fusté
Modified: 2008-11-26 05:50 UTC (History)
0 users

See Also:


Attachments
Xorg log (20.18 KB, text/plain)
2008-08-25 02:39 UTC, Emmanuel Fusté
no flags Details
Log with garbage on screen (18.98 KB, text/plain)
2008-08-26 05:37 UTC, Emmanuel Fusté
no flags Details
server start OK (16.15 KB, text/plain)
2008-08-26 05:37 UTC, Emmanuel Fusté
no flags Details
No freq sync (490.69 KB, image/jpeg)
2008-08-26 05:39 UTC, Emmanuel Fusté
no flags Details
Xorg log intel 2.4.1 (42.05 KB, text/plain)
2008-09-26 04:37 UTC, Emmanuel Fusté
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emmanuel Fusté 2008-08-25 02:39:56 UTC
Created attachment 18498 [details]
Xorg log

Ibm/Lenovo Netvista with 82845G/GL

Old or newer driver (latest test with 2.4 HEAD of August 24th) did not start.
Tested with/without "NoDRI", "XAA", "EXA", "ForceEnablePipeA" options.
Comment 1 Wang Zhenyu 2008-08-25 20:12:31 UTC
How about "ExaNoComposite" and "NoAccel" option?
Comment 2 Emmanuel Fusté 2008-08-26 05:37:34 UTC
Created attachment 18522 [details]
Log with garbage on screen
Comment 3 Emmanuel Fusté 2008-08-26 05:37:58 UTC
Created attachment 18523 [details]
server start OK
Comment 4 Emmanuel Fusté 2008-08-26 05:39:57 UTC
Created attachment 18525 [details]
No freq sync
Comment 5 Emmanuel Fusté 2008-08-26 05:40:30 UTC
Ok, with "NoAccel" option, the server start, but screen does not synchronize: hardware state is not clean.
A reboot later, all start correctly.

"ExaNoComposite" is not enough and a reboot is need between each try to clean up HW state, or I get a corrupted or blank screen (picture attached)

Will run with "NoAccel" for now.
Please, ask if you need logs, other tests results or some patches to try to run without "NoAccel" option.

Comment 6 Emmanuel Fusté 2008-08-26 06:11:33 UTC
Clean boot 
"NoAccel" option
"startx" or "/etc/init.d/gdm start" -> all is OK
Switch to console (CTRL-ALT-F1) ok
Switch back to X -> black-blank screen
Switch back and forth between console and X : console ok, X blank.
Comment 7 Michael Fu 2008-09-25 18:44:10 UTC
(In reply to comment #6)
> Clean boot 
> "NoAccel" option
> "startx" or "/etc/init.d/gdm start" -> all is OK
> Switch to console (CTRL-ALT-F1) ok
> Switch back to X -> black-blank screen
> Switch back and forth between console and X : console ok, X blank.
> 

would you please attach the log? My guess is it's full of "pipe underrun"...
Comment 8 Wang Zhenyu 2008-09-25 21:46:02 UTC
Could you try patch on #17756?
Comment 9 Emmanuel Fusté 2008-09-26 04:37:13 UTC
Created attachment 19237 [details]
Xorg log intel 2.4.1
Comment 10 Emmanuel Fusté 2008-09-26 04:38:31 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > Clean boot 
> > "NoAccel" option
> > "startx" or "/etc/init.d/gdm start" -> all is OK
> > Switch to console (CTRL-ALT-F1) ok
> > Switch back to X -> black-blank screen
> > Switch back and forth between console and X : console ok, X blank.
> > 
> 
> would you please attach the log? My guess is it's full of "pipe underrun"...
> 
Exactly !!!! : "underrun on pipe A!"

Log attached.
Comment 11 Emmanuel Fusté 2008-09-26 05:40:50 UTC
Patch #17756 applied on intel_2.4.2 driver with X.Org Server 1.5.1 (debian Experimental)

All is now robust and working perfectly, driver accelerated and DRI on !

Before closing this bug, a similar patch could be useful for the kernel i810fb frame-buffer  driver which is non functional on the same computer. (and kernel dri mode-setting dev should perhaps be audited too for the same pblm).

Many thanks!!
Comment 12 Michael Fu 2008-11-26 05:50:45 UTC


*** This bug has been marked as a duplicate of bug 17756 ***