Bug 17442 - [GEM ]X get crash with error"[drm] failure adding irq handler" when starting
[GEM ]X get crash with error"[drm] failure adding irq handler" when starting
Status: VERIFIED DUPLICATE of bug 17446
Product: xorg
Classification: Unclassified
Component: Driver/intel
git
Other Linux (All)
: medium normal
Assigned To: Gordon Jin
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-05 01:08 UTC by liuhaien
Modified: 2009-01-12 23:16 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg.0.log (59.11 KB, text/plain)
2008-09-05 01:08 UTC, liuhaien
no flags Details
xorg conf file (4.31 KB, text/plain)
2008-09-05 01:10 UTC, liuhaien
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description liuhaien 2008-09-05 01:08:15 UTC
Created attachment 18687 [details]
xorg.0.log

System Environment:
--------------------------
Host:		gm965
Arch:		i386
Kernel:		2.6.27-rc4(eric's kernel tree)
Libdrm:		(master)99f8cce3eae79c9cf5e9897ef1af8eac24b38c09
Mesa:		(master)4a32f0c63886b985743ecadc24fd60a23864c491
Xserver:		(master)47bf269d5922a4998c33908a53ad1affa8de96c0
Xf86_video_intel:		(master)fca7a4e9a5c73e1c129e94eeccf8fc795f729931
Bug detailed description:
--------------------------
X cannot start with below error:
(EE) intel(0): Failed to pin front buffer: Cannot allocate memory

Fatal server error:
Couldn't bind memory for BO front buffer


Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
Please also check the log file at "/opt/X11R7/var/log/Xorg.0.log" for addition
 information.

X: intel_bufmgr_gem.c:531: dri_gem_bo_unmap: Assertion `bo_gem->mapped' failed
******************************************************
dmesg shows:
[drm] Initialized i915 1.6.0 20080730 on minor 0
[drm:i915_gem_object_bind_to_gtt] *ERROR* GTT full, but LRU list empty
[drm:i915_gem_object_pin] *ERROR* Failure to bind: -12<3>[drm:i915_gem_object_bind_to_gtt] *ERROR* GTT full, but LRU list empty
[drm:i915_gem_object_pin] *ERROR* Failure to bind: -12
---------------------------------------------------

Reproduce steps:
----------------
1.X&
Comment 1 liuhaien 2008-09-05 01:10:00 UTC
Created attachment 18688 [details]
xorg conf file
Comment 2 Tobias Hain 2008-09-05 08:03:05 UTC
I guess you are using this huge virtual display to drive multiple displays with xrandr. I have the same chipset (GM965) and encountered the same bug (though it was the back buffer that failed to allocate). It helped to reduce the virtual desktop size.

Could you try to disable this big virtual display in xorg.conf and report back? I do recognize that those big virtual sizes work in previous non-GEM kernels.

	SubSection "Display"
#		Virtual   4048 2048
		Viewport  0 0
		Depth     24
		Modes    "1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
Comment 3 liuhaien 2008-09-07 20:04:56 UTC


(In reply to comment #2)
> I guess you are using this huge virtual display to drive multiple displays with
> xrandr. I have the same chipset (GM965) and encountered the same bug (though it
> was the back buffer that failed to allocate). It helped to reduce the virtual
> desktop size.
> 
> Could you try to disable this big virtual display in xorg.conf and report back?
> I do recognize that those big virtual sizes work in previous non-GEM kernels.
> 
>         SubSection "Display"
> #               Virtual   4048 2048
>                 Viewport  0 0
>                 Depth     24
>                 Modes    "1280x1024" "1024x768" "800x600" "640x480"
>         EndSubSection
> 

thanks ,we have tried it as you said,and thie issue dosen't exist.but we encounter
another issue as the title shows.
Comment 4 liuhaien 2008-09-07 20:07:32 UTC
when starting X,X will crash and we get below error:
(EE) intel(0): [drm] failure adding irq handler
-------------------------------------
we try to bisect and find this commit(from eric's kernel tree) which cause the issue:
commit 7297294597b9be5bb377d996a5bcbcda64417add
Author: Kristian Høgsberg <krh@redhat.com>
Date:   Wed Aug 20 11:04:27 2008 -0400

    i915 gem: install and uninstall irq handler in entervt and leavevt ioctls.

    Signed-off-by: Kristian Høgsberg <krh@redhat.com>
    Signed-off-by: Eric Anholt <eric@anholt.net>

Comment 5 liuhaien 2008-09-07 23:40:55 UTC
 It also happens on G33 and 945g 
Comment 6 Tobias Hain 2008-09-08 00:54:13 UTC
Most likely a duplicate of
https://bugs.freedesktop.org/show_bug.cgi?id=17446

Try the suggested commit 1063ef90845d7c84f4799ac34bd23ef37860bdc0 of eric's kernel there.
Comment 7 liuhaien 2008-09-08 01:09:48 UTC
(In reply to comment #6)
> Most likely a duplicate of
> https://bugs.freedesktop.org/show_bug.cgi?id=17446
> 
> Try the suggested commit 1063ef90845d7c84f4799ac34bd23ef37860bdc0 of eric's
> kernel there.
> 

it works well with commit 1063ef90845d7c84f4799ac34bd23ef37860bdc0.
Comment 8 Eric Anholt 2008-09-10 15:11:47 UTC
Please close the old bug and open a new one instead of changing the topic of a bug several comments in.

The new topic of this bug is a dupe of 17446.

*** This bug has been marked as a duplicate of bug 17446 ***
Comment 9 Gordon Jin 2008-09-13 18:07:11 UTC
Haien, remember to file a new bug for the original issue (huge virtual display). Please also test if it's reproducible with non-GEM kernel.
Comment 10 liuhaien 2008-09-16 19:01:11 UTC
(In reply to comment #9)
> Haien, remember to file a new bug for the original issue (huge virtual
> display). Please also test if it's reproducible with non-GEM kernel.
> 

ok, I have filed a new bug (#17618)for that issue.
Comment 11 liuhaien 2008-09-17 17:52:24 UTC
(In reply to comment #10)
> (In reply to comment #9)
> > Haien, remember to file a new bug for the original issue (huge virtual
> > display). Please also test if it's reproducible with non-GEM kernel.
> > 
> 
> ok, I have filed a new bug (#17618)for that issue.
> 

and it can not reproduce with non-GEM kernel ,there is another issue with non-GEM kernel ,see bug 17621.