Bug 17545 - Internet system erro when using Add and Remove or search using yum
Summary: Internet system erro when using Add and Remove or search using yum
Status: RESOLVED NOTOURBUG
Alias: None
Product: PackageKit
Classification: Unclassified
Component: backend-yum (show other bugs)
Version: unspecified
Hardware: x86 (IA32) All
: high blocker
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-11 23:40 UTC by khaled
Modified: 2008-09-12 03:17 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description khaled 2008-09-11 23:40:02 UTC
Error Type: <type 'exceptions.SyntaxError'>
Error Value: invalid syntax (filter-data.py, line 111)
  File : /usr/share/PackageKit/helpers/yum/search-group.py , line 20, in <module>
    backend = PackageKitYumBackend(sys.argv[1:],lock=False)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 242, in __init__
    self._setup_yum()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 1555, in _setup_yum
    self.yumbase.doConfigSetup(errorlevel=0,debuglevel=0)     # Setup Yum Config
  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 134, in doConfigSetup
    errorlevel=errorlevel)
  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 180, in _getConfig
    startupconf.pluginconfpath,disabled_plugins)
  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 342, in doPluginSetup
    plugin_types, confpath, disabled_plugins)
  File : /usr/lib/python2.5/site-packages/yum/plugins.py , line 151, in __init__
    self._importplugins(types)
  File : /usr/lib/python2.5/site-packages/yum/plugins.py , line 193, in _importplugins
    self._loadplugin(modulefile, types)
  File : /usr/lib/python2.5/site-packages/yum/plugins.py , line 226, in _loadplugin
    module = imp.load_module(modname, fp, pathname, description)
Comment 1 Richard Hughes 2008-09-12 03:17:23 UTC
This is a bug in yum-filter-data - if you uninstall the plugin everything should work okay. There's not a lot PackageKit can do in this case, sorry.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.