Bug 17554 - yum and yumex stop working
Summary: yum and yumex stop working
Status: RESOLVED INVALID
Alias: None
Product: PackageKit
Classification: Unclassified
Component: backend-yum (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
: 17565 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-09-12 09:50 UTC by Michel Desmarais
Modified: 2008-09-26 08:16 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Desmarais 2008-09-12 09:50:53 UTC
fc9 last build of yum, yumex and PackageKit available 
working in french
The only thing i did is configured the vnc server and user
a stop vnc service in case. The problem persist.
don't know if it is a bug. 

from system updates and yumex action the same message error:
Error Type: <type 'exceptions.SyntaxError'>
Error Value: invalid syntax (filter-data.py, line 111)
  File : /usr/share/PackageKit/helpers/yum/refresh-cache.py , line 17, in <module>
    backend = PackageKitYumBackend(sys.argv[1:])
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 242, in __init__
    self._setup_yum()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 1555, in _setup_yum
    self.yumbase.doConfigSetup(errorlevel=0,debuglevel=0)     # Setup Yum Config
  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 139, in doConfigSetup
    errorlevel=errorlevel)
  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 189, in _getConfig
    startupconf.pluginconfpath,disabled_plugins,enabled_plugins)
  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 355, in doPluginSetup
    plugin_types, confpath, disabled_plugins, enabled_plugins)
  File : /usr/lib/python2.5/site-packages/yum/plugins.py , line 152, in __init__
    self._importplugins(types)
  File : /usr/lib/python2.5/site-packages/yum/plugins.py , line 195, in _importplugins
    self._loadplugin(modulefile, types)
  File : /usr/lib/python2.5/site-packages/yum/plugins.py , line 251, in _loadplugin
    module = imp.load_module(modname, fp, pathname, description)
from kyum:
 File "/usr/bin/yum", line 29, in <module>
***     yummain.user_main(sys.argv[1:], exit_code=True)
***   File "/usr/share/yum-cli/yummain.py", line 229, in user_main
***     errcode = main(args)
***   File "/usr/share/yum-cli/yummain.py", line 84, in main
***     base.getOptionsConfig(args)
***   File "/usr/share/yum-cli/cli.py", line 184, in getOptionsConfig
***     enabled_plugins=self.optparser._splitArg(opts.enableplugins))
***   File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 189, in _getConfig
***     startupconf.pluginconfpath,disabled_plugins,enabled_plugins)
***   File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 355, in doPluginSetup
***     plugin_types, confpath, disabled_plugins, enabled_plugins)
***   File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 152, in __init__
***     self._importplugins(types)
***   File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 195, in _importplugins
***     self._loadplugin(modulefile, types)
***   File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 251, in _loadplugin
***     module = imp.load_module(modname, fp, pathname, description)
***   File "/usr/lib/yum-plugins/filter-data.py", line 111
***     ('committers', 'committer')]
***                                ^
*** SyntaxError: invalid syntax
Comment 1 Marco PAolini 2008-09-13 15:26:36 UTC
*** Bug 17565 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.