Bug 17707 - ut2004 :wrong texture on guns
Summary: ut2004 :wrong texture on guns
Status: VERIFIED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915 (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: haihao
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-22 00:28 UTC by lin, jiewen
Modified: 2009-01-07 01:06 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg.conf (3.59 KB, application/octet-stream)
2008-09-22 00:28 UTC, lin, jiewen
Details
Xorg.0.log (44.23 KB, text/plain)
2008-09-22 00:29 UTC, lin, jiewen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lin, jiewen 2008-09-22 00:28:08 UTC
Created attachment 19083 [details]
xorg.conf

System Environment:
--------------------------
--Platform: 945gm
--Architecture(32-bit,64-bit,compatiblity): 32-bit
--2D driver: master 071937ae577db67a9b5760bd4c2c4b61a8194822
--3D driver: mesa-7_2_branch 35fe0e56e6f6b45ceea0c3d43be7596c1ea44e00
--DRM: shipped with kernel 2.6.27-rc5
--libdrm: master 8ca06eb492f861dbf049a2e104e4e2a5ba814c13
--Xserver: 1.5release
--Kernel: 2.6.27-rc5
--Display connector: LVDS

Bug detailed description:
--------------------------
Run ut2004, unexpected colors on default gun.
Reproduce steps:
----------------
1 xinit &
2 ut2004
Comment 1 lin, jiewen 2008-09-22 00:29:48 UTC
Created attachment 19084 [details]
Xorg.0.log
Comment 2 lin, jiewen 2008-09-22 00:44:18 UTC
965 also have this issue.
Comment 3 Guillaume Melquiond 2008-09-22 01:05:54 UTC
I don't have UT2004 and you haven't posted screenshots, so I can't tell whether it is the same bug or not. But since you are talking about "unexpected colors", perhaps it is bug #16520.
Comment 4 lin, jiewen 2008-09-22 01:16:28 UTC
965 also have this issue.
Comment 5 lin, jiewen 2008-09-22 02:06:26 UTC
(In reply to comment #3)
> I don't have UT2004 and you haven't posted screenshots, so I can't tell whether
> it is the same bug or not. But since you are talking about "unexpected colors",
> perhaps it is bug #16520.
> 

Yes, They have the same phenomenon.
Comment 6 Gordon Jin 2008-09-22 02:23:35 UTC

*** This bug has been marked as a duplicate of bug 16520 ***
Comment 7 Gordon Jin 2008-12-23 23:07:38 UTC
bug#16520 has been fixed, but this one (ut2004) not. So not dup.
Comment 8 Gordon Jin 2008-12-23 23:09:00 UTC
This still exists in the latest code (mesa master).
Comment 9 Tobias Jakobi 2008-12-24 09:37:01 UTC
Hi there,

like I stated in the now closed bug #16520 I can still see the black weapon model issue with latest mesa git master and my Intel i915 chipset.

Greets,
Tobias
Comment 10 haihao 2008-12-28 17:37:44 UTC
fixed in mesa

commit 0674a238547f9f4f9de9c6cf5d72015e5960aa9e
Author: Xiang, Haihao <haihao.xiang@intel.com>
Date:   Mon Dec 29 09:30:41 2008 +0800

    intel: enable ATI_texture_env_combine3. Fixes #17707
Comment 11 lin, jiewen 2008-12-28 18:37:24 UTC
(In reply to comment #10)
> fixed in mesa
> 
> commit 0674a238547f9f4f9de9c6cf5d72015e5960aa9e
> Author: Xiang, Haihao <haihao.xiang@intel.com>
> Date:   Mon Dec 29 09:30:41 2008 +0800
> 
>     intel: enable ATI_texture_env_combine3. Fixes #17707
> 
It is fixed in master branch, when will  the commit 0674a238547f9f4f9de9c6cf5d72015e5960aa9e be added into q4-branch? 
Comment 12 Ian Romanick 2009-01-05 09:00:54 UTC
Why does adding support for an uncommon, optional extension fix this bug?  Please explain.
Comment 13 haihao 2009-01-05 17:14:45 UTC
With gdb's analysis, unit 2 is activated to render the weapon, but without  ATI_texture_env_combine3 support, this unit is disabled indeed. I think unit 2 should use some combiner operations which are provided by ATI_texture_env_combine3  when rendering the weapon.
Comment 14 haihao 2009-01-05 17:39:13 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > fixed in mesa
> > 
> > commit 0674a238547f9f4f9de9c6cf5d72015e5960aa9e
> > Author: Xiang, Haihao <haihao.xiang@intel.com>
> > Date:   Mon Dec 29 09:30:41 2008 +0800
> > 
> >     intel: enable ATI_texture_env_combine3. Fixes #17707
> > 
> It is fixed in master branch, when will  the commit
> 0674a238547f9f4f9de9c6cf5d72015e5960aa9e be added into q4-branch? 
> 

cherry-picked.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.