Bug 17937 - [regression] screen flickers while loading X, running xrandr or playing a video (i915)
Summary: [regression] screen flickers while loading X, running xrandr or playing a vid...
Status: RESOLVED DUPLICATE of bug 17405
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.4 (2008.09)
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Gordon Jin
QA Contact: Xorg Project Team
URL: https://bugs.launchpad.net/ubuntu/+so...
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2008-10-06 23:30 UTC by unggnu
Modified: 2008-10-07 06:22 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (39.11 KB, text/plain)
2008-10-06 23:30 UTC, unggnu
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description unggnu 2008-10-06 23:30:37 UTC
Created attachment 19423 [details]
Xorg.0.log

After gdm login, running xrandr or opening a video screen flickers heavily. Mostly black lines are shown in the center on boot or after running xrandr and mirrored artifacts of the screen if a video is loaded. After resolution change the whole screen flickers for several seconds.
Opengl apps like glxgears doesn't seem to be affected.
It happens at least with intel driver version 2.4.0 and current 2.4.1-1ubuntu6
2.3.1 and older revisions doesn't have this problem.

Os: Ubuntu Intrepid 8.04
Driver: 2.4.1-1ubuntu6
Kernel: 2.6.27.5.5
Xorg: 1.5.1

Video of gdm login: http://launchpadlibrarian.net/18218614/gdm_login.ogv
lspci: http://launchpadlibrarian.net/18218132/LsPci.txt
xrandr: http://launchpadlibrarian.net/18218135/Xrandr.txt
Comment 1 Gordon Jin 2008-10-07 06:22:20 UTC
this 2.4 issue should be dup with bug#17405.

*** This bug has been marked as a duplicate of bug 17405 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.