Bug 18062 - [965 GEM] VT->X (and resuming from suspend) with compiz running locks machine, on Fedora Rawhide
Summary: [965 GEM] VT->X (and resuming from suspend) with compiz running locks machine...
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: Other All
: high critical
Assignee: Eric Anholt
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 18098 18841
  Show dependency treegraph
 
Reported: 2008-10-14 07:23 UTC by Ben Gamari
Modified: 2008-12-21 22:23 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg log (90.28 KB, text/plain)
2008-10-14 07:23 UTC, Ben Gamari
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Gamari 2008-10-14 07:23:12 UTC
Created attachment 19652 [details]
Xorg log

Recently, I've finally been able to start running compiz on my Fedora Rawhide machine. Unfortunately it seems like the machine has a pretty consistent tendency to lock up during resume after suspending with compiz running. Generally, the machine freezes with a black screen and cursor, sometimes with some spotty colorful corruption near the cursor. Suspend and resume are otherwise 100% reliable without compiz.

Hardware configuration:
Dell D830, i965 GM, Core 2 Duo

Software configuration:
64-bit userland and kernel

xf86-video-intel from git master
mesa-7.2-0.7.fc10
kernel-2.6.27-3.fc10
libdrm-2.4.0-0.21.fc10
xorg-x11-server-Xorg-1.5.2-2.fc10
Comment 1 Ben Gamari 2008-10-14 07:30:07 UTC
Not surprisingly, this lockup can also be reproduced with a VT switch. The machine locks up with frozen cursor and no keyboard input (no lights toggle) although one can still see occasional hard drive activity, so the kernel is still alive. I'll try getting a backtrace soon
Comment 2 Gordon Jin 2008-10-14 18:28:27 UTC
I'm wondering if this is redhat-kernel-specific issue. Could you try an upstream kernel like 2.6.27-rcX?
Comment 3 Ben Gamari 2008-10-14 18:31:22 UTC
Note that the Rawhide kernels now include GEM support. Did you try a GEM capable kernel? It seems quite possible that this issue could be a result of GEM.
Comment 4 liuhaien 2008-10-14 22:54:18 UTC
I also can  see this issue on our q965 with gem-classic. the kernel is from drm-intel-next. 
Comment 5 Ben Gamari 2008-10-15 17:51:51 UTC
As it turns out, even starting metacity prior to suspending and resuming causes a crash when restarting compiz. Just another datapoint.
Comment 6 Gordon Jin 2008-10-16 22:41:23 UTC
We filed a similar bug#18098 with drm-intel-next kernel.
Comment 7 Will Woods 2008-11-02 18:54:16 UTC
I appear to have the same problem (or at least a closely related one - it's on i915 instead of i965). Resume/VT switch on my laptop causes a black, non-responsive display. Interestingly, it *sometimes* recovers. At that point there is an interesting traceback:

[mi] EQ overflowing. The server is probably stuck in an infinite loop.

Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x3b) [0x812b94b]
1: /usr/bin/Xorg(mieqEnqueue+0x289) [0x810b069]
2: /usr/bin/Xorg(xf86PostMotionEventP+0xc2) [0x80d3892]
3: /usr/bin/Xorg(xf86PostMotionEvent+0x68) [0x80d39f8]
4: /usr/lib/xorg/modules/input//synaptics_drv.so [0x4ba8fe]
5: /usr/lib/xorg/modules/input//synaptics_drv.so [0x4bcf79]
6: /usr/bin/Xorg [0x80bfaa7]
7: /usr/bin/Xorg [0x80aa22e]
8: [0x110400]
9: [0x110416]
10: /lib/libc.so.6(ioctl+0x19) [0x294939]
11: /usr/lib/libdrm.so.2 [0x47e26cf]
12: /usr/lib/libdrm.so.2(drmWaitVBlank+0x28) [0x47e2e08]
13: /usr/lib/dri/i915_dri.so [0x5c59dc]
14: /usr/lib/dri/i915_dri.so(driWaitForVBlank+0xd8) [0x5c5bfc]
15: /usr/lib/dri/i915_dri.so(intelSwapBuffers+0x262) [0x5d519c]
16: /usr/lib/dri/i915_dri.so [0x5c5d76]
17: /usr/lib/xorg/modules/extensions//libglx.so [0x470454]
18: /usr/lib/xorg/modules/extensions//libglx.so [0x462cfe]
19: /usr/lib/xorg/modules/extensions//libglx.so [0x46663a]
20: /usr/bin/Xorg(Dispatch+0x34f) [0x8085e6f]
21: /usr/bin/Xorg(main+0x47d) [0x806b6ed]
22: /lib/libc.so.6(__libc_start_main+0xe5) [0x1cf6d5]
23: /usr/bin/Xorg [0x806aad1]
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnequeue: out-of-order valuator event; dropping.

I can reproduce the problem with vanilla (non-Fedora) kernel 2.6.28-rc2-git7, so it's not RH-specific.

Further info (including my Xorg log) can be found at the downstream bug: https://bugzilla.redhat.com/show_bug.cgi?id=467332
Comment 8 Ben Gamari 2008-11-07 16:54:50 UTC
One of the Redhat guys noted that the symptoms of this bug match remarkably well with those of another redhat bug, https://bugzilla.redhat.com/show_bug.cgi?id=464866#c10. 
Comment 9 Gordon Jin 2008-12-02 22:55:07 UTC
Eric, are you seeing this? I thought a recent fix from keithp is against this, but seems not?
Comment 10 Gordon Jin 2008-12-04 00:55:33 UTC
Per bug#18879 comment#1, this bug has been fixed in Fedora, and re-appears now in git. So I guess we can close this one and track 18879?
Comment 11 liuhaien 2008-12-21 21:46:08 UTC
it still exists with the latest code:
Libdrm:		(master)0243c9f801a35de3465a0321c02f18a4d07ce5b8
Mesa:		(intel-2008-q4)f96baeaac3ef41260ac3975750627ece073fdce0
Xserver:(server-1.6-branch)32e81074b967716865aef08b66ec29caf0fec2c5
Xf86_video_intel:		(xf86-video-intel-2.6-branch)
                           83f3c376b5942e134047a220e6e5f2432ffc492c
GEM_kernel:       (for-airlied)0fbdb7c9455a05eb89f358f0eb66fb8ab094a0c5

Comment 12 liuhaien 2008-12-21 22:23:50 UTC
sorry,this bug has been fixed in Fedora, so let us track 18879.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.