Bug 18092 - [nv] GeForce 8200 and 8300 not supported (10de:0848/0849/C77/MCP77/MCP78S)
[nv] GeForce 8200 and 8300 not supported (10de:0848/0849/C77/MCP77/MCP78S)
Status: RESOLVED FIXED
Product: xorg
Classification: Unclassified
Component: Driver/nVidia (open)
7.4 (2008.09)
x86-64 (AMD64) Linux (All)
: medium normal
Assigned To: Aaron Plattner
Xorg Project Team
:
: 17526 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-16 11:28 UTC by Sebastian Brandt
Modified: 2010-03-08 16:25 UTC (History)
3 users (show)

See Also:


Attachments
Xorg log with open-source nVidia driver (7.4 on opensuse 11.0) (14.00 KB, text/plain)
2008-10-16 11:28 UTC, Sebastian Brandt
no flags Details
Xorg log with patched nv driver, NoAccel, works (-logverbose 9) (34.29 KB, text/plain)
2008-10-16 12:55 UTC, Sebastian Brandt
no flags Details
Xorg log with patched nv driver, with XAA, hangs (-logverbose 9) (32.50 KB, text/plain)
2008-10-16 13:10 UTC, Sebastian Brandt
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Brandt 2008-10-16 11:28:09 UTC
The GeForce 8300 graphics chip is not supported by the open source nVidia driver of the current (7.4) xorg release. 

The 8300 is only available as OEM/on board, e.g., on the ASUS M3N/H-HDMI mainboard.
lscpi: 02:00.0 VGA compatible controller: nVidia Corporation Device 0848 (rev a2)
lspci -n: 02:00.0 0300: 10de:0848 (rev a2)
http://pci-ids.ucw.cz/read/PC/10de/0848 

According to http://en.wikipedia.org/wiki/GeForce_8_Series#Geforce_8300_and_8400, it has a G86 core.

NVidia proprietary driver supports it, of course (since at least 173.14.05)
(II) NVIDIA(0): NVIDIA GPU GeForce 8300 (C77) at PCI:2:0:0 (GPU-0)

Excerpt from Xorg-log with open-source nVidia:
[complete log attached]
X.Org X Server 1.5.2
Release Date: 10 October 2008
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux aluro 2.6.25.16-0.1-default #1 SMP 2008-08-21 00:34:25 +0200 x86_64
Build Date: 13 October 2008  04:47:51PM
[...]
(II) Primary Device is: PCI 02@00:00:0
(WW) NV: Ignoring unsupported device 0x10de0848 at 02@00:00:0

I installed the xorg 7.4 from http://download.opensuse.org/repositories/X11:/XOrg/openSUSE_11.0/ and expected it to support more nVidia devices than the 7.3 version ... unfortunately, it doesn't.
Comment 1 Sebastian Brandt 2008-10-16 11:28:53 UTC
Created attachment 19694 [details]
Xorg log with open-source nVidia driver (7.4 on opensuse 11.0)
Comment 2 Sebastian Brandt 2008-10-16 12:53:12 UTC
Patched nv_driver.c to get the card to work w/o acceleration, at least ... though I'm not sure whether this gives any advantage over VESA ;-)

The only thing needed is to add the (masked) PCI ID of the card to the 
  static Bool
  NVIsG80(int chipType)
function in nv_driver.c:

        case 0x06f0:
//added in line 804:
        case 0x0840:
            return TRUE;

AND to set Option "NoAccel" "true" in the xorg.conf driver section.

If the NoAccel is left out, the log appears the same; the "only" difference is that the screen is half black, half patterned. 
Ctrl+Alt+Backspace does not work then, nor does console switch. Remote login, then kill -9 XOrg , then chvt works to get the system usable again. Normal kill or chvt w/o kill does not help.
Comment 3 Sebastian Brandt 2008-10-16 12:55:47 UTC
Created attachment 19698 [details]
Xorg log with patched nv driver, NoAccel, works (-logverbose 9)
Comment 4 Sebastian Brandt 2008-10-16 13:10:55 UTC
Created attachment 19700 [details]
Xorg log with patched nv driver, with XAA, hangs (-logverbose 9)

This is a log which did not work ... apart from the NoAccel/XAA stuff, no obvious differences to the one before.
For the moment, I switch back to VESA, as VESA is by far faster than nVidia/OS w/o XAA ... and, for much stuff, even faster than NVidia/closed source ...
Comment 5 Vedran Miletić 2009-09-05 15:51:58 UTC

*** This bug has been marked as a duplicate of bug 18286 ***
Comment 6 Vedran Miletić 2009-09-05 16:12:26 UTC
Sorry, didn't notice this was nv, not nouveau.
Comment 7 Vedran Miletić 2009-09-05 16:12:49 UTC
*** Bug 17526 has been marked as a duplicate of this bug. ***
Comment 8 Aaron Plattner 2010-03-08 16:25:22 UTC
Please try version 2.1.17.