Bug 18145 - [gem-classic] running ut2004/celestia/torcs for a few mins hangs X with waiting for fence error
Summary: [gem-classic] running ut2004/celestia/torcs for a few mins hangs X with waiti...
Status: VERIFIED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: haihao
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: intel-mesa-blocker
  Show dependency treegraph
 
Reported: 2008-10-21 02:26 UTC by lin, jiewen
Modified: 2008-11-10 00:52 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xorg conf file (3.63 KB, text/plain)
2008-10-21 02:26 UTC, lin, jiewen
Details
xorg.0,log (81.96 KB, text/plain)
2008-10-21 02:32 UTC, lin, jiewen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lin, jiewen 2008-10-21 02:26:05 UTC
System Environment:
--------------------------

--Platform: gm45
--Architecture(32-bit,64-bit,compatiblity): 32-bit
--2D driver: xf86-video-intel-2.5-branch  0135a49ec96ca311d0673a4d924b63fe4a921e37
--3D driver: intel-2008-q3 branch 46921a5ee832a3443894dcc98e065d2f535e899d
--DRM:shipped with kernel 2.6.27stolen-mem
--libdrm: master branch  a59ea02ff839fa0801763a90beb8b232b933c746
--Xserver: 1.5.2
--Kernel: 2.6.27stolen-mem

Bug detailed description:
--------------------------
Start X and run ut2004 for several minutes.X crashes with error messages:
intel_bufmgr_fake.c:392: Error waiting for fence: Device or resource busy.
Signal: SIGIOT [iot trap]
Aborting.
Crash information will be saved to your logfile

Reproduce steps:
----------------
1. xinit &
2. ut2004
Comment 1 lin, jiewen 2008-10-21 02:26:40 UTC
Created attachment 19779 [details]
xorg conf file
Comment 2 lin, jiewen 2008-10-21 02:32:39 UTC
Created attachment 19780 [details]
xorg.0,log
Comment 3 lin, jiewen 2008-10-21 20:09:57 UTC
This bug also happened when ran celestia with starting the desktop.The failure message is"intel_bufmgr_fake.c:392: Error waiting for fence: Device or resource busy.Aborting" . But it work well with nude X.(steps: xinit& ; celestia)
Comment 4 Gordon Jin 2008-10-22 00:42:15 UTC
This happens on all of machines we tested: G45, GM45, GM965, Q965, 945GM.
It seems running with nude X may delay the triggered time.
Comment 5 Gordon Jin 2008-10-23 22:49:03 UTC
This works fine with mesa_7_2_branch.
Comment 6 haihao 2008-10-24 01:45:43 UTC
Seems it works fine if setting EXANoComposite to true in xorg.conf.
Comment 7 lin, jiewen 2008-10-26 21:54:58 UTC
(In reply to comment #6)
> Seems it works fine if setting EXANoComposite to true in xorg.conf.
> 

Yes, Haien have tried this, it worked well.
Comment 8 lin, jiewen 2008-10-28 02:25:05 UTC
But , with gem, setting EXANoComposite to true in xorg.conf just make the game run further ,it hangs X at last.(about 40 minutes)
Comment 9 Gordon Jin 2008-10-28 19:00:43 UTC
(In reply to comment #8)
> But , with gem, setting EXANoComposite to true in xorg.conf just make the game
> run further ,it hangs X at last.(about 40 minutes)

Jiewen, please file a separate bug for GEM, since the logs and components are different. 

Comment 10 lin, jiewen 2008-11-10 00:50:38 UTC
With gem, the are a new bug https://bugs.freedesktop.org/show_bug.cgi?id=18145 which is "games hang X" issue. 
Comment 11 lin, jiewen 2008-11-10 00:52:02 UTC
With gem, the are a new bug https://bugs.freedesktop.org/show_bug.cgi?id=18380
which is "games hang X" issue. 


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.