Bug 18240 - can't include poppler when building with GDK_DISABLE_SINGLE_INCLUDES
can't include poppler when building with GDK_DISABLE_SINGLE_INCLUDES
Status: RESOLVED FIXED
Product: poppler
Classification: Unclassified
Component: glib frontend
unspecified
Other All
: high major
Assigned To: poppler-bugs
:
: 18925 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-27 03:50 UTC by Christian Persch (GNOME)
Modified: 2008-12-13 08:26 UTC (History)
2 users (show)

See Also:


Attachments
patch (327 bytes, patch)
2008-10-27 03:51 UTC, Christian Persch (GNOME)
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Persch (GNOME) 2008-10-27 03:50:02 UTC
poppler-page.h should only include gdk/gdk.h directly.
Comment 1 Christian Persch (GNOME) 2008-10-27 03:51:23 UTC
Created attachment 19878 [details] [review]
patch
Comment 2 Albert Astals Cid 2008-10-27 16:31:37 UTC
Carlos?
Comment 3 Carlos Garcia Campos 2008-10-28 02:37:48 UTC
Pushed, thanks Christian!
Comment 4 Carlos Garcia Campos 2008-12-12 04:56:38 UTC
*** Bug 18925 has been marked as a duplicate of this bug. ***
Comment 5 Carlos Garcia Campos 2008-12-13 08:26:26 UTC
*** Bug 18925 has been marked as a duplicate of this bug. ***