Bug 18256 - [gem gm45]wrong minimap display in torcs
[gem gm45]wrong minimap display in torcs
Status: VERIFIED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
unspecified
x86 (IA32) Linux (All)
: medium normal
Assigned To: Eric Anholt
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-28 00:27 UTC by lin, jiewen
Modified: 2009-12-14 23:23 UTC (History)
0 users

See Also:


Attachments
xorg.conf (3.67 KB, text/plain)
2008-10-28 00:27 UTC, lin, jiewen
Details
log (81.42 KB, text/plain)
2008-10-28 00:28 UTC, lin, jiewen
Details
comparision (563.14 KB, image/png)
2008-10-28 00:30 UTC, lin, jiewen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lin, jiewen 2008-10-28 00:27:27 UTC
Created attachment 19894 [details]
xorg.conf

System Environment:
--------------------------

--Platform: gm45
--Architecture(32-bit,64-bit,compatiblity): 32-bit
--2D driver: (master)87ea531c5dc5b39809395b277c330854aaaaf019
--3D driver: intel-2008-q3 branch 46921a5ee832a3443894dcc98e065d2f535e899d
--DRM:shipped with kernel 2.6.27stolen-mem
--libdrm: (master)1d930fc75b99a89fc77d35d8f95f2877cfd5d7f0
--Xserver: (master)102c4dac7c521941f52652152b1660cd7f559d56
--Kernel: 2.6.27-rc9(drm-intel-next)af1f46ebc03f4eab533e7a695d836ad9f255bf49 

Bug detailed description:
--------------------------
Start X and play torcs, the minimap top right corner displays fragmentarily.See the attachment"comparision" to see clearly.
Reproduce steps:
----------------
1. xinit &
2. torcs
Comment 1 lin, jiewen 2008-10-28 00:28:12 UTC
Created attachment 19895 [details]
log
Comment 2 lin, jiewen 2008-10-28 00:30:10 UTC
Created attachment 19896 [details]
comparision
Comment 3 lin, jiewen 2008-10-28 00:46:24 UTC
This issue doesn't happen on q965 and 945gm.
Comment 4 lin, jiewen 2008-10-28 02:03:29 UTC
Correct the System Environment:


System Environment:
--------------------------

--Platform: gm45
--Architecture(32-bit,64-bit,compatiblity): 32-bit
--2D driver: (master)87ea531c5dc5b39809395b277c330854aaaaf019
--3D driver: (master)2a877411dbe35abdd8c15fb4821d9232619d89cc
--DRM:shipped with kernel 2.6.27-rc9(drm-intel-next)
--libdrm: (master)1d930fc75b99a89fc77d35d8f95f2877cfd5d7f0
--Xserver: (master)102c4dac7c521941f52652152b1660cd7f559d56
--Kernel: 2.6.27-rc9(drm-intel-next)af1f46ebc03f4eab533e7a695d836ad9f255bf49 

Comment 5 lin, jiewen 2008-12-08 23:54:58 UTC
Still exists with current code.some maps can not see the road map on the minimap, some maps can not see the all points which indicate cars on the road map.
Comment 6 Eric Anholt 2008-12-18 09:23:44 UTC
the minimap is produced with glReadPixels.

*** This bug has been marked as a duplicate of bug 18586 ***
Comment 7 Gordon Jin 2008-12-21 05:47:34 UTC
Jiewen, I think this bug is reproduced on HP GM45 (with glReadPixels pass), while bug#18586 is reproduced on Sony GM45 (with glReadPixels fail), so this shouldn't be dup, right?
Comment 8 lin, jiewen 2008-12-21 18:12:21 UTC
Yes, they should not be the same.
Comment 9 lin, jiewen 2008-12-26 02:39:46 UTC
G45 64bit also has this issue.
Comment 10 lin, jiewen 2008-12-28 21:33:29 UTC
(In reply to comment #9)
> G45 64bit also has this issue.
> 

(In reply to comment #9)
> G45 64bit also has this issue.
> 
The issue(fragmentary minimap) on G45 64bit is caused by bug 19317.
Comment 11 Eric Anholt 2009-01-07 02:06:29 UTC
I can't reproduce this on any systems without readpix demo failure.  I still believe this is a dupe of those bug reports.
Comment 12 Eric Anholt 2009-12-09 15:55:42 UTC
This should be fixed now that the other readpixels issues are fixed.
Comment 13 fangxun 2009-12-14 23:23:42 UTC
Verified with current driver.