Bug 18259 - Xorg 7.4 with xfs breaks GTK+ 1.2 applications, such as Xdialog
Xorg 7.4 with xfs breaks GTK+ 1.2 applications, such as Xdialog
Status: RESOLVED FIXED
Product: xorg
Classification: Unclassified
Component: Server/General
7.4 (2008.09)
Other All
: medium normal
Assigned To: Xorg Project Team
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-28 00:45 UTC by Peter Åstrand
Modified: 2009-06-09 16:18 UTC (History)
0 users

See Also:


Attachments
Screenshot of GTK+ calendar example with xfs fontpath (1.62 KB, image/png)
2008-10-28 00:47 UTC, Peter Åstrand
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Åstrand 2008-10-28 00:45:07 UTC
We have discovered that Xorg 7.4 does not work correctly when using xfs. For example, the GTK+ 1.2 function gdk_string_extent() returns a zero width with a font that normally works. This problem is visible with the Xdialog application, which crashes with "Floating point exception" on startup. Here's how to reproduce this on Fedora 9:

* Install xorg-x11-xfs and start it. 
* Install xdialog. 
* In the X session, run Xdialog-gtk1 and verify that you can see the help screen. 
* Change the fontpath to use xfs: xset fp= unix/:7100
* Run Xdialog-gtk1, which now crashes with "Floating point exception". 

All updates installed. We have also been able to verify this problem with our own Xvnc compiled with the Xorg 7.4 sources, against xfs running on Fedora Core 6. The problem has also been verified on the latest Fedora Rawhide. 

I've also been able to verify the problem with the GTK+ "calendar" demo application, located in /usr/share/doc/gtk+-devel-1.2.10/examples/calendar on F9.
Comment 1 Peter Åstrand 2008-10-28 00:47:13 UTC
Created attachment 19897 [details]
Screenshot of GTK+ calendar example with xfs fontpath
Comment 2 Peter Åstrand 2008-11-21 00:47:05 UTC
It turns out that this bug is actually the same as https://bugzilla.redhat.com/show_bug.cgi?id=430416. The patch in http://lists.freedesktop.org/archives/xorg/2008-August/037554.html works fine. 
Comment 3 Alan Coopersmith 2009-06-09 16:18:29 UTC
(In reply to comment #2)
> It turns out that this bug is actually the same as
> https://bugzilla.redhat.com/show_bug.cgi?id=430416. The patch in
> http://lists.freedesktop.org/archives/xorg/2008-August/037554.html works fine. 
> 

Closing since that patch is now applied in git master:
http://cgit.freedesktop.org/xorg/xserver/commit/?id=f8dd80d13bb5313a11b38b280f8ad3e22f0a6300