Bug 18283 - [855gm GEM]black screen when start Xorg
Summary: [855gm GEM]black screen when start Xorg
Status: VERIFIED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: high blocker
Assignee: Eric Anholt
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
: 18560 (view as bug list)
Depends on:
Blocks: 17963
  Show dependency treegraph
 
Reported: 2008-10-28 18:27 UTC by liuhaien
Modified: 2009-01-06 18:05 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg.0.log (42.70 KB, text/plain)
2008-10-28 18:27 UTC, liuhaien
no flags Details
xorg conf file (3.66 KB, text/plain)
2008-10-28 18:29 UTC, liuhaien
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description liuhaien 2008-10-28 18:27:45 UTC
Created attachment 19922 [details]
xorg.0.log

System Environment:
--------------------------
--Platform: 855gm
--Architecture(32-bit,64-bit,compatiblity): 32bit
Mesa:           (master)2a877411dbe35abdd8c15fb4821d9232619d89cc
Xserver:                (master)102c4dac7c521941f52652152b1660cd7f559d56
Xf86_video_intel:              
(master)87ea531c5dc5b39809395b277c330854aaaaf019
libdrm:(master)e47ab7a5081e178bad385ce2e75b01474ea7aa4c
Kernel_gem:            
(drm-intel-next)43f7ccc48dd7587983cfe16de578042a7ad3a9b3

Bug detailed description:
--------------------------
start X with GEM,it will display nothing but a black screen.dmesg show errors:
-----------------------
[drm:i915_driver_load] *ERROR* failed to enable MSI
[drm] Initialized i915 1.6.0 20080730 on minor 1

Reproduce steps:
----------------
X&
Comment 1 liuhaien 2008-10-28 18:29:27 UTC
Created attachment 19923 [details]
xorg conf file
Comment 2 liuhaien 2008-10-28 19:34:42 UTC
and there is no response when run xterm and other applications.
Comment 3 Eric Anholt 2008-11-24 18:32:04 UTC
commit afa21e0584f78964c092981fad94e45d38cda249
Author: Dave Airlie <airlied@linux.ie>
Date:   Tue Nov 11 18:02:12 2008 +1000

    drm/i915: Filter pci devices based on PCI_CLASS_DISPLAY_VGA

was the fix based on the fix I wrote for the problem.
Comment 4 liuhaien 2008-11-25 22:50:31 UTC
verified.
Comment 5 Eric Anholt 2009-01-06 18:05:20 UTC
*** Bug 18560 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.