Bug 18287 - [GEM]some glean cases run failed such as api2,pixelFormats
[GEM]some glean cases run failed such as api2,pixelFormats
Status: VERIFIED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
unspecified
Other Linux (All)
: high normal
Assigned To: Eric Anholt
:
Depends on:
Blocks: 18841 intel-3d-release
  Show dependency treegraph
 
Reported: 2008-10-29 02:22 UTC by liuhaien
Modified: 2009-06-11 01:57 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xorg.0.log (46.42 KB, text/plain)
2008-10-29 02:22 UTC, liuhaien
Details
xorg conf file (3.57 KB, text/plain)
2008-10-29 02:23 UTC, liuhaien
Details

Note You need to log in before you can comment on or make changes to this bug.
Description liuhaien 2008-10-29 02:22:49 UTC
Created attachment 19927 [details]
xorg.0.log

System Environment:
--------------------------

--Platform:915 965

--Architecture(32-bit,64-bit,compatiblity):32bit 

Kernel:		2.6.27-rc9
Mesa:		(master)bcfba0d91e51290b1a957a1861ec0b18899feb92
Xserver:		(master)102c4dac7c521941f52652152b1660cd7f559d56
Xf86_video_intel:		(master)87ea531c5dc5b39809395b277c330854aaaaf019
libdrm: master e47ab7a5081e178bad385ce2e75b01474ea7aa4c



Bug detailed description:
-------------------------
startx ,run glean cases, for Q965, some cases run failed such as api2,fragProg1,pixelFormats,texCombine





Current result:
----------------
many cases run failed 


Expected result:
----------------
run normally
Comment 1 liuhaien 2008-10-29 02:23:15 UTC
Created attachment 19928 [details]
xorg conf file
Comment 2 liuhaien 2008-10-29 02:23:52 UTC
GEM_kernel:       (drm-intel-next)af1f46ebc03f4eab533e7a695d836ad9f255bf49
Comment 3 Gordon Jin 2008-10-29 02:28:36 UTC
This may be recent regression in GEM kernel.
Comment 4 Shuang He 2008-10-29 02:38:08 UTC
(In reply to comment #3)
> This may be recent regression in GEM kernel.
> 

should be regression in mesa
at least with mesa commit e7002694418cd0decb1cd0d9121f634480e5f0d6, fragProg1 passed
Comment 5 Eric Anholt 2008-10-31 16:37:52 UTC
We haven't been on rc9 kernel for a couple of weeks, yet you claim to be on a GEM kernel.  Are you not tracking the right branch or something?  Also, this should be bisectable if it's new since the commit you mentioned, and that should be done.
Comment 6 Eric Anholt 2008-11-03 15:04:46 UTC
The following kernel change may also be relevant.

commit 3bae6ff2f4c2869bddfa1f735d1bf58cfd20006a
Author: Owen Taylor <otaylor@redhat.com>
Date:   Mon Nov 3 14:38:17 2008 -0800

    i915: Don't attempt to short-circuit object_wait_rendering by checking domains.
    
    This could return early when reading after writing a buffer, if somebody
    had already put it on the flushing list (write domains are 0, but still
    active), leading to glReadPixels failure.
    
    Signed-off-by: Eric Anholt <eric@anholt.net>
Comment 7 lin, jiewen 2008-11-03 23:00:27 UTC
We bisect the mesa, this issue still exists.

(In reply to comment #6)
> The following kernel change may also be relevant.
> 
> commit 3bae6ff2f4c2869bddfa1f735d1bf58cfd20006a
> Author: Owen Taylor <otaylor@redhat.com>
> Date:   Mon Nov 3 14:38:17 2008 -0800
> 
>     i915: Don't attempt to short-circuit object_wait_rendering by checking
> domains.
> 
>     This could return early when reading after writing a buffer, if somebody
>     had already put it on the flushing list (write domains are 0, but still
>     active), leading to glReadPixels failure.
> 
>     Signed-off-by: Eric Anholt <eric@anholt.net>
> 


We bisect to the commit before 3bae6ff2f4c2869bddfa1f735d1bf58cfd20006a, the issue still exsit.
There are some "good commits " days before ,but we can find them in the drm-intel-next branch now,they are gone.So we can not bisect kernel without "good  commit".
Comment 8 liuhaien 2009-03-22 19:02:48 UTC
fragProg1 works now, but api2 and pixelformats still fail against:
Libdrm:		(master)00d8e960ca665b7f0528438331f4d0ae77fbb4cc
Mesa:(mesa_7_4_branch)b009a32bf428192fef2dc4787d25f022a472854f		
Xserver:	(server-1.6-branch)60c161545af80eb78eb790a05bde79409dfdf16e
Xf86_video_intel:	(2.7)e2465249a90b9aefe6d7a96eb56a51fde54698a0
Kernel:       (for-airlied)a2e785c32b886dd7f0289d1cf15fc14e9c81bc01
Comment 9 Eric Anholt 2009-04-14 15:03:58 UTC
As with other basic conformance test failures, this bug needs information about mesa readpix demo results (and if that fails, it needs to be closed and a new bug opened about the real problem).
Comment 10 Gordon Jin 2009-04-15 01:04:36 UTC
(In reply to comment #9)
> As with other basic conformance test failures, this bug needs information about
> mesa readpix demo results (and if that fails, it needs to be closed and a new
> bug opened about the real problem).

This bug happens on all of our platforms, including those with readpix pass.

Actually we've stopped conformance testing on those machines (Sony GM45, 915GV, 855GM) suffered by readpix, so we don't file conformance test bugs on those machines now.
Comment 11 Gordon Jin 2009-06-09 11:52:38 UTC
Haien, the nightly test result repository shows these 2 cases passed since May 15th. Can you confirm?

I would be so happy to close this one if that's true.
Comment 12 liuhaien 2009-06-11 01:49:00 UTC
(In reply to comment #11)
> Haien, the nightly test result repository shows these 2 cases passed since May
> 15th. Can you confirm?
> 
> I would be so happy to close this one if that's true.
> 

yes, they work well now, I think we can close it.
Comment 13 liuhaien 2009-06-11 01:57:34 UTC
verified with below commits:
Libdrm:		(master)3d4bfe8c893d016ef43d1ebf28e4607aa1f540a4
Mesa:		(mesa_7_5_branch)cfff2a6189b38f1ee8c8ca204e223574a5abf760
Xserver:		(server-1.6-branch)5cd5a01259ba349f1868ca4af04207cf120d69e4
Xf86_video_intel:		(master)66ceedc0cc123e5c9f85f708b2e56d943f00e4b9
Kernel:     (for-linus)0e7ddf7eeeef5aea85412120539ab5369577faeb