Bug 18486 - Internal Error
Internal Error
Status: RESOLVED INVALID
Product: PackageKit
Classification: Unclassified
Component: core
unspecified
Other All
: medium normal
Assigned To: Richard Hughes
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-11 12:57 UTC by Mohammad Khan
Modified: 2012-01-05 10:00 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mohammad Khan 2008-11-11 12:57:20 UTC
Error Type: <type 'exceptions.IOError'>
Error Value: [Errno 116] Stale NFS file handle: '//var/cache/yum/updates-newkey/primary.sqlite'
  File : /usr/share/PackageKit/helpers/yum/search-name.py , line 21, in <module>
    backend.search_name(options,searchterms)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 441, in search_name
    self._do_search(searchlist,filters,key)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 226, in wrapper
    func(*args,**kwargs)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 323, in _do_search
    for (pkg,values) in res:
  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 1586, in searchGenerator
    for sack in self.pkgSack.sacks.values():
  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 591, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 434, in _getSacks
    self.repos.populateSack(which=repos)
  File : /usr/lib/python2.5/site-packages/yum/repos.py , line 251, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File : /usr/lib/python2.5/site-packages/yum/yumRepo.py , line 171, in populate
    misc.bunzipFile(db_fn, db_un_fn)
  File : /usr/lib/python2.5/site-packages/yum/misc.py , line 514, in bunzipFile
    destination = open(dest, 'w')
Comment 1 Morgan Olausson 2008-12-03 08:40:55 UTC
I think this is something similar.
This happened during automatic update:



Error Type: <type 'exceptions.IndexError'>
Error Value: list index out of range
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2202, in <module>
    main()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2199, in main
    backend.dispatcher(sys.argv[1:])
  File : /usr/lib/python2.5/site-packages/packagekit/backend.py, line 610, in dispatcher
    self.dispatch_command(args[0], args[1:])
  File : /usr/lib/python2.5/site-packages/packagekit/backend.py, line 577, in dispatch_command
    self.update_system()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1099, in update_system
    txmbr = self.yumbase.update() # Add all updates to Transaction
  File : /usr/lib/python2.5/site-packages/yum/__init__.py, line 2542, in update
    updated_pkg = self.rpmdb.searchPkgTuple(old)[0]
Comment 2 Morgan Olausson 2008-12-03 08:49:05 UTC
I missed this second errorprintout that came at the same time.

Error Type: &lt;type &apos;exceptions.IndexError&apos;&gt;
Error Value: list index out of range
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2202, in &lt;module&gt;
    main()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2199, in main
    backend.dispatcher(sys.argv[1:])
  File : /usr/lib/python2.5/site-packages/packagekit/backend.py, line 610, in dispatcher
    self.dispatch_command(args[0], args[1:])
  File : /usr/lib/python2.5/site-packages/packagekit/backend.py, line 577, in dispatch_command
    self.update_system()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1099, in update_system
    txmbr = self.yumbase.update() # Add all updates to Transaction
  File : /usr/lib/python2.5/site-packages/yum/__init__.py, line 2542, in update
    updated_pkg = self.rpmdb.searchPkgTuple(old)[0]
Comment 3 Jean-François Fortin Tam 2012-01-05 10:00:53 UTC
Hi there,
This bug report is very old and based on a version not supported anymore. By upgrading to a newer version of PackageKit you could receive bug fixes and new functionality. You may need to upgrade your Linux distribution to obtain a newer version of PackageKit.
Please feel free to reopen this bug if the problem still occurs with the latest version.