Bug 18526 - [FTBFS] Fails to build PackageKit-scan.c in docs/
Summary: [FTBFS] Fails to build PackageKit-scan.c in docs/
Status: RESOLVED INVALID
Alias: None
Product: PackageKit
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: Other All
: medium major
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-14 01:37 UTC by Diego Escalante Urrelo
Modified: 2012-01-05 09:58 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Escalante Urrelo 2008-11-14 01:37:12 UTC
gtk-doc: Compiling scanner
libtool: compile:  gcc -I/usr/include/PolicyKit -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -pthread -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I../../lib/packagekit-glib -I../../lib/packagekit-glib -I../../libselftest -Wcast-align -Wno-uninitialized -Wall -Wreturn-type -Werror -DG_DISABLE_SINGLE_INCLUDES -DGTK_DISABLE_SINGLE_INCLUDES -DG_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGDK_MULTIHEAD_SAFE -DGTK_MULTIHEAD_SAFE -g -O2 -c PackageKit-scan.c  -fPIC -DPIC -o .libs/PackageKit-scan.o
cc1: warnings being treated as errors
PackageKit-scan.c: In function ‘output_hierarchy’:
PackageKit-scan.c:708: error: format not a string literal and no format arguments
PackageKit-scan.c: In function ‘output_interfaces’:
PackageKit-scan.c:759: error: format not a string literal and no format arguments
PackageKit-scan.c: In function ‘output_prerequisites’:
PackageKit-scan.c:804: error: format not a string literal and no format arguments
Compilation of scanner failed:
Comment 1 Jean-François Fortin Tam 2012-01-05 09:58:29 UTC
Hi there,
This bug report is very old and based on a version not supported anymore. By upgrading to a newer version of PackageKit you could receive bug fixes and new functionality. You may need to upgrade your Linux distribution to obtain a newer version of PackageKit.
Please feel free to reopen this bug if the problem still occurs with the latest version.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.