Bug 18582 - [GM45] startx gets black screen on VAIO SR19XN
Summary: [GM45] startx gets black screen on VAIO SR19XN
Status: RESOLVED DUPLICATE of bug 17292
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.2 (2007.02)
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Gordon Jin
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-17 15:12 UTC by Alexandre Kaspar
Modified: 2008-11-23 14:52 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg log message (23.06 KB, text/plain)
2008-11-17 15:12 UTC, Alexandre Kaspar
no flags Details
Log of XOrg when trying to use "startx" from level 3 (18.88 KB, text/x-log)
2008-11-22 15:52 UTC, Alexandre Kaspar
no flags Details
Xorg log message with i810 driver which neither works (5.24 KB, text/x-log)
2008-11-23 14:46 UTC, Alexandre Kaspar
no flags Details
Error when trying "make" on xf86 (2.5.0) to compile it (6.36 KB, text/plain)
2008-11-23 14:52 UTC, Alexandre Kaspar
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Kaspar 2008-11-17 15:12:58 UTC
Created attachment 20387 [details]
xorg log message

I'm on fedora 9 with kernel 2.6.27. All seems to work excepted the graphics driver. When trying to start the x server "startx" or switching on level 5, then the screen's getting black. It looks like there's something happening since the screen color's changing but nothing works really.

The only way to use linux is then to use the vesa driver.
But I need a better driver since there's no 3d acceleration working with the vesa driver.

The xorg log is attached.

Nota bene : it looks like the graphics card isn't recognized. It's called "Unknown video card" on gnome display panel.
Comment 1 Gordon Jin 2008-11-17 19:37:13 UTC
The log shows it's GM45(Cantiga), not G45.

Both are new, and there're some recent new fixes. Fedora 9 may be too old for this kind of new chipsets.

If you could build drivers by yourself, you could get the latest driver info at http://intellinuxgraphics.org/download.html. Otherwise you could try a newer distribution.
Comment 2 Alexandre Kaspar 2008-11-22 04:32:44 UTC
The graphic card is a "Mobile Intel® Graphics Media Accelerator X4500MHD".
It's on a VAIO SR19XN. 
(http://vaio.sony.ch/view/ShowProduct.action?product=VGN-SR19XN&site=voe_de_DE_cons&category=VN+SR+Series&assetid=1218032875584)

Do you think the fedora 10 release would be enough to make it work ?
Comment 3 Alexandre Kaspar 2008-11-22 15:51:15 UTC
Hi again.

I did some big updates (new kernel and use of releases frome rawhide (f10).

But it still doesn't work.
The log is now totally new but there's still warnings. 
(There's no error, but the screen still doesn't work. It gets black and then nothing. Juste some kinds of flash of the screen as if it was trying to adapt something)
Comment 4 Alexandre Kaspar 2008-11-22 15:52:13 UTC
Created attachment 20514 [details]
Log of XOrg when trying to use "startx" from level 3
Comment 5 Gordon Jin 2008-11-22 20:56:14 UTC
Jesse/Zhenyu, do you think it dup with bug#17292 or 17508?
Comment 6 Michael Fu 2008-11-22 22:33:41 UTC

*** This bug has been marked as a duplicate of bug 17292 ***
Comment 7 Alexandre Kaspar 2008-11-23 14:46:01 UTC
Created attachment 20524 [details]
Xorg log message with i810 driver which neither works

I get the same graphical result as explained in comment #11 (http://bugs.freedesktop.org/show_bug.cgi?id=17292#c11) but not the same errors. In my case, I don't even get an error using the "intel" driver. There're only the warnings WW in the log.

Should I try the i810 driver instead ?
It is worst since it doesn't even start complaining :

"(II) Module mouse: vendor="X.Org Foundation"
	compiled for 1.4.99.901, module version = 1.3.0
	Module class: X.Org XInput Driver
	ABI class: X.Org XInput driver, version 2.0
(II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
	i810-dc100, i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G,
	E7221 (i915), 915GM, 945G, 945GM, 945GME, 965G, G35, 965Q, 946GZ,
	965GM, 965GME/GLE, G33, Q35, Q33,
	Mobile Intel® GM45 Express Chipset,
	Intel Integrated Graphics Device, G45/G43, Q45/Q43, G41
(II) Primary Device is: PCI 00@00:02:0
(EE) No devices detected.

Fatal server error:
no screens found"

It's ambarasting since I have a GM45 and not a G45 as you said...
Since I've no external screen, I haven't be able to try connecting my vaio to it and see if that's the same problem.
If I can get one, I'll try.
Moreover, I'll upgrade to F10 as soon as it's released (we're close !).

Note : the versions I use (from yum) :
xorg-x11-drv-i810.i386                   2.5.0-3.fc10           installed       
xorg-x11-drv-i810-devel.i386             2.5.0-3.fc10           installed  
...
xorg-x11-server-Xorg.i386                1.5.2-3.fc9            installed       
xorg-x11-server-common.i386              1.5.2-3.fc9            installed       
xorg-x11-server-devel.i386               1.5.2-12.fc10          installed       
xorg-x11-server-source.i386              1.5.2-12.fc10          installed       
xorg-x11-server-utils.i386               7.4-1.fc9              installed 
...
libdrm.i386                              2.4.0-0.21.fc10        installed       
libdrm-devel.i386                        2.4.0-0.21.fc10        installed  
...
mesa-dri-drivers.i386                    7.2-0.13.fc10          installed       
mesa-libGL.i386                          7.2-0.13.fc10          installed       
mesa-libGL-devel.i386                    7.2-0.13.fc10          installed       
mesa-libGLU.i386                         7.1-0.37.fc9           installed       
mesa-libGLU-devel.i386                   7.1-0.37.fc9           installed
Comment 8 Alexandre Kaspar 2008-11-23 14:52:26 UTC
Created attachment 20525 [details]
Error when trying "make" on xf86 (2.5.0) to compile it

There may be some lib (or version) problem since I cannot compile the xf86 driver. (2.5.0)
"./configure" works well, but "make" shows a lot of errors.

Firstly, there wasn't any drm.h in /usr/include. There's one in the kernel sources.
Then I created some symlink to it but now there're other problems (c.f. the attached log).


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.