Bug 18629 - Font glitches when zooming
Summary: Font glitches when zooming
Status: RESOLVED MOVED
Alias: None
Product: poppler
Classification: Unclassified
Component: qt4 frontend (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-19 21:23 UTC by Jacopo De Simoi
Modified: 2018-08-20 21:33 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Screenshot of the same document, same zoom level, yet different outcome (206.01 KB, image/png)
2008-11-19 21:23 UTC, Jacopo De Simoi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jacopo De Simoi 2008-11-19 21:23:40 UTC
Created attachment 20457 [details]
Screenshot of the same document, same zoom level, yet different outcome

I am using Okular 0.7.3 on kde 4.1.3 with poppler 0.10.1 and fontconfig 2.6.0.
Everything compiled from source (gentoo) with -O2 (gcc 4.1.2)
Occasionally when zooming in and out the font (Times -> n021004l.pfb) is rendered in a weird "condensed" weight (have a look at the screenshot).
More rarely the font is rendered "condensed" for a few sentences and then back to normal (wasn't able to get a screenshot of that).
I was not able to reproduce the issue using epdfview. 
It might be that it uses more standard zoom values (notice 305.05% on the left window) or that the problem is related to the qt4 bindings.

This happens with every pdf which uses the Times font, but it might be just an issue with non-embedded fonts.
Comment 1 GitLab Migration User 2018-08-20 21:33:45 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/poppler/poppler/issues/12.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.