Bug 1867 - [XKB] Croatian keyboard is not properly defined
Summary: [XKB] Croatian keyboard is not properly defined
Status: RESOLVED DUPLICATE of bug 1899
Alias: None
Product: xorg
Classification: Unclassified
Component: Input/Keyboard (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: Xorg Project Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-11-18 08:45 UTC by Miroslav Rajcic
Modified: 2005-03-07 14:04 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
This is a working hr keymap from XFree4.3, Debian fork. (2.02 KB, text/plain)
2004-12-10 05:48 UTC, Ante Karamatic
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Miroslav Rajcic 2004-11-18 08:45:52 UTC
Croatian keyboard is not defined properly on my FC3 distribution using
xorg-x11-6.8.1-12.i386.rpm. 

One of the keyboard keys is wrongly defined.
Steps to Reproduce:
1. Select Croatian keyboard
2. Press key next to the "right shift key" (first one left of it)
3. It should, but it does not, produce minus and underscore letters!

Below, there is a patch against file
"/usr/X11R6/lib/X11/xkb/symbols/pc/hr" that fixes the problem.

---------------------- PATCH ---------------------------------------
--- hr	2004-11-16 18:07:42.314679720 +0100
+++ hr_new	2004-11-11 14:29:43.000000000 +0100
@@ -20,6 +20,7 @@
 
     name[Group1]="Croatian";
 
+    key <AB10> {	[     minus,	underscore	]	}; 
     key <AE01>	{ [         1,     exclam,   asciitilde,   dead_tilde ]	};
     key <AE02>	{ [         2,   quotedbl,   dead_caron,        caron ]	};
     key <AE03>	{ [         3, numbersign,  asciicircum,
dead_circumflex ] };
Comment 1 Ante Karamatic 2004-12-10 05:48:15 UTC
Created attachment 1506 [details]
This is a working hr keymap from XFree4.3, Debian fork.
Comment 2 Ante Karamatic 2005-02-15 06:28:01 UTC
Xorg 6.8.2 still has broken croatian keymap. I emailed fix to the maintainer 
of the CVS - no response. It would be nice if we could fix it over CVS, or if 
you would fix it yourself. This bug is being fixed by almost every 
distribution, isn't that funny? Everybody is fixing xorg's bug, but xorg 
developers don't. On http://www.grad.hr/~ivoks/hr is 
working /usr/lib/X11/xkb/symbols/pc/hr keymap. Beside that <AB10>, there is 
one typo (Seprator, and it should be Separator). Just merge this file to your 
CVS and everything will be fine. Tested, working.

This bug is in Xorg from the begining of the fork. XFree4.4 doesn't have it, 
Debian XFree fork doesn't have it. Even Pat will fix it in Slackware. Why is 
so hard to put thoose two lines in that file? We aren't very big country, but 
it would be nice to have a working keymap.
Comment 3 Pablo Saratxaga 2005-03-08 09:04:49 UTC

*** This bug has been marked as a duplicate of 1899 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.