Bug 18703 - (GM45_GLX_freeze) [GM45 GEM] freezes after GLX application running for several mins
(GM45_GLX_freeze)
[GM45 GEM] freezes after GLX application running for several mins
Status: CLOSED FIXED
Product: xorg
Classification: Unclassified
Component: Driver/intel
7.4 (2008.09)
Other All
: high critical
Assigned To: Eric Anholt
Xorg Project Team
:
Depends on:
Blocks: 18841
  Show dependency treegraph
 
Reported: 2008-11-25 13:42 UTC by Claudio Camacho
Modified: 2008-12-08 21:48 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log with linux 2.6.28-rc6 + Xorg 7.4 + xf86-intel-2.5.1 (22.74 KB, text/plain)
2008-11-25 13:44 UTC, Claudio Camacho
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Claudio Camacho 2008-11-25 13:42:22 UTC
From kernel 2.6.28-rc6 onwards and driver xf86-video-intel-2.5.1, the Intel GM45 freezes the Xorg when running any GLX (OpenGL) application.

The Xorg server works fine as long as no GLX applications are used. When GLX is in use, the system works for several minutes and then freezes completely, although the mouse cursor can be moved.

The whole system is not crashed, since pressing the power button will generate the shutdown event and, in case of having acpid running, the computer turns off.

This freeze happens with any GLX application, and I have tested ioquake3 (Quake 3 Arena), TORCS and Kwin (KDE 4.x) composite manager (only when using OpenGL rendering).

Please note that this doesn't happen when using xf86-video-intel-2.5.1 with a 2.6.27 kernel, which makes me presume that there is some problem with GEM.
Comment 1 Claudio Camacho 2008-11-25 13:44:19 UTC
Created attachment 20585 [details]
Xorg.0.log with linux 2.6.28-rc6 + Xorg 7.4 + xf86-intel-2.5.1

This is the Xorg.0.log with the 2.6.28-rc6 kernel, using xf86-video-intel-2.5.1 and Xorg 7.4 (xserver is 1.5.3).
Comment 2 Gordon Jin 2008-11-25 23:43:52 UTC
This seems similar to bug#18052.

Can smaller demo like glxgears reproduce this too?
Comment 3 Claudio Camacho 2008-11-26 06:51:07 UTC
Hi,

glxgears didn't crash the Xorg, I run them both in windowed mode and in fullscreen mode, both for 30 minutes, and nothing happened, so I guess is a problem with more demanding OpenGL applications.

At least I tested Quake 3 Arena, TORCS 1.3.0 and Kwin 4.1.3, and all crash the Xorg after several minutes.

I hope this can help in finding the bug.
Comment 4 Gordon Jin 2008-12-02 01:28:15 UTC
bug#18052 has gone with latest kernel: git://git.kernel.org/pub/scm/linux/kernel/git/anholt/drm-intel for-airlied branch. Could you try it?
Comment 5 Claudio Camacho 2008-12-02 02:30:42 UTC
Hi,

Yes, with 2.6.28-rc7 + xf86-video-intel-2.5.1 now the graphics card behaves better with GLX applications. But there are still some big issues. For now, the Quake 3 Arena and the kwin4 with desktop effects and OpenGL rendering work properly and don't crash the Xorg.

However, all the applications now are very laggish. For instance, when pressing the button "Play" in Quake 3 Arena, it takes several seconds for the application to respond, and then it starts to load the game. Also, the framerate is ridiculously low. With 2.6.27 + 2.4.2 I got up to 80fps in Quake 3 Arena, whereas now I get only 29fps.

Another thing I wanted to point out is that some games don't even start the OpenGL mode. For instance, TORCS is not using OpenGL until the race is started. So I can browse the menus, but once I start the race, I only see a black screen, and not the starting grid with the cars. It looks like the whole OpenGL part hangs, and the game is stuck.

Should I open a new bug for this? Really, the performance of the GM45 is ridiculous, compared to what it should provide.

P.S.- Thanks for taking care of these bugs :)
Comment 6 Daniel FitzGibbons 2008-12-04 16:45:55 UTC
I get this crash on Fedora 10 and Opensuse 11.1 which use 2.5.x and kernel 2.6.27.x.  Both with the default driver and with the latest intel driver compiled from git.  I don't think these are using GEM, so I'm not sure it is GEM specific bug.
Comment 7 Gordon Jin 2008-12-04 17:33:13 UTC
(In reply to comment #6)
> I get this crash on Fedora 10 and Opensuse 11.1 which use 2.5.x and kernel
> 2.6.27.x.  Both with the default driver and with the latest intel driver
> compiled from git.  I don't think these are using GEM, so I'm not sure it is
> GEM specific bug.

Daniel:
Fedora 10 uses GEM kernel. Opensuse 11.1 uses non-GEM kernel so falling into gem-classic mode (with latest driver supporting gem). So your issue seems bug#18052.

Comment 8 Eric Anholt 2008-12-08 18:36:29 UTC
What version of mesa are you using?  Expect lower performance in Mesa 7.2 and earlier, as it is running in a compatibility mode.

Marking this fixed as the original issue (ioquake3 hang) is fixed.  Please open separate bugs for separate issues.
Comment 9 Gordon Jin 2008-12-08 19:47:28 UTC
(In reply to comment #5)
> Hi,
> 
> Yes, with 2.6.28-rc7 + xf86-video-intel-2.5.1 now the graphics card behaves
> better with GLX applications. But there are still some big issues. 

Are you using upstream 2.6.28-rc7 or for-airlied tree? TORCS is running fine on my GM45 with for-airlied.
Comment 10 Claudio Camacho 2008-12-08 21:48:38 UTC
I use mesa 7.2 and 2.6.28-rc7 from stock (nothing with for-airlied).

I will close this bug and open a new one with the performance issue, thank you very much all of you for your time :)