Bug 18822 - Regression - missing, misplaced textures with OpenArena.
Summary: Regression - missing, misplaced textures with OpenArena.
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Eric Anholt
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 18841
  Show dependency treegraph
 
Reported: 2008-11-30 12:54 UTC by Mateusz Kaduk
Modified: 2009-08-24 12:31 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mateusz Kaduk 2008-11-30 12:54:16 UTC
When I join game, I dont see players, some textures are misplaced, disappear or never are displayed.

I did git-bisect and this is the latest working commit.

# git-bisect good
8e5639577c03ccd75bb421e494638fbb5a3e7dcd is first bad commit
commit 8e5639577c03ccd75bb421e494638fbb5a3e7dcd
Author: Eric Anholt <eric@anholt.net>
Date:   Fri Nov 28 12:16:51 2008 -0800

    i965: Fix clashing enums for BRW_NEW_INDICES/VERTICES versus BATCH/DEPTH_BUFFER.
    
    Fixes upload of large amounts of state for every new primitive emit.

:040000 040000 6214a3b1eed3b71cbe7750e1d4b782ef70c35593 2d6943b2fa3c17204f2ce3b2750ae7c30e684d18 M	src

Bug is present in following configuration from 30.11.08
Debian (sid) amd64
xorg 1.5.3
master xf86-intel
master libdrm
master mesa
for-airlied master kernel branch from Eric's tree.
Comment 1 Mateusz Kaduk 2008-11-30 16:37:43 UTC
Repeated test

git checkout 8e5639577c03ccd75bb421e494638fbb5a3e7dcd   <--- Bad
git checkout 8e5639577c03ccd75bb421e494638fbb5a3e7dcd~1 <--- Works

Comment 2 Eric Anholt 2008-12-03 11:49:34 UTC
commit 264cba6f70eacd9e04646104d10ba63c248d7b83
Author: Eric Anholt <eric@anholt.net>
Date:   Wed Dec 3 11:36:55 2008 -0800

    i965: Fix failure to upload new constant data when changing programs.
    
    This is fallout from the ffvertex_prog.c work.  It doesn't call
    ProgramStringNotify, so we don't set param_state, so we wouldn't track when
    VP parameters changed, and constants wouldn't get uploaded.  Instead, remove
    param_state entirely and just use the real value that we want to be tracking.
    
    Fixes rendering in openarena since BRW_NEW_BATCH got disentangled from
    BRW_NEW_INDICES.
    
    Bug #18822.
Comment 3 Adam Jackson 2009-08-24 12:31:09 UTC
Mass version move, cvs -> git


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.