Bug 18829 - Make XCB backend supported
Summary: Make XCB backend supported
Status: RESOLVED NOTABUG
Alias: None
Product: cairo
Classification: Unclassified
Component: xcb backend (show other bugs)
Version: 1.8.5
Hardware: Other All
: medium normal
Assignee: Carl Worth
QA Contact: cairo-bugs mailing list
URL: https://bugzilla.redhat.com/show_bug....
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-01 00:39 UTC by Michal Nowak
Modified: 2010-03-05 12:05 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michal Nowak 2008-12-01 00:39:44 UTC
My bug in $(URI) depends on it.
Comment 1 Behdad Esfahbod 2008-12-01 00:46:00 UTC
This wouldn't magically happen unless someone works on bringing the xcb backend to the supported level.
Comment 2 Bill McGonigle 2010-03-05 10:13:31 UTC
There's a summer of code proposal for merging the xlib and xcb backends but not a bugzilla entry that I could find - should this bug become that request or file a new one?
Comment 3 Chris Wilson 2010-03-05 10:36:51 UTC
It's in progress, with the goal of xcb superseding xlib and so cairo-xlib only being used on old systems that will not install libxcb. For continued support of cairo-xlib, there is a proxy layer [cairo-xlib-xcb] until applications/toolkits move onto using xcb directly.

Clone the tree, ./configure --enable-xcb, test and send patches.
Comment 4 Bill McGonigle 2010-03-05 12:05:10 UTC
Good news, thanks Chris.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.