Bug 18876 - [855gm GEM]No rendering when run drawpix/readpix
Summary: [855gm GEM]No rendering when run drawpix/readpix
Status: VERIFIED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915 (show other bugs)
Version: unspecified
Hardware: Other All
: medium major
Assignee: Eric Anholt
QA Contact:
URL:
Whiteboard:
Keywords:
: 18875 (view as bug list)
Depends on:
Blocks: 18841 intel-3d-release
  Show dependency treegraph
 
Reported: 2008-12-03 18:38 UTC by liuhaien
Modified: 2009-06-03 19:51 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
screenshot of drawpix (547.50 KB, image/png)
2008-12-03 18:38 UTC, liuhaien
Details
screenshot of readpix (479.47 KB, image/png)
2008-12-03 18:39 UTC, liuhaien
Details
xorg.0.log (38.79 KB, text/plain)
2008-12-03 18:41 UTC, liuhaien
Details
xorg conf file (3.76 KB, text/plain)
2008-12-03 18:41 UTC, liuhaien
Details

Note You need to log in before you can comment on or make changes to this bug.
Description liuhaien 2008-12-03 18:38:01 UTC
Created attachment 20782 [details]
screenshot of drawpix

System Environment:
--------------------------

Host:           x-855gm
Arch:           i386
OSD:            Fedora Core release 6 (Zod)
GEM_kernel:       (for-airlied)728ced8c47f99a2287cdd0d3e77f5ae1a3d410e6
Libdrm:         (master)b0d93c74d884b40bd94469a5ef75fdb2fef17680
Mesa:           (master)154a9e5317f890618932cea0129ef887e16baf84
Xorg:           7.2
Xserver_stable:        
(server-1.6-branch)b268458eab2f213ec14dfe8013aa714c187e3aab
Xf86_video_intel:              
(master)07f5a8223187c1abc79c104d2fa5859a54cecd30


Bug detailed description:
-------------------------
startx ,run mesa demos drawpix and readpix , we will get nothing but a white window, see the screenshots in the attachment.
Comment 1 liuhaien 2008-12-03 18:39:01 UTC
Created attachment 20783 [details]
screenshot of readpix
Comment 2 liuhaien 2008-12-03 18:41:13 UTC
Created attachment 20784 [details]
xorg.0.log
Comment 3 liuhaien 2008-12-03 18:41:30 UTC
Created attachment 20785 [details]
xorg conf file
Comment 4 Eric Anholt 2008-12-03 21:22:47 UTC
*** Bug 18875 has been marked as a duplicate of this bug. ***
Comment 5 Gordon Jin 2008-12-04 00:23:56 UTC
1. This is the first time GEM can go so far on our 855gm.
2. This doesn't happen on 9xx.
Comment 6 liuhaien 2008-12-09 01:20:28 UTC
this issue still exists when set tiling off.
Comment 7 liuhaien 2009-03-22 20:26:12 UTC
still exists against:
Libdrm:         (master)00d8e960ca665b7f0528438331f4d0ae77fbb4cc
Mesa:(mesa_7_4_branch)b009a32bf428192fef2dc4787d25f022a472854f          
Xserver:        (server-1.6-branch)60c161545af80eb78eb790a05bde79409dfdf16e
Xf86_video_intel:       (2.7)e2465249a90b9aefe6d7a96eb56a51fde54698a0
Kernel:       (for-airlied)a2e785c32b886dd7f0289d1cf15fc14e9c81bc01
Comment 8 Eric Anholt 2009-05-26 20:54:10 UTC
commit 8ec6e036792decf5149a209e51cb5e93ccc5c754
Author: Eric Anholt <eric@anholt.net>
Date:   Tue May 26 20:45:29 2009 -0700

    i915: Fall back on NPOT textured metaops on 830-class.

(now readpix just shows off that software fallbacks on 8xx are incorrect).
Comment 9 liuhaien 2009-06-03 19:51:47 UTC
Verified althrough the display is tiled.
Libdrm:		(master)00fae87f96e1fc5198311feec81866bf9c53d0e1
Mesa:		(master)9f6ec50f8c79283583eeebdebd16bf7dcd134816
Xserver:		(master)7f027d9dc0146e229802aeac342ea2dbab63264a
Xf86_video_intel:		(master)b8e360bf2b77d28559d15a7c0f9c766848eb6ced
Kernel:       (for-linus)07f4f3e8a24138ca2f3650723d670df25687cd05


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.