Bug 18941 - [G45 XV] playing video hangs system on DG45ID
[G45 XV] playing video hangs system on DG45ID
Status: VERIFIED WORKSFORME
Product: xorg
Classification: Unclassified
Component: Driver/intel
unspecified
IA64 (Itanium) Linux (All)
: high critical
Assigned To: Zou Nan hai
Xorg Project Team
:
Depends on:
Blocks: 18858
  Show dependency treegraph
 
Reported: 2008-12-07 23:43 UTC by lin, jiewen
Modified: 2009-01-14 22:50 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
log (54.76 KB, text/plain)
2008-12-07 23:43 UTC, lin, jiewen
no flags Details
conf (3.81 KB, text/plain)
2008-12-07 23:44 UTC, lin, jiewen
no flags Details
system log1 (881.33 KB, text/plain)
2008-12-08 17:40 UTC, lin, jiewen
no flags Details
system log2 (180.84 KB, text/plain)
2008-12-08 17:41 UTC, lin, jiewen
no flags Details
log (8.71 KB, text/plain)
2008-12-22 00:21 UTC, lin, jiewen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description lin, jiewen 2008-12-07 23:43:50 UTC
Created attachment 20886 [details]
log

System Environment:
--------------------------

--Platform: G45
--Architecture(32-bit,64-bit,compatiblity): 64-bit
--2D driver: (master)b156b3165e1aae5df0353737d0335ac2e653f5fd
--3D driver: (master)bdc8ac4426f00eaafbe8ca0d356563efe390294d
--DRM: shipped with kernel 2.6.28-rc6-for-airlied
--libdrm: (master)b0d93c74d884b40bd94469a5ef75fdb2fef17680
--Xserver: (master)8c1dd40a04693f09f4fcea6e7f905af34c7589de
--Kernel: 2.6.28-rc6-for-airlied

Bug detailed description:
--------------------------
Start X and play video, OS is hung several minutes later(around 3).


Reproduce steps:
----------------
1. xinit &
2. ./mplayer videofile
Comment 1 lin, jiewen 2008-12-07 23:44:48 UTC
Created attachment 20887 [details]
conf
Comment 2 Gordon Jin 2008-12-08 06:28:38 UTC
anything interesting in /var/log/messages?
Comment 3 lin, jiewen 2008-12-08 17:40:22 UTC
Created attachment 20925 [details]
system log1
Comment 4 lin, jiewen 2008-12-08 17:41:07 UTC
Created attachment 20926 [details]
system log2
Comment 5 Gordon Jin 2008-12-09 21:46:58 UTC
This happens on the Intel DG45ID board (purchased from market), with pci id 2e22 (rev 03).

We put the hard disk to a G45 SSG SDV (with the same pci id and rev), and playing video works fine.

So this seems to be related with the specific board.

We did see the same issue on a G45 CRB from CPG, see internal bug 325.

All Q45 SDV or CRB are fine.

XV seems the only problem on these impacted G45 boards, and other tests are fine.
Comment 6 Wang Zhenyu 2008-12-15 21:24:56 UTC
Looks we have to make decision for this one, and it shouldn't block 2.6 release...
Comment 7 Michael Fu 2008-12-17 18:11:56 UTC
Nanhai is using the other DG45ID board in the G45 SDV. Let's see if he can reproduce this or not. 

We should check with people on the mailing list that uses DG45ID to see if they met same issue. Can Gordon do this?

keith packard has one DG45ID, too.
Comment 8 Michael Fu 2008-12-18 06:28:43 UTC
nanhai can't reproduce this on the DG45ID he has. Let's see others' report.
Comment 9 Michael Fu 2008-12-18 19:33:51 UTC
Will Saxon [saxonww@gmail.com] also report didn't find this issue on his DG45ID... Since this is a system hang, I'm just wonderring maybe the HW malfunction? how about give it other high load like keep building kernel source to see if it will hang, too?
Comment 10 Wang Zhenyu 2008-12-21 19:06:08 UTC
Close for this failure hardware.
Comment 11 lin, jiewen 2008-12-21 22:10:01 UTC
(In reply to comment #9)
> Will Saxon [saxonww@gmail.com] also report didn't find this issue on his
> DG45ID... Since this is a system hang, I'm just wonderring maybe the HW
> malfunction? how about give it other high load like keep building kernel source
> to see if it will hang, too?
> 

We built kernel source for more than 2 hours, it works well.
Comment 12 lin, jiewen 2008-12-22 00:21:19 UTC
Created attachment 21384 [details]
log

We tried to run specviewperf, but os crashed with output(on the attachment)in 25 minutes.
Comment 13 lin, jiewen 2008-12-22 21:18:47 UTC
(In reply to comment #12)
> Created an attachment (id=21384) [details]
> log
> 
> We tried to run specviewperf, but os crashed with output(on the attachment)in
> 25 minutes.
> 

Specviewperf10 does not have this issue on asus g45(p5q-em) with the same disk. so it should be DG45ID's issue.