Bug 18964 - [G45] Hyperspace demo from rss-glx hangs X with git driver
Summary: [G45] Hyperspace demo from rss-glx hangs X with git driver
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium critical
Assignee: Eric Anholt
QA Contact:
URL:
Whiteboard:
Keywords:
: 20086 (view as bug list)
Depends on:
Blocks: 18841 intel-3d-release
  Show dependency treegraph
 
Reported: 2008-12-08 16:57 UTC by Sven Arvidsson
Modified: 2009-08-24 12:31 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg log (74.98 KB, text/plain)
2008-12-08 16:57 UTC, Sven Arvidsson
Details
Backtrace from hyperspace (8.34 KB, text/plain)
2008-12-08 16:57 UTC, Sven Arvidsson
Details
Backtrace from Xorg (3.93 KB, text/plain)
2008-12-08 16:58 UTC, Sven Arvidsson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sven Arvidsson 2008-12-08 16:57:25 UTC
Created attachment 20921 [details]
Xorg log

The hyperspace demo from rss-glx (Really Slick Screensavers) causes an immediate hang in X.

Killing hyperspace does not help and the hardware is wedged upon killing Xorg.

System environment:
-- chipset: G45 / ICH10R
-- system architecture: 32-bit
-- xf86-video-intel: bea98cdfd93fc1181a06c51e57fcab227ff4827e
-- xserver: 1.5.2
-- mesa: a0d5c3cfe6582f8294154f6877319193458158a2
-- drm: c99566fb810c9d8cae5e9cd39d1772b55e2f514c
-- kernel: for-airlied 66647dc60d16fae9f6963fd98b6d9baa1a8dac69
-- Linux distribution: Debian unstable
-- Machine or mobo model: Asus P5Q-EM
-- Display connector: DVI
Comment 1 Sven Arvidsson 2008-12-08 16:57:53 UTC
Created attachment 20922 [details]
Backtrace from hyperspace
Comment 2 Sven Arvidsson 2008-12-08 16:58:17 UTC
Created attachment 20923 [details]
Backtrace from Xorg
Comment 3 Eric Anholt 2008-12-09 14:36:26 UTC
reproduced on g45.  Noted that the app only sets s/t wrap modes on cube mapping, but the docs claim that we need to have all 3 in the same mode or it gets angry.  Smashing all 3 settings to CLAMP didn't help, though.  The hang is on what is, at first glance, a perfectly healthy batchbuffer. (INTEL_DEBUG=bat,sync)
Comment 4 martin 2009-02-17 05:49:37 UTC
I have a very similar issue on a box with a GA-EG45M-DS2H (G45) motherboard. The backtrace I see in xorg is different though and I also don't have any "[mi] EQ overflow" spam in my xorg.log. Once there is a patch for this, please post the commit sha1 or .patch and I will test it on my box as well.

My bug is here:
http://bugs.freedesktop.org/show_bug.cgi?id=20086
Comment 5 martin 2009-02-18 13:04:49 UTC
*** Bug 20086 has been marked as a duplicate of this bug. ***
Comment 6 Eric Anholt 2009-03-06 10:46:48 UTC
I can no longer reproduce this with Mesa master.  Can anyone else test?
Comment 7 martin 2009-03-06 11:07:30 UTC
If would be useful to understand when this got fixed (for potential cherry picking), I might try to bisect later (if I find the time) but if anyone got known good or known bad commits, please paste them here.
Comment 8 Sven Arvidsson 2009-03-08 09:14:52 UTC
I just tried Mesa 2305642b2e8edcebdc727f1181f7dbfcc78e8028 and it no longer causes a hang.
Comment 9 Adam Jackson 2009-08-24 12:31:15 UTC
Mass version move, cvs -> git


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.