Bug 19018 - Doesn't/can't handle SSL certificate errors.
Doesn't/can't handle SSL certificate errors.
Status: RESOLVED DUPLICATE of bug 23491
Product: Telepathy
Classification: Unclassified
Component: haze
unspecified
Other All
: medium major
Assigned To: Telepathy bugs list
Telepathy bugs list
:
: 17907 26704 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-11 08:28 UTC by Will Thompson
Modified: 2010-09-06 02:15 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Will Thompson 2008-12-11 08:28:04 UTC
This is because the certificate for rsi.hotmail.com, the server whence offline messages are retrieved, makes libpurple throw up a certificate warning thing which haze throws on the floor.

Workaround: ship the certificate as known-trusted in haze until I get a chance to fix libpurple and then deal with it properly.
Comment 1 Will Thompson 2009-04-22 05:40:19 UTC
Recent libpurples whitelist the rsi.hotmail.com cert, so this works again.

But the underlying problem is not fixed; retitling.
Comment 2 Simon McVittie 2010-07-19 03:32:12 UTC
*** Bug 26704 has been marked as a duplicate of this bug. ***
Comment 3 Will Thompson 2010-09-06 02:13:08 UTC
*** Bug 17907 has been marked as a duplicate of this bug. ***
Comment 4 Will Thompson 2010-09-06 02:15:32 UTC
bug 23941 has more detail than this bug; duppin'

*** This bug has been marked as a duplicate of bug 23491 ***