Bug 19038 - [G45 GEM]incorrect rendering when run mesa demo(fbo_firecube)
[G45 GEM]incorrect rendering when run mesa demo(fbo_firecube)
Status: VERIFIED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
unspecified
Other Linux (All)
: high normal
Assigned To: Eric Anholt
:
Depends on:
Blocks: 18841
  Show dependency treegraph
 
Reported: 2008-12-12 01:02 UTC by liuhaien
Modified: 2008-12-29 21:10 UTC (History)
0 users

See Also:


Attachments
xorg.0.log (41.96 KB, text/plain)
2008-12-12 01:02 UTC, liuhaien
Details
xorg conf file (3.76 KB, text/plain)
2008-12-12 01:02 UTC, liuhaien
Details
screenshot (137.52 KB, image/png)
2008-12-12 01:03 UTC, liuhaien
Details

Note You need to log in before you can comment on or make changes to this bug.
Description liuhaien 2008-12-12 01:02:20 UTC
Created attachment 21084 [details]
xorg.0.log

System Environment:
--------------------------
Host:		x-g45a
Arch:		i386
OSD:		Fedora release 9 (Sulphur)
Kernel:		2.6.28-rc8
Libdrm:		(master)9583c099b4a08b49e03f7b461c344b6d277fd262
Mesa_stable:		(intel-2008-q4)154a9e5317f890618932cea0129ef887e16baf84
Xserver_stable:	(server-1.6-branch)523aae1fa6d8002e55e85aee49f113b7eb9a6df3
Xf86_video_intel_stable:(xf86-video-intel-2.6-branch) 
                     005127b5825993d2fe3c36e3a01a37ea6904739e
GEM kernel (for-airlied)8b1fae4e4200388b64dd88065639413cb3f1051c


Bug detailed description:
-------------------------
startx , then run mesa demo fbo_firecube,we will get a incorrect rendering as is shown in the attached screenshot.

Reproduce steps:
----------------
1.xinit&
2. run mesa demo/fbo_cubefire
Comment 1 liuhaien 2008-12-12 01:02:44 UTC
Created attachment 21085 [details]
xorg conf file
Comment 2 liuhaien 2008-12-12 01:03:46 UTC
Created attachment 21086 [details]
screenshot
Comment 3 Eric Anholt 2008-12-14 19:32:01 UTC
intel-2008-q4 needs to pull the fixes from master.
Comment 4 Eric Anholt 2008-12-19 13:13:14 UTC
commit 76e1e0df49267e6a3f5d5f5548535f87b077308a
Author: Eric Anholt <eric@anholt.net>
Date:   Sat Dec 6 14:21:12 2008 -0800

    intel: Fix glBitmap blit acceleration for FBO destinations.
    
    Bug #18914.  Fixes fbo_firecube hang due to drawing outside the FBO bounds.
    Thanks to Pierre Willenbrock for debugging the issue.
    (cherry picked from commit cb433d91c6e198b7c77f747f1a38803532bc9be9)
Comment 5 liuhaien 2008-12-29 21:10:54 UTC
verified against:
Kernel:		2.6.28-release
Libdrm:		(master)c34539e8bb5568b1d6059abf139dd08e07e84eea
Mesa:		(intel-2008-q4)88f4b17555be36f3023f74a1b9c792294f09912b
Xorg:		7.2
Xserver: (server-1.6-branch)32e81074b967716865aef08b66ec29caf0fec2c5
Xf86_video_intel:		(xf86-video-intel-2.6-branch)
 892cb5db6fd4c5cc692bc74a2615860f27e9feff