Bug 19059 - Option "MigrationHeuristic greedy" causes icon corruption on KDE 4 systray
Summary: Option "MigrationHeuristic greedy" causes icon corruption on KDE 4 systray
Status: RESOLVED DUPLICATE of bug 16773
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: 7.4 (2008.09)
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-12 14:04 UTC by Eduardo Durany
Modified: 2008-12-18 01:53 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
screenshot of the systray (11.71 KB, image/png)
2008-12-12 14:28 UTC, Eduardo Durany
no flags Details
xorg.conf with MigrationHeuristic greedy (1.04 KB, text/plain)
2008-12-12 17:58 UTC, Eduardo Durany
no flags Details
Xorg.0.log with MigrationHeuristic greedy (34.87 KB, text/plain)
2008-12-12 17:59 UTC, Eduardo Durany
no flags Details
xorg.conf without MigrationHeuristic greedy (1.04 KB, application/octet-stream)
2008-12-12 18:00 UTC, Eduardo Durany
no flags Details
Xorg.0.log without MigrationHeuristic greedy (34.82 KB, text/x-log)
2008-12-12 18:00 UTC, Eduardo Durany
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eduardo Durany 2008-12-12 14:04:07 UTC
Hardware:
Radeon Mobility 7500

System:
xserver-xorg-video-radeon 6.9.0+git20081003.f9826a56
xorg 7.4
KDE 4.2 beta 1 (kwin with compositing enabled)
ubuntu intrepid

xorg.conf:
Section "Device"
        Identifier      "Configured Video Device"
        Driver          "ati"

        Option          "AGPMode" "4"
        Option          "DynamicClocks" "true"
        Option          "TVDACLoadDetect" "TRUE"
        Option          "TVStandard" "pal"

        Option          "AccelMethod" "EXA"
        Option          "AccelDFS"    "true"
        Option          "MigrationHeuristic" "greedy"
EndSection

With "MigrationHeuristic greedy" icons do not display correctly on KDE systray. If i disable this option, systray icons are shown correctly but compositing is much slower.

More info: http://bugs.kde.org/show_bug.cgi?id=170283
Comment 1 Eduardo Durany 2008-12-12 14:28:57 UTC
Created attachment 21103 [details]
screenshot of the systray
Comment 2 Alex Deucher 2008-12-12 16:14:30 UTC
please attach your xorg log and config.
Comment 3 Eduardo Durany 2008-12-12 17:58:47 UTC
Created attachment 21114 [details]
xorg.conf with MigrationHeuristic greedy
Comment 4 Eduardo Durany 2008-12-12 17:59:32 UTC
Created attachment 21115 [details]
Xorg.0.log with MigrationHeuristic greedy
Comment 5 Eduardo Durany 2008-12-12 18:00:10 UTC
Created attachment 21116 [details]
xorg.conf without MigrationHeuristic greedy
Comment 6 Eduardo Durany 2008-12-12 18:00:45 UTC
Created attachment 21117 [details]
Xorg.0.log without MigrationHeuristic greedy
Comment 7 Michel Dänzer 2008-12-14 05:05:38 UTC
"greedy" is known broken, and there's little if any interest in fixing it.

*** This bug has been marked as a duplicate of bug 16773 ***
Comment 8 Eduardo Durany 2008-12-14 06:04:09 UTC
Ok, thanks for your answer.
Comment 9 Elias Probst 2008-12-18 01:43:33 UTC
What to do instead?
Is there any usable configuration, neither slowing down compositing nor hiding the systray icons?
Does anyone know one?

Regards, Elias P.
Comment 10 Michel Dänzer 2008-12-18 01:53:17 UTC
(In reply to comment #9)
> What to do instead?

Use the default "always" and fix/report problems with it. Note that there have been EXA core improvements in the upcoming xserver 1.6, you may want to try the current release candidates. Also, Option "FBTexPercent" "0" may help EXA performance on setups like the one documented in this report.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.