Bug 19068 - [845] Crash when starting compiz
Summary: [845] Crash when starting compiz
Status: RESOLVED DUPLICATE of bug 26345
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.3 (2007.09)
Hardware: Other All
: medium critical
Assignee: Default DRI bug account
QA Contact: Xorg Project Team
Depends on:
Reported: 2008-12-13 01:37 UTC by Oxmosys
Modified: 2012-04-14 07:45 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:

lspci log (7.68 KB, text/x-log)
2008-12-13 01:38 UTC, Oxmosys
no flags Details
What changed in a9449fff4be8e6b3cc82914376420e3a66b960f5 commit (297.96 KB, text/plain)
2008-12-13 01:39 UTC, Oxmosys
no flags Details
Xorg.0.log with ModeDebug (99.06 KB, text/plain)
2008-12-15 05:25 UTC, Oxmosys
no flags Details
uname -a (94 bytes, text/plain)
2008-12-15 05:26 UTC, Oxmosys
no flags Details
xrandr --verbose (6.66 KB, text/plain)
2008-12-15 05:27 UTC, Oxmosys
no flags Details
dmesg log (28.74 KB, text/plain)
2008-12-15 05:32 UTC, Oxmosys
no flags Details
xorg.conf (1.04 KB, text/plain)
2008-12-15 05:33 UTC, Oxmosys
no flags Details
Xorg.0.log with ModeDebug when crashing during a VT Switch (136.59 KB, text/plain)
2008-12-15 11:32 UTC, Oxmosys
no flags Details
Xorg.0.log from 2.5.1 (31.71 KB, text/plain)
2008-12-21 23:10 UTC, Oxmosys
no flags Details

Description Oxmosys 2008-12-13 01:37:45 UTC
When starting compiz or any other compositing WM, intel driver definitively crash. The keyboard stops responding, the mouse still works and it's still possible to open a ssh session.

This bug happens on the following graphic card :
00:02.0 VGA compatible controller [0300]: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device [8086:2562] (rev 01)

It has been introduced by this git commit :
commit a9449fff4be8e6b3cc82914376420e3a66b960f5
Merge: a470f6b... 177924e...
Author: Zhenyu Wang <zhenyu.z.wang@intel.com>
Date:   Fri Nov 9 19:36:25 2007 +0800

    Merge branch 'master' into xvmc

Steps to reproduce :
1. Have a computer with the right graphic card.
2. Boot Ubuntu 8.10 Live CD on this computer.

Result : Ubuntu will boot and stay freeze on Xorg screen (compiz is pre-enabled).

This bug is still not fixed in 2.5.0 release distributed in ubuntu Jaunty.
Comment 1 Oxmosys 2008-12-13 01:38:30 UTC
Created attachment 21119 [details]
lspci log
Comment 2 Oxmosys 2008-12-13 01:39:52 UTC
Created attachment 21120 [details]
What changed in a9449fff4be8e6b3cc82914376420e3a66b960f5 commit
Comment 3 Michael Fu 2008-12-14 20:50:03 UTC
this bug even miss xorg.log.. pls refer to http://intellinuxgraphics.org/how_to_report_bug.html. thanks.
Comment 4 Michael Fu 2008-12-14 20:56:52 UTC
Also, please check if the work-around in bug# 17713 or bug# 18270 works for you...thanks.
Comment 5 Oxmosys 2008-12-15 05:25:45 UTC
Created attachment 21165 [details]
Xorg.0.log with ModeDebug
Comment 6 Oxmosys 2008-12-15 05:26:25 UTC
Created attachment 21166 [details]
uname -a
Comment 7 Oxmosys 2008-12-15 05:27:32 UTC
Created attachment 21167 [details]
xrandr --verbose
Comment 8 Oxmosys 2008-12-15 05:32:57 UTC
Created attachment 21168 [details]
dmesg log
Comment 9 Oxmosys 2008-12-15 05:33:32 UTC
Created attachment 21169 [details]
Comment 10 Oxmosys 2008-12-15 05:43:16 UTC
Workaround in bug# 17713 "Option "NoAccel"" make it impossible to start compiz.

Chipset : 82845G
System architecture : i386
Packages :
  libdrm2   2.3.1-0build1
  xserver-xorg   1:7.4~5ubuntu3
  xserver-xorg-video-intel   2:2.4.1-1ubuntu10
  libgl1-mesa-dri   7.2-1ubuntu2
Linux distribution : Linux Ubuntu 8.10
Machine model : Dell Optiplex GX160
Display Connector : VGA

Thanks! Would it be useful to have a gdm backtrace? If yes, I can try it.
Comment 11 Oxmosys 2008-12-15 11:32:07 UTC
Created attachment 21187 [details]
Xorg.0.log with ModeDebug when crashing during a VT Switch

I reproduced another crash in other circumstances with this graphic card. I'm writing the informations in case there is some link : when switching between multiple X sessions or when I logout from one of the active X session, X sometime fall into a black screen and it isn't possible to restart it. Text consoles still works but X is completely down. Compiz is not involved in this bug and it gives a lot of interesting outputs in Xorg.0.log.
Comment 12 Wang Zhenyu 2008-12-21 19:03:18 UTC
Could you try Option "EXANoComposite" "true"? Is it working with xf86-video-intel 2.3.2? How about 2.4.3?
Comment 13 Oxmosys 2008-12-21 22:33:06 UTC
I tried EXANoComposite workaround with 2.4.1 and the bug is still reproducible. The first time that I tried it, I got a different behavior : The screen showed "No signal detected" three times. 

The driver does not survive to a console switch in 2.5.1 so I can't provide more information about 2.5.1 at the moment. Let me know if you need more information.
Comment 14 Oxmosys 2008-12-21 23:10:39 UTC
Created attachment 21380 [details]
Xorg.0.log from 2.5.1

More details about 2.5.1 driver issues : 

I attached a Xorg.0.log from ubuntu 9.04 alpha 2 which includes 2.5.1 intel driver. Now the driver have many issues even without compiz. When X starts, some elements are missing or disappears from the screen (like icons in the menu), some texts are grey while they should be black, black artifacts in text and other weird effects. If I only click on GNOME menu, it generally take around 5 seconds before X freeze definitively. Maybe that metacity now use some kind of rendering by default?
Comment 15 Jesse Barnes 2009-05-11 11:21:16 UTC
Adjusting severity: crashes & hangs should be marked critical.
Comment 16 Eric Anholt 2009-06-30 19:14:28 UTC
Does this still occur with master of the 2D driver and 2.6.29 or 2.6.30 of the kernel, using UXA?  It should avoid some problems that could have crashed non-UXA compiz.
Comment 17 Bryce Harrington 2009-07-09 11:49:07 UTC
Eric, fwiw, according to a reporter on the downstream bug (https://bugs.edge.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/285250), this issue still occurs with Karmic Alpha-2, which is the 2.6.30-5 kernel and a git snapshot of the -intel driver up to ec2fde7c (plus some cherrypicks).

Comment 18 Eric Anholt 2009-07-15 15:48:42 UTC
Possible fix for hangs with compiz:

commit a1e6abb5ca89d699144d10fdc4309b3b78f2f7a9
Author: Eric Anholt <eric@anholt.net>
Date:   Wed Jul 15 14:15:10 2009 -0700

    Use batch_start_atomic to fix batchbuffer wrapping problems with 8xx render.
    Bug #22483.
Comment 19 Gordon Jin 2009-07-16 19:20:16 UTC
Could you try xf86-video-intel git master branch, which includes Eric's fix?
(or wait for a couple of days for 2.8.0 release)
Comment 20 Oxmosys 2009-07-16 19:30:25 UTC
I'm going to try this with next ubuntu karmic alpha release (july 23th).
Comment 21 Juha Laukkanen 2009-07-20 11:54:26 UTC
(In reply to comment #18)
> Possible fix for hangs with compiz:
> commit a1e6abb5ca89d699144d10fdc4309b3b78f2f7a9
> Author: Eric Anholt <eric@anholt.net>
> Date:   Wed Jul 15 14:15:10 2009 -0700
>     Use batch_start_atomic to fix batchbuffer wrapping problems with 8xx
> render.
>     Bug #22483.

Atleast for me (845G, Gentoo, Xorg 1.6.2, and xf86-video-intel driver (with batch_start_atomic fix) still freezes X when DRI is enabled.

Well I hope this gets resolved by the end of year. :)
Comment 22 Oxmosys 2009-07-26 09:25:54 UTC
I also confirm that the bug is not fixed, karmic alpha 3 has xserver-xorg-video-intel 2.8.0 and starting compiz still cause Xorg to freeze. I can move the mouse but nothing happens on the screen, and it's not possible to switch to TTY1-6. Xorg is just freeze.
Comment 23 Gordon Jin 2009-08-30 20:45:17 UTC
(clearing NEEDINFO)
Comment 24 ahph1uxsb8rae 2009-09-09 09:02:52 UTC
I guess Alpha-5 is still affected. Some months ago I tested Alpha-2 on another (now fixed) bug and my chipset (i830M) was blacklisted by ubuntu and disabled compiz. Yesterday I reinstalled Alpha-5 for further testing and have the same error. GDM boots up, login works but the UI crashes after some time. Keyboard and mouse are frozen, reboot by SysRq is possible, switching to another console is not.

Hardware is here: https://bugs.freedesktop.org/show_bug.cgi?id=22287#c1
Comment 25 ahph1uxsb8rae 2009-09-19 14:17:11 UTC
Still there on Alpha-6. I forwarded another bug report to Launchpad.


I am not very experienced in debugging a desktop. Is there a way to enable debugging on GDM and GNOME to see what they do while initializing? Best case would be writing to logfiles.
Comment 26 Chris Wilson 2010-03-02 07:54:00 UTC
This is very much likely a dup of the CPU/GPU coherency issue clearly demonstrated by bug 26345.
Comment 27 Eugeni Dodonov 2011-09-08 15:56:07 UTC
This issue is affecting a hardware component which is not being actively worked on anymore.

Moving the assignee to the dri-devel list as contact, to give this issue a better coverage.
Comment 28 Chris Wilson 2012-04-14 07:45:12 UTC

*** This bug has been marked as a duplicate of bug 26345 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.