Bug 19090 - [845G DVO-LVDS] Not able to start X in SLES11 with "maximum number of X display failures reached"
[845G DVO-LVDS] Not able to start X in SLES11 with "maximum number of X displ...
Status: RESOLVED WONTFIX
Product: xorg
Classification: Unclassified
Component: Driver/intel
7.4 (2008.09)
All Linux (All)
: medium normal
Assigned To: Wang Zhenyu
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-14 22:26 UTC by Guek Wu Neo
Modified: 2009-03-01 23:58 UTC (History)
11 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log and xorg.conf (30.00 KB, application/octet-stream)
2008-12-14 22:32 UTC, Guek Wu Neo
no flags Details
xorg.log with EXANoComposition (22.93 KB, text/plain)
2008-12-16 00:27 UTC, Michael Fu
no flags Details
xorg.conf with EXANoComposite (4.43 KB, text/plain)
2008-12-16 00:28 UTC, Michael Fu
no flags Details
Xorg.log (71.63 KB, text/plain)
2008-12-16 01:59 UTC, Vance
no flags Details
Xorg.0.log (22.75 KB, text/plain)
2008-12-16 23:10 UTC, Guek Wu Neo
no flags Details
this the xorg.conf used. (4.78 KB, application/octet-stream)
2008-12-21 20:12 UTC, Guek Wu Neo
no flags Details
this is Xorg.0.log (22.74 KB, text/plain)
2008-12-21 20:13 UTC, Guek Wu Neo
no flags Details
dmesg per request (29.71 KB, text/plain)
2008-12-22 02:09 UTC, Guek Wu Neo
no flags Details
Xorg log in debug mode (22.46 KB, text/plain)
2009-01-21 22:43 UTC, Vance
no flags Details
Xorg configuration used (4.27 KB, text/plain)
2009-01-21 22:44 UTC, Vance
no flags Details
Screen capture of hanged screen (112.28 KB, image/jpeg)
2009-02-04 02:25 UTC, Vance
no flags Details
Xorg.log (139.94 KB, text/plain)
2009-02-04 02:26 UTC, Vance
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Guek Wu Neo 2008-12-14 22:26:11 UTC
VGA compatible controller [0300]: Intel Corporation
82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device [8086:2562] (rev
03)

Problem description: Not able to startX. Problem exist is Sles11 beta1/2/3/4/5/6 when intel driver is used.
Error message:Not able to start X with error message " maximum number of X
display failures reached.
Comment 1 Guek Wu Neo 2008-12-14 22:32:14 UTC
Created attachment 21151 [details]
Xorg.0.log and xorg.conf

We have a bug reported to Novell Bugzilla#442416 that points  to this intel bug#18270 as resolution Upstream .


We have tried comment#33in Intelbug18270. It does not resolve our problem. attached is the log collected from trying comment#33.

Since the terminal name in Bug#18270 is for others, had open this bug separately per intel request to deal with IBM terminals.
Comment 2 Guek Wu Neo 2008-12-16 00:17:16 UTC
Michael

This bug is created per yr advise. Any update from intel?
Comment 3 Michael Fu 2008-12-16 00:27:55 UTC
Created attachment 21197 [details]
xorg.log with EXANoComposition
Comment 4 Michael Fu 2008-12-16 00:28:55 UTC
Created attachment 21198 [details]
xorg.conf with EXANoComposite
Comment 5 Michael Fu 2008-12-16 01:26:07 UTC
Let's try turns off 2D acceleration completely.. add  Option "NoAccel" "Yes" to device section. 

Please turn on "ModeDebug" "True" , too, then attach the xorg.log ( no gzip ). 

thanks!
Comment 6 Vance 2008-12-16 01:59:24 UTC
Created attachment 21200 [details]
Xorg.log

Hi Michael, here is the Xorg.log with NoAccel option and ModeDebug turned on. I see a blanked out white screen when X is loaded. But I can still go into the tty consoles which means the system didn't hang.
Comment 7 Wang Zhenyu 2008-12-16 19:35:14 UTC
I've finished current testing on 845GV here. It looks interrupt is broken on it, so I have to disable DRI. After that, everything works fine even with exa composite on. I'm on all git masters, kernel 2.6.28-rc8, xf86-video-intel 2.6-rc1 should be the same, etc.
Comment 8 Guek Wu Neo 2008-12-16 22:13:07 UTC
Zhenyu,

do you need out to test out any option?
Comment 9 Wang Zhenyu 2008-12-16 22:33:56 UTC
yeah, please try Option "DRI" "off".
Comment 10 Guek Wu Neo 2008-12-16 23:10:33 UTC
Created attachment 21228 [details]
Xorg.0.log

added the Option "DRI" "off". Display still does not turn out ok.
Is there any other package that we need to add in?
Comment 11 Wang Zhenyu 2008-12-18 22:33:46 UTC
Guek, do you use the same hardware like Vance's? As your log showed failure with no output detected, which is different with this problem. 
Comment 12 Guek Wu Neo 2008-12-21 18:38:37 UTC
we are using the same physical terminal to test out and report the problem.
Comment 13 Michael Fu 2008-12-21 19:08:27 UTC
(In reply to comment #12)
> we are using the same physical terminal to test out and report the problem.
> 

Do you mean you are using exact same HW environment to do testing as with Vance? But the test result diff is big. Vance at least can still detect the connected monitor. Would you please test it more times to see if you always get the same log? Or double check with Vance how he did the test?
Comment 14 Guek Wu Neo 2008-12-21 20:11:47 UTC
No difference in  hardware that we are using. The terminal comes with an integrated Monitor. 

Tested again. Get the same result. 
No able to get o X window. See this error message " WARNING: GdmLocalDisplayFactory: maximum number of X display failures reached: check X server log for errors"




Comment 15 Guek Wu Neo 2008-12-21 20:12:33 UTC
Created attachment 21377 [details]
this the xorg.conf used.
Comment 16 Guek Wu Neo 2008-12-21 20:13:02 UTC
Created attachment 21378 [details]
this is Xorg.0.log
Comment 17 Wang Zhenyu 2008-12-22 00:00:42 UTC
Guek, you're testing this board with only VGA connected or no output connected? Could you paste X log with ModeDebug on?
Comment 18 Guek Wu Neo 2008-12-22 00:22:43 UTC
The board is tested with touchscreen monitor attached phyiscally.
The Xorg.0.log in previous attached already with 'Option "ModeDebug" "true"'.

This is the 'hwinfo --monitor' information.

27: None 00.0: 10002 LCD Monitor
  [Created at monitor.140]
  Unique ID: rdCR.lhai6zl_YJ6
  Hardware Class: monitor
  Model: "IBM Notebook LCD"
  Vendor: "IBM CORPORATION"
  Device: "Notebook LCD"
  Resolution: 1024x768@60Hz
  Size: 305x229 mm
  Driver Info #0:
    Max. Resolution: 1024x768
    Vert. Sync Range: 50-75 Hz
    Hor. Sync Range: 31-69 kHz
  Config Status: cfg=new, avail=yes, need=no, active=unknown


Comment 19 Michael Fu 2008-12-22 00:51:13 UTC
Are you using any kernel vesa driver? like vesafb, etc. maybe you can attach your dmesg. thanks.
Comment 20 Guek Wu Neo 2008-12-22 02:09:01 UTC
Created attachment 21388 [details]
dmesg per request

Is using "intel" video driver. comment#15 xorg.conf is the setup that is used, the xorg.0.log is in comment#16.


Attached is the dmesg.
Comment 21 Michael Fu 2008-12-23 19:11:03 UTC
Guek Wu Neo, 

- Does this machine also comes with two display like other POS machine you are making?

- If you change the driver to vesa, can you get any display work?

thanks.
Comment 22 Guek Wu Neo 2008-12-23 20:22:20 UTC
This POS machine has 2 graphics cards.

Primary is Intel, Secondary is nVidia

Primary video card:
VGA compatible controller [0300]: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device [8086:2562] (rev 03)

Secondary video card:
VGA compatible controller [0300]: nVidia Corporation NV11 [GeForce2 MX/MX 400] [10de:0110] (rev b2)


Yes switching to vesa or fbdev will be able to get to see Xdeskstop for the Primary display( that is connected to the integrated LCD monitor(in comment#18). 

However when vesa is used, once exit to terminal console from Xdesktop, when return to Xdesktop again, will see black screen.

Comment 23 Michael Fu 2008-12-23 21:31:35 UTC
(In reply to comment #22)
> This POS machine has 2 graphics cards.
> 
> Primary is Intel, Secondary is nVidia
> 
> Primary video card:
> VGA compatible controller [0300]: Intel Corporation 82845G/GL[Brookdale-G]/GE
> Chipset Integrated Graphics Device [8086:2562] (rev 03)
> 
> Secondary video card:
> VGA compatible controller [0300]: nVidia Corporation NV11 [GeForce2 MX/MX 400]
> [10de:0110] (rev b2)
> 
> 
> Yes switching to vesa or fbdev will be able to get to see Xdeskstop for the
> Primary display( that is connected to the integrated LCD monitor(in
> comment#18). 
> 
> However when vesa is used, once exit to terminal console from Xdesktop, when
> return to Xdesktop again, will see black screen.
> 

could you please double check if monitor is really connected to the integrated intel graphics? e.g. by connecting two monitors to both VGA ports... thanks.
Comment 24 Guek Wu Neo 2008-12-24 00:06:28 UTC
there will only be display on one monitor even when there are total 2 monitors connected to the 2 vga ports.
Per the xorg.conf, is configured to use port 0:02:0 which is the intel card.

here is the sax2 -p output:
Chip: 0  is -> IBM i845                         00:02:0 0x8086 0x2562 PCI vesa
Chip: 1  is -> NVidia GeForce2 MX/MX 400        01:10:0 0x10de 0x0110 AGP nv
Comment 25 Guek Wu Neo 2008-12-24 00:14:57 UTC
continue on comment#24, the display on the one monitor is as mentioned in comment#14 when intel driver is used.

If vesa or fbdev is used, the display on the one monitor is as mentioned in comment#22
Comment 26 qwang13 2008-12-31 00:20:51 UTC
Just reminder one point,  This release of beta6 graphics doesn't have all packages of Intel Q3 release. I am not sure if you have packages the latest driver from SLE11-RC1 factory. RC1 should have Q3 release at all. 

If possible, please have a try. Of course, if you packages intel Q3 release seperately, that is fine.

Thanks
Comment 27 Stefan Dirsch 2009-01-02 07:25:19 UTC
openSUSE 11.1/Novell SLE11 specific
-----------------------------------

  * The issue is that sax2, which runs during installation (and also on 
    LiveCD), does not use Xserver's "-br" option yet and the problem only 
    occurs when this option is not being set. This is the reasons why 
    xdm/gdm/kdm, which now use "-br" option by default, work after 
    installation (after being forced to reboot). Still it's a driver bug.
Comment 28 Vance 2009-01-05 02:17:27 UTC
Hi qwang13, testing has been done on SLED 11 RC1 version already, so from what you mentioned, the graphics packages should be included. We still see the gdm display error when intel driver is used.

Hi Stefan, just to understand your comment a little better, do you mean that during installation we will encounter the error when sax2 attempts to configure the graphics hardware but not post installation? On our machine(563), sax uses VESA for the graphics driver by default so we have to manually change to intel when testing and it is during this process where we will see the display failure. 
Comment 29 Stefan Dirsch 2009-01-05 02:49:32 UTC
Vance, whenever you run 'sax2 -r' or start it from Linux console and use intel driver for 845G you'll run into this situation, since sax2 doesn't use always Xserver's '-br' option. This will be 'fixed' in SaX2 (I consider this a driver bug) in SLE11 RC2.
Comment 30 Vance 2009-01-13 00:11:08 UTC
Hi Michael, based on the Stefan's comments, do you have anything to comment on what needs to be done on the video driver on your side? 
Comment 31 Vance 2009-01-13 23:38:53 UTC
Hi Stefan, about the option -br you mentioned, am I right to say that it is an internal parameter of the sax2 program and not part of the command e.g. sax2 -br? 
Comment 32 Stefan Dirsch 2009-01-14 01:30:10 UTC
-br is an Xserver option.

# Xorg --help
-br                    create root window with black background
Comment 33 Vance 2009-01-14 02:19:18 UTC
Thanks for clarifying. So this means if I start the machine in init3 mode, then manually run Xorg -br, I should be able to replicate the effect of the fix?
Comment 34 Stefan Dirsch 2009-01-14 02:49:47 UTC
Somewhat. There's no fix for Xorg/intel driver. With -br Xserver starts fine, withou this option it hangs.
Comment 35 Vance 2009-01-19 01:45:01 UTC
(In reply to comment #30)
> Hi Michael, based on the Stefan's comments, do you have anything to comment on
> what needs to be done on the video driver on your side? 
> 

Hi Michael, can you provide feedback based on my previous question?
Comment 36 Vance 2009-01-19 01:57:44 UTC
Hi Stefan, since RC2 was delayed slightly, I decided to try running Xorg -br in init3 to try the fix but recieved an error saying no screens found. Would it be helpful to you if I provide the Xorg.log?
Comment 37 Stefan Dirsch 2009-01-19 02:38:07 UTC
Vance, RC2 should be available *very* soon.
Comment 38 Vance 2009-01-21 22:43:18 UTC
Created attachment 22143 [details]
Xorg log in debug mode

I tried using intel driver after installing SLES11 RC2 on the machine and I am still getting this error message:

gdm[2949]: WARNING: GdmLocalDisplayFactory: maximum number of X display failures reached: check X server log for errors
Comment 39 Vance 2009-01-21 22:44:14 UTC
Created attachment 22144 [details]
Xorg configuration used
Comment 40 Wang Zhenyu 2009-01-22 19:19:21 UTC
Using 'intel' driver on this 845GV seems not work, as it uses DVO LVDS, our driver has no support. But we also can't make VGA output to work on it, does anyone know why? (BIOS and vesa both can't light it up too)
Comment 41 Vance 2009-01-28 23:06:46 UTC
Hi Zhenyu,

        Here's another update on the testing we have done. We have altogether 4 machines that uses the i845G chipset, 3 of them connects to external displays and one has an integrated display. We tested SLES 11 RC2 on all four machines. On the machines that uses external displays, we could get all of them to function properly in X only when the "noaccel" option is set to true. Without this option, X would hang after logging in. Is it possible to make the display work without disabling acceleration? 

The machine with the integrated display is the one I have been using to provide the logs and is the one with the DVO LVDS issue you mentioned. The dislay works fine when using vesafb or fbdev. I wonder if Novell has any input on this? 
Comment 42 Michael Fu 2009-01-31 18:50:28 UTC
(In reply to comment #41)
> Hi Zhenyu,
> 
>         Here's another update on the testing we have done. We have altogether 4
> machines that uses the i845G chipset, 3 of them connects to external displays
> and one has an integrated display. We tested SLES 11 RC2 on all four machines.
> On the machines that uses external displays, we could get all of them to
> function properly in X only when the "noaccel" option is set to true. Without
> this option, X would hang after logging in. Is it possible to make the display
> work without disabling acceleration? 

this matches the behavior of our machine here.

> 
> The machine with the integrated display is the one I have been using to provide
> the logs and is the one with the DVO LVDS issue you mentioned. The dislay works
> fine when using vesafb or fbdev. I wonder if Novell has any input on this? 
> 

Have you tried the VGA on this kind of 845G machine? I have a sample from you, it never works ever since press the power button. That's why we think this is a HW/FW issue.
Comment 43 Vance 2009-02-01 21:58:02 UTC
(In reply to comment #42)
> > The machine with the integrated display is the one I have been using to provide
> > the logs and is the one with the DVO LVDS issue you mentioned. The dislay works
> > fine when using vesafb or fbdev. I wonder if Novell has any input on this? 
> > 
> 
> Have you tried the VGA on this kind of 845G machine? I have a sample from you,
> it never works ever since press the power button. That's why we think this is a
> HW/FW issue.
> 

Hi, Micheal. Happy New Year to you. So you mean the redwood machine we shipped to you doesn't even boot up? Can you elaborate on what you mean by trying vga on this machine?
Comment 44 Michael Fu 2009-02-01 22:08:24 UTC
it can boot, but only show things on the LVDS panel. There is a VGA D-sub connector on the back. After connect a VGA monitor to it, it's always black ever since power the machine on ( No bios info, no Linux messages, nothing ... )
Comment 45 Antonio Quizon 2009-02-01 23:17:15 UTC
michael i think your talking about the secondary vga. but why are you doing that, does it because the lcd panel does not work? i cant remember if i send it to you disconnected but it should be easier for you to identify how to connect it  back.  

i got 3 more machines with the same chipsets working, so I cant understand why it shouldnt for Redwood. 
Comment 46 Michael Fu 2009-02-01 23:50:43 UTC
ok. so it's a known issue? I'm not bothering to play with it. I thought you are going to use a dual play on it...

if only LVDS panel is used, why not just use VESA driver, if you only need basic display function? support to 845G is becoming legacy in our driver.
Comment 47 Antonio Quizon 2009-02-02 00:10:52 UTC
we need dual video support for this machine, thats why we need the 845 driver to work with the primary chipset then we can test the dual video. Right now we are using vesa and we are unable to detect the secondary video.

could you please help us to work on this? as i stated earlier 3 more machines are found working and we dont know why it is not for redwood, the main difference is redwood offers dual video but using a different video card. 
Comment 48 Michael Fu 2009-02-02 00:15:26 UTC
sorry, even bios can't light it up... I'm afraid we can't help. That's why I'm wonderring if it's a HW or FW issue.. Are you using a NV or ATI card in the as the secondary display? that will make things even worse.
Comment 49 Stefan Dirsch 2009-02-02 02:56:56 UTC
(In reply to comment #41)
> Hi Zhenyu,
> 
> Here's another update on the testing we have done. We have altogether 4
> machines that uses the i845G chipset, 3 of them connects to external displays
> and one has an integrated display. We tested SLES 11 RC2 on all four machines.
> On the machines that uses external displays, we could get all of them to
> function properly in X only when the "noaccel" option is set to true. Without
> this option, X would hang after logging in. Is it possible to make the display
> work without disabling acceleration? 

I don't need this option on our 845G machines (FSC + Dell Optiplex GX260)

> The machine with the integrated display is the one I have been using to provide
> the logs and is the one with the DVO LVDS issue you mentioned. The dislay works
> fine when using vesafb or fbdev. I wonder if Novell has any input on this? 

We don't have such a machine at Novell.

Comment 50 Vance 2009-02-04 02:20:42 UTC
Hi Michael, I probably should elaborate our test situation with the Redwood. This machine is the only one that uses an integrated intel i845 chipset with an add-on nvidia Geforce2 MX 400 graphics adapter. For single display(integrated), using intel drivers will give a gdm display error as I have mentioned before. Using vesa/fbdev works perfectly fine. However, when we use vesa in dual display(attaching an external display to nvidia card) mode, there would be no display on the secondary display while the primary display works. 

On a similar machine but using an intel i915 chipset and Ati graphics card, we could get the dual display to work when using intel/radeon driver where using vesa/radeon will give a blank screen on the secondary display(similar to above situation). I hope this clears up the reason why we need to try a working intel driver on this platform.

I also have a test update on SLED 11 RC3:

I reported on RC2 that the three machines that does not use an LVDS output worked with the "NoAccel" "yes" option. In RC3, even with this option, I get a white screen after logging in. I will attaching the screen shot and the Xorg.log with debug on. Any idea what might have changed in RC3 to effect this, Stefan?

Comment 51 Vance 2009-02-04 02:25:37 UTC
Created attachment 22568 [details]
Screen capture of hanged screen
Comment 52 Vance 2009-02-04 02:26:44 UTC
Created attachment 22569 [details]
Xorg.log
Comment 53 Stefan Dirsch 2009-02-04 02:30:39 UTC
> I also have a test update on SLED 11 RC3:
>
> I reported on RC2 that the three machines that does not use an LVDS output
> worked with the "NoAccel" "yes" option. In RC3, even with this option, I get a
> white screen after logging in. I will attaching the screen shot and the
> Xorg.log with debug on. Any idea what might have changed in RC3 to effect this,
> Stefan?

No idea, there weren't any changes for intel driver between RC2 and RC3. No changes for xorg-server, Mesa, libdrm either.
Comment 54 Michael Fu 2009-02-04 05:37:01 UTC
(In reply to comment #50)
> Hi Michael, I probably should elaborate our test situation with the Redwood.
> This machine is the only one that uses an integrated intel i845 chipset with an
> add-on nvidia Geforce2 MX 400 graphics adapter. For single display(integrated),
> using intel drivers will give a gdm display error as I have mentioned before.
> Using vesa/fbdev works perfectly fine. However, when we use vesa in dual
> display(attaching an external display to nvidia card) mode, there would be no
> display on the secondary display while the primary display works. 
> 
> On a similar machine but using an intel i915 chipset and Ati graphics card, we
> could get the dual display to work when using intel/radeon driver where using
> vesa/radeon will give a blank screen on the secondary display(similar to above
> situation). I hope this clears up the reason why we need to try a working intel
> driver on this platform.

we didn't test that, so I don't know how to help you here...

> 
> I also have a test update on SLED 11 RC3:
> 
> I reported on RC2 that the three machines that does not use an LVDS output
> worked with the "NoAccel" "yes" option. In RC3, even with this option, I get a
> white screen after logging in. 
>

I'm confused... Have you ever opened about about this? I mean is there a bug in which we tell you to use "NoAccel" "Yes" to work around? If yes, pls comment on that bug, rather than this bug... thanks.

Comment 55 Vance 2009-02-04 22:30:13 UTC
Michael, this bug was opened for for machines with i845 chipsets having issues with the intel driver included in SLES/D 11. This includes the four machines I mentioned in Comment#41. They were grouped together into this bug because all four uses the same chipset and had the same error when using intel drivers. The NoAccel option was suggested by yourself in Comment#5. We try to use the device options you have mentioned in this thread when we test.

A further update on the three machines I mentioned that requires the NoAccel option, I have verified that in SLES11 RC3 I was able to login and see the desktop with this option(with intel driver). In SLED11 RC3, X would freeze up with a white screen after I logged in. 

Stefan, could it be any application in SLED that is causing this? If so, how I can help to determine which is it?
Comment 56 Stefan Dirsch 2009-02-04 23:57:39 UTC
Maybe Gnome tries to start compiz or KDE its KDE desktop effects. I suggest to try a failsafe Xsession instead to verify this.
Comment 57 Vance 2009-02-05 00:17:47 UTC
(In reply to comment #56)
> Maybe Gnome tries to start compiz or KDE its KDE desktop effects. I suggest to
> try a failsafe Xsession instead to verify this.
> 

You are right Stefan. After uninstalling Compiz from SLED it works just the same as in SLES.
Comment 58 Michael Fu 2009-03-01 19:16:22 UTC
I think finally, this eventually can be concluded as a DVO-LVDS support request. Unfortunately, this is unlikely happen given this DVO support is really becoming legacy

The other lesson we learned is,  we finally know that this platform use a NV card to provide VGA output.. it sounds like there are other "Redwood" system that doesn't use Nv card, while Intel chip provide the VGA output. This is really confusing .. Maybe from your side, they are all Redwood, but for us it's totally different thing and shouldn't be put together in one bug report.

We really should make sure we are talking about just _one_ platform in one bug...
Comment 59 Vance 2009-03-01 22:55:49 UTC
Hi Michael,

The reason we used this bug report for four platforms was because they were using the same chipset and experiencing the same issues in the beginning. But I see you point and agree too that for future bug threads, we will use a separate bug to track each platform, and let them be marked duplicates if found to be as such.

So just to confirm with you that DVO-LVDS support will not be provided for the intel drivers? If so it means we can only use vesa driver and not have dual display support for this machine.
Comment 60 Michael Fu 2009-03-01 23:58:11 UTC
(In reply to comment #59)
> Hi Michael,
> 
> So just to confirm with you that DVO-LVDS support will not be provided for the
> intel drivers? If so it means we can only use vesa driver and not have dual
> display support for this machine.
> 

yes.