Bug 19130 - [GEM] xdemo/glsync gets no sync
Summary: [GEM] xdemo/glsync gets no sync
Status: VERIFIED INVALID
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium normal
Assignee: Jesse Barnes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 18841
  Show dependency treegraph
 
Reported: 2008-12-17 00:37 UTC by lin, jiewen
Modified: 2009-01-03 19:07 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
conf (3.70 KB, text/plain)
2008-12-17 00:37 UTC, lin, jiewen
Details
log (44.22 KB, text/plain)
2008-12-17 00:38 UTC, lin, jiewen
Details
screenshot (9.68 KB, image/png)
2008-12-17 00:38 UTC, lin, jiewen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lin, jiewen 2008-12-17 00:37:23 UTC
Created attachment 21231 [details]
conf

System Environment:
--------------------------

--Platform: 965
--Architecture(32-bit,64-bit,compatiblity): 32-bit
--2D driver: (xf86-video-intel-2.6-branch)83f3c376b5942e134047a220e6e5f2432ffc492c
--3D driver: (intel-2008-q4)0d5b1e591b7fb2cf3109b7e147bb3ea6aa8f8b15
--DRM:shipped with kernel 2.6.28-rc8 for-airlied
--libdrm: (master)c86d431fe6174b1c2de531929213ea7dbd92326d
--Xserver: (server-1.6-branch)32e81074b967716865aef08b66ec29caf0fec2c5
--Kernel: 2.6.28-rc8 for-airlied

Bug detailed description:
--------------------------
start X and run glsync, but get no sync in the window.

Reproduce steps:
----------------
1. xinit &
2. ./mesa/progs/xdemo/glsync
Comment 1 lin, jiewen 2008-12-17 00:38:01 UTC
Created attachment 21232 [details]
log
Comment 2 lin, jiewen 2008-12-17 00:38:46 UTC
Created attachment 21233 [details]
screenshot
Comment 3 Gordon Jin 2008-12-17 00:58:09 UTC
Jesse/Eric, is this a current known issue? I'm not sure how big the impact is, and if this should block Q4 release.
Comment 4 Jesse Barnes 2008-12-31 11:59:38 UTC
You need to pass an option to glsync, otherwise it will show you what tearing looks like.  Have you tried that?  glsync -h should give you help, or you can just read the comments in glsync.c.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.