Bug 19140 - Xorg hang [drm:radeon_cp_idle] *ERROR* radeon_cp_idle called without lock held [1002:5961]
Summary: Xorg hang [drm:radeon_cp_idle] *ERROR* radeon_cp_idle called without lock hel...
Status: RESOLVED DUPLICATE of bug 7128
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: 7.3 (2007.09)
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
URL: https://bugs.edge.launchpad.net/ubunt...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-17 11:52 UTC by Bryce Harrington
Modified: 2010-03-26 19:09 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (87.21 KB, patch)
2008-12-17 11:55 UTC, Bryce Harrington
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Bryce Harrington 2008-12-17 11:52:21 UTC
Forwarding this bug from a Ubuntu reporter:
https://bugs.edge.launchpad.net/ubuntu/+bug/305458

[Problem]
X gets stuck in a loop, reporting the following error to dmesg:

 [drm:radeon_cp_idle] *ERROR* radeon_cp_idle called without lock held, held 0 owner ed9589c0 ee2e0880

[lspci]
01:05.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200] 0300: 1002:5961 (rev 01)
        Subsystem: C.P. Technology Co. Ltd Device 2063
	Subsystem: 148c:2063

[Original Report]
When attempting to run a 3d game such as Enemy Territory or a game via wine X crashes and locks up. I am still able to ssh into the system but unable to kill X in any way. Exactly the same thing happens using the kernel from Hardy so I'm inclined to believe this not a kernel issue.

dmesg is entirely filled with:
Dec 5 11:23:39 smithers kernel: [ 126.311404] [drm:radeon_cp_idle] *ERROR* radeon_cp_idle called without lock held, held 0 owner ed9589c0 ee2e0880
Dec 5 11:23:39 smithers kernel: [ 126.313311] [drm:radeon_cp_reset] *ERROR* radeon_cp_reset called without lock held, held 0 owner ed9589c0 ee2e0880
Dec 5 11:23:39 smithers kernel: [ 126.316425] [drm:radeon_cp_start] *ERROR* radeon_cp_start called without lock held, held 0 owner ed9589c0 ee2e0880

01:05.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200] (rev 01)
        Subsystem: C.P. Technology Co. Ltd Device 2063

$ lsb_release -rd
Description: Ubuntu 8.10
Release: 8.10

$ apt-cache policy linux-image-generic
linux-image-generic:
  Installed: 2.6.27.9.13
  Candidate: 2.6.27.9.13
  Version table:
 *** 2.6.27.9.13 0
        500 http://ubuntu.virginmedia.com intrepid-updates/main Packages
        500 http://ubuntu.virginmedia.com intrepid-security/main Packages
        100 /var/lib/dpkg/status
     2.6.27.7.11 0
        500 http://ubuntu.virginmedia.com intrepid/main Packages
Comment 1 Bryce Harrington 2008-12-17 11:55:09 UTC
Created attachment 21247 [details] [review]
Xorg.0.log
Comment 2 Dave Airlie 2008-12-18 01:12:00 UTC
is the user running compiz or kwin effects?
Comment 3 Bryce Harrington 2008-12-18 09:34:43 UTC
Yes, the user only sees the issue manifest while desktop effects (kde 4.1.3) is on.
Comment 4 Michel Dänzer 2008-12-22 04:51:45 UTC
(In reply to comment #3)
> Yes, the user only sees the issue manifest while desktop effects (kde 4.1.3) is
> on.

Then it could be the same problem as bug 7128 / https://bugzilla.redhat.com/show_bug.cgi?id=445331 and friends, due to the AIGLX code dereferncing a stale DrawablePtr.

However, I thought there was a workaround for this in KDE 4.1.3... but maybe that only applies when disabling kwin compositing, and the problem can still be triggered in other circumstances such as the ones described here.
Comment 5 Radosław Warowny 2009-03-03 12:30:05 UTC
The same issue affects also system without deskop effects activated. The system is Ubuntu 8.10, AMD64, Gnome desktop, RV350.
Comment 6 Radosław Warowny 2009-03-04 14:37:42 UTC
After changing AccelMethod option from default (XAA) to EXA the symptoms changes to X server restart instead of system hang with the following messages appearing in X log file:

Backtrace:
0: /usr/X11R6/bin/X(xf86SigHandler+0x65) [0x480f35]
1: /lib/libc.so.6 [0x7f00ee79f0a0]
2: /usr/lib/xorg/modules/extensions//libglx.so(__glXDeassociateContext+0x75) [0x7f00edc7a3b5]
3: /usr/lib/xorg/modules/extensions//libglx.so(__glXContextDestroy+0xf) [0x7f00edc766ef]
4: /usr/lib/xorg/modules/extensions//libglx.so [0x7f00edc82902]
5: /usr/lib/xorg/modules/extensions//libglx.so(__glXFreeContext+0x6c) [0x7f00edc788ac]
6: /usr/lib/xorg/modules/extensions//libglx.so [0x7f00edc788f3]
7: /usr/X11R6/bin/X(FreeResourceByType+0x105) [0x435505]
8: /usr/lib/xorg/modules/extensions//libglx.so [0x7f00edc751fe]
9: /usr/lib/xorg/modules/extensions//libglx.so [0x7f00edc78bd2]
10: /usr/X11R6/bin/X(Dispatch+0x364) [0x44d6e4]
11: /usr/X11R6/bin/X(main+0x45d) [0x4336fd]
12: /lib/libc.so.6(__libc_start_main+0xe6) [0x7f00ee78a466]
13: /usr/X11R6/bin/X [0x432ad9]
Saw signal 11.  Server aborting.
Comment 7 Corbin Simpson 2010-03-26 19:09:57 UTC
Marking this bug as a duplicate of #7128. Please open a new bug if this still happens with KMS.

*** This bug has been marked as a duplicate of bug 7128 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.