Bug 19149 - [945GM] occasional crash under high load. Ring lockups
Summary: [945GM] occasional crash under high load. Ring lockups
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915 (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: haihao
QA Contact:
Depends on: 14539
  Show dependency treegraph
Reported: 2008-12-17 18:32 UTC by haihao
Modified: 2009-08-24 12:31 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Description haihao 2008-12-17 18:32:01 UTC
+++ This bug was initially created as a clone of Bug #14539 +++

Created an attachment (id=14373)
dmesg, xorg.conf, Xorg.0.log/old

I got a crash with when my laptop was under high memory
pressure and load. I've attached the two Xorg.log files from /var/log as
they both had the same timestamp. I think it is Xorg.log rather than
Xorg.log.old though. I didn't have any GL apps running at the time, just
xchat, gnome-terminal, liferea, galeon and evolution. I was compiling a
big C++ app (synfig) with -j2 at the time, which caused the memory

I occasionally get crashes, the result is usually that the screen is messed up (purple mess at the top) but the kernel is fine, so pressing the power button results in a graceful shutdown. I'm using a Dell Inspiron 6400 laptop.

$ lspci -n | grep 00:02
00:02.0 0300: 8086:27a2 (rev 03)
00:02.1 0380: 8086:27a6 (rev 03)
$ lspci | grep 00:02
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
$ uname -m
$ dpkg -s xserver-xorg-video-intel xserver-xorg xserver-xorg-core libdrm2 libgl1-mesa-dri | egrep '(Version|Package)'
Package: xserver-xorg-video-intel
Version: 2:
Package: xserver-xorg
Version: 1:7.3+10
Package: xserver-xorg-core
Version: 2:1.4.1~git20080131-1
Package: libdrm2
Version: 2.3.0-4
Package: libgl1-mesa-dri
Version: 7.0.2-4
$ uname -r
$ cat /etc/lsb-release 
$ xrandr --verbose
Screen 0: minimum 320 x 200, current 1280 x 800, maximum 2048 x 2048
VGA disconnected (normal left inverted right x axis y axis)
	Identifier: 0x4b
	Timestamp:  174813
	Subpixel:   unknown
	CRTCs:      0 1
LVDS connected 1280x800+0+0 (0x4e) normal (normal left inverted right x axis y axis) 331mm x 207mm
	Identifier: 0x4c
	Timestamp:  174813
	Subpixel:   horizontal rgb
	CRTC:       1
	CRTCs:      1
		supported: native       legacy       combination  kernel      
	BACKLIGHT: 100 (0x00000064) range:  (0,100)
  1280x800 (0x4e)   71.1MHz -HSync -VSync
        h: width  1280 start 1328 end 1360 total 1440 skew    0 clock   49.4KHz
        v: height  800 start  802 end  808 total  823           clock   60.0Hz
  1280x800 (0x4f)   83.5MHz
        h: width  1280 start 1344 end 1480 total 1680 skew    0 clock   49.7KHz
        v: height  800 start  801 end  804 total  828           clock   60.0Hz
  1280x768 (0x50)   80.1MHz
        h: width  1280 start 1344 end 1480 total 1680 skew    0 clock   47.7KHz
        v: height  768 start  769 end  772 total  795           clock   60.0Hz
  1024x768 (0x51)   65.0MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock   48.4KHz
        v: height  768 start  771 end  777 total  806           clock   60.0Hz
  800x600 (0x52)   40.0MHz +HSync +VSync
        h: width   800 start  840 end  968 total 1056 skew    0 clock   37.9KHz
        v: height  600 start  601 end  605 total  628           clock   60.3Hz
  640x480 (0x53)   25.2MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock   31.5KHz
        v: height  480 start  490 end  492 total  525           clock   59.9Hz
TV disconnected (normal left inverted right x axis y axis)
	Identifier: 0x4d
	Timestamp:  174813
	Subpixel:   unknown
	CRTCs:      0 1
	BOTTOM: 37 (0x00000025) range:  (0,100)
	RIGHT: 46 (0x0000002e) range:  (0,100)
	TOP: 36 (0x00000024) range:  (0,100)
	LEFT: 54 (0x00000036) range:  (0,100)
		supported: NTSC-M       NTSC-443     NTSC-J       PAL-M       
		           PAL-N        PAL
Comment 1 haihao 2008-12-30 17:30:52 UTC
Hi, Paul
   It seems the latest xf86-video-intel driver fixes intermittent crashes on 945GM (see bug #17638), could you try it?

Comment 2 Paul Wise 2008-12-30 17:52:25 UTC
Due to the lenny freeze, Debian doesn't yet have the required versions of libdrm & xf86-video-intel. Once they are packaged, I'll update to them. I haven't had the crash in quite a while though (see the info in the old bug).
Comment 3 Gordon Jin 2009-04-15 01:27:16 UTC
Paul, any update? Have you tried newer driver? 
Comment 4 Paul Wise 2009-04-15 01:34:56 UTC
Not yet, sorry. I'm waiting for security support for Debian testing/squeeze before I upgrade my laptop to squeeze/sid. Also there are a couple of transitions in sid I'm waiting for, Xorg being one of the not-so-fun sounding ones.
Comment 5 Eric Anholt 2009-06-30 20:07:04 UTC
Feedback timeout at 6 months.  (We're pretty sure we fixed it)
Comment 6 Paul Wise 2009-07-02 08:04:08 UTC
This still occurs in 2.3.2 in Debian lenny/squeeze, is there any patch for that version?
Comment 7 Adam Jackson 2009-08-24 12:31:25 UTC
Mass version move, cvs -> git

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.