Bug 19270 - [UXA] arbnpot-mipmap has a wrong output
Summary: [UXA] arbnpot-mipmap has a wrong output
Status: VERIFIED DUPLICATE of bug 19174
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Eric Anholt
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-23 22:33 UTC by zhao jian
Modified: 2009-07-13 23:28 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg.conf (3.79 KB, text/plain)
2008-12-23 22:34 UTC, zhao jian
Details
xorg.0.log (65.92 KB, text/plain)
2008-12-23 22:34 UTC, zhao jian
Details
arbnpot_mapmap_UXA (865.67 KB, image/x-png)
2008-12-23 22:35 UTC, zhao jian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zhao jian 2008-12-23 22:33:33 UTC
System Environment:
----------------------
Host:          gm45
Arch:          i386
OSD:            Fedora release 10 (Cambridge)
Kernel:    2.6.28-rc9
Libdrm:         (master)c86d431fe6174b1c2de531929213ea7dbd92326d
Mesa:            (intel-2008-q4)0d5b1e591b7fb2cf3109b7e147bb3ea6aa8f8b15
Xserver:     (server-1.6-branch)32e81074b967716865aef08b66ec29caf0fec2c5
Xf86_video_intel:      (xf86-video-intel-2.6-branch) 83f3c376b5942e134047a220e6e5f2432ffc492c
GEM Kernel: (for-airlied branch)  88493410cbe68eb267c540fbb0f6809a1a4124d6


Bug Description:
---------------------
On gm45 with UXA enabled, there will be some problems when run arbnpot-mipmap. With the 'xcompmgr' off, the picture is out of the window.(As shown in the attachment)When drag the window away the picture still showing there, and if you drag the window back to the pic, that pic will be refreshed. If you change the window size, the pic will change correspondingly. 
With the 'xcompmgr' on, at first the picture is out of the window too. But if you move the window away there will be no pic outside the window. 

Reproduce steps:
----------------
1.enable UXA
2.xinit&
3. gnome-session&
4. mesa/progs/tests/arbnpot-mipmap
Comment 1 zhao jian 2008-12-23 22:34:01 UTC
Created attachment 21460 [details]
xorg.conf
Comment 2 zhao jian 2008-12-23 22:34:25 UTC
Created attachment 21461 [details]
xorg.0.log
Comment 3 zhao jian 2008-12-23 22:35:39 UTC
Created attachment 21462 [details]
arbnpot_mapmap_UXA
Comment 4 Eric Anholt 2008-12-27 16:47:57 UTC

*** This bug has been marked as a duplicate of bug 19174 ***
Comment 5 zhao jian 2009-07-13 23:28:36 UTC
Now it works well both in KMS and UMS. Verified with 
Libdrm:         (master)3f3c5be6f908272199ccf53f108b1124bfe0a00e
Mesa:           (master)59155f70e701bc0b4fb816da991d6921f53b3bc7
Xserver:                (master)cc575a3ba4a52265e410b325c2291fe900a54f33
Xf86_video_intel:       (master)b74bf3f9a65af9e72921d4e9028d9d4d023f8bc6
Kernel:         (drm-intel-next)5019914ca3b7517b2d82db2e92e3f683ac48e535


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.