Bug 19316 - [q965 G965 Glean]Glean case/texCombine run failed
Summary: [q965 G965 Glean]Glean case/texCombine run failed
Status: VERIFIED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: Eric Anholt
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: intel-3d-release
  Show dependency treegraph
 
Reported: 2008-12-28 21:23 UTC by liuhaien
Modified: 2009-11-05 01:41 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xorg.0.log (61.20 KB, text/plain)
2008-12-28 21:23 UTC, liuhaien
Details
xorg conf file (3.67 KB, text/plain)
2008-12-28 21:23 UTC, liuhaien
Details

Note You need to log in before you can comment on or make changes to this bug.
Description liuhaien 2008-12-28 21:23:02 UTC
Created attachment 21534 [details]
xorg.0.log

System Environment:
--------------------------
Host:		x-q965
Arch:		i386
OSD:		Fedora release 8 (Werewolf)
Kernel:		2.6.28-release
Libdrm_stable:		(master)c34539e8bb5568b1d6059abf139dd08e07e84eea
Mesa_stable:		(intel-2008-q4)88f4b17555be36f3023f74a1b9c792294f09912b
Xorg:		7.2
Xserver_stable:	(server-1.6-branch)32e81074b967716865aef08b66ec29caf0fec2c5
Xf86_video_intel_stable: (xf86-video-intel-2.6-branch)
                               892cb5db6fd4c5cc692bc74a2615860f27e9feff


Bug detailed description:
-------------------------
startx ,then run glean case/texCombine, it will run too slow(more than 30 minutes) and get a failure at the end of testing. but it works and run fast with software rendering.and this issue only happens on q965,it is ok on G45 and gm45.

Reproduce steps:
----------------
1.xinit&
2.run glean case/texCombine
Comment 1 liuhaien 2008-12-28 21:23:21 UTC
Created attachment 21535 [details]
xorg conf file
Comment 2 Eric Anholt 2008-12-29 11:35:39 UTC
this is your q965 with the readpixels troubles, right?
Comment 3 liuhaien 2008-12-29 17:19:46 UTC
(In reply to comment #2)
> this is your q965 with the readpixels troubles, right?
> 

No,readpixels works on q965.
Comment 4 liuhaien 2008-12-29 18:23:10 UTC
I find it worked on 2008-11-19 with below commit:
Libdrm:		(master)930c0e7cf4f4776f7a69e7acc6fedeed7addb235
Mesa:		(master)80d6379722a1249ce13db79a898d340644936f67
Xserver:		(master)08cd361234ed0410f67342f46ae01120c4fe3331
Xf86_video_intel:		(master)30c29627c859f1f6780aa652d6de4fa985b63dd0
Comment 5 liuhaien 2008-12-29 21:31:33 UTC
following is the output when running texCombine:
--------------------------------------------
do_wait: drmWaitVBlank returned -1, IRQs don't seem to be working correctly.
Try adjusting the vblank_mode configuration parameter.
--------------------------------------------

when setting vblank_mode=0, this case can work well.
Comment 6 liuhaien 2009-01-04 17:27:42 UTC
the issue also happens on G965.but works on other platforms.
Comment 7 Eric Anholt 2009-01-07 02:38:30 UTC
oh, vblank troubles.  had you done some VT switches previously in your testing with this X Server instance?  If so, this is probably just a dupe of the other "vt switch and your vblank irqs stop" bugs.
Comment 8 liuhaien 2009-01-07 23:29:10 UTC
(In reply to comment #7)
> oh, vblank troubles.  had you done some VT switches previously in your testing
> with this X Server instance?  If so, this is probably just a dupe of the other
> "vt switch and your vblank irqs stop" bugs.
> 

no,I hadn't.
I have tried it with Jesse's patch (bug 18879),but this case still timeout.
Comment 9 liuhaien 2009-03-22 19:26:41 UTC
still fails against:
Libdrm:         (master)00d8e960ca665b7f0528438331f4d0ae77fbb4cc
Mesa:(mesa_7_4_branch)b009a32bf428192fef2dc4787d25f022a472854f          
Xserver:        (server-1.6-branch)60c161545af80eb78eb790a05bde79409dfdf16e
Xf86_video_intel:       (2.7)e2465249a90b9aefe6d7a96eb56a51fde54698a0
Kernel:       (for-airlied)a2e785c32b886dd7f0289d1cf15fc14e9c81bc01
Comment 10 zhao jian 2009-11-05 01:41:11 UTC
It passes now on q965 and G45. it can finish in 30 min without --quick option, and will need 2 hours more only finished two times.(it will repeat many times)
Libdrm:         (master)b7ed162d2912d53d03d94f9ceaebf7d96d570c04
Mesa:           (master)898de4a9d5e47ed32c600e5907476fd9338aa7e9
Xserver:         (master)7442f3355ab8f0bb2b1a270da18c65d8d315d4dd
Xf86_video_intel:      (master)10946118dd3a63f1375a1bfde0b2f0542a93c1c2
Kernel:         (drm-intel-next)a83a4400415893d2599a256f6842ac4d871dffd7


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.