Bug 19319 - Intel driver crashes x.org and/or virtual consoles
Intel driver crashes x.org and/or virtual consoles
Status: RESOLVED DUPLICATE of bug 17638
Product: xorg
Classification: Unclassified
Component: Driver/intel
7.4 (2008.09)
x86 (IA32) Linux (All)
: medium critical
Assigned To: Gordon Jin
Xorg Project Team
: NEEDINFO
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-29 10:02 UTC by Harald Nikolisin
Modified: 2009-02-18 01:39 UTC (History)
6 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log when only the virtual consoles crashed (29.43 KB, application/octet-stream)
2009-01-11 06:26 UTC, Harald Nikolisin
no flags Details
Xorg.0.log when also the X-session itself freezed (22.07 KB, application/octet-stream)
2009-01-11 06:26 UTC, Harald Nikolisin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Nikolisin 2008-12-29 10:02:49 UTC
First of all I'm used this machine for nearly 2 years without any X.org/Intel problems on SuSE Linux 10.1 (cames x.org 7.3).
The 3 capability wasn't that good, and I have to use i915resolution, but it was ok.

I reinstalled the computer this year with openSUSE 11.0 (I think . After 2-3 weeks of testing, I had the problem that the virtual consoles sometimes crashing (after pressing F1-F6 or the syslog with F10) - they never reappear, also not after
init 3
init 5

well, after the recommendation of Stefan Dirsch from Novell, I used the x.org software repository to update everything related to x.org from 7.3 to 7.4

After 2-3 MONTHS of testing I found myself in following situation:

- I sometimes switches to the virtual consoles - crash of these consoles every 2nd day (mostly when I want to switching to it, rarely when I'm logging in/out of an KDE session) - They never reappear (except rebooting)

- Once per week also my x.org session get's destroyed. When I'm in a session I found myself at the kdm login manager

- Once per week the whole x.org system crashes when I'm logging in/out of an KDE session. If that happens I cannot see else as garbage on the monitor and nothing of x.org never reappears. I MUST REBOOT THE MACHINE from another host via ssh!

This are the major 3 points. Additionly 3D functionality is completely broken! I cannot see a reasonable output of any openGL program (like GoogleEarth,KDE-kubrick...)

This is an excerpt of my xorg.conf:

Section "Device"
  BoardName    "945 GM"
  BusID        "0:2:0"
  Driver       "intel"
  Identifier   "Device[0]"
  Option       "monitor-LVDS" "Monitor[0]"
  VendorName   "Intel"
EndSection

How can I achieve a stable desktop? I'm using Linux at home & at work since years but this is really the worst thing I ever saw! X.org is after the kernel the most important piece of software - I cannot work without it. I don't want to save files every 10 seconds. The desktop must remain STABLE.
What for a regression are you introducing with x.org/intel in the last time.
I can live without 3D capabilities, but please say what I should do for a STABLE desktop - because this is a production machine (should be possible with Linux, or not).

I can provide you with all information you'll need!

System environment:
chipset: ?
xf86-video-intel: 2.5
xserver: 7.4
mesa: 1.4 Mesa 7.2
drm: Mesa DRI Intel(R) 945GM 20080716 x86/MMX/SSE2
kernel: 2.6.25.18-0.2-pae
Linux distribution: openSUSE 11.0
Machine or mobo model: Hush Technologies B3 (2006)
Display connector: TFT Philips 200W 1680 x 1050
Comment 1 Harald Nikolisin 2008-12-29 13:43:58 UTC
sorry for the confusing english at the beginning. I'm feeling sick today (not related to x.org)
I want to say that the old SuSE Linux came with x.org 6.x (probably 6.8) and openSUSE 11.0 came with x.org 7.3
Second sentence is "The 3D capability wasn't that good".

 
Comment 2 Gordon Jin 2008-12-29 18:40:12 UTC
This is probably duped with bug#14464 or 16780 or 17638, so I'm decreasing priority for now.

Could you try any of following workaround in xorg.conf to see if any of them works:
1) add AccelMethod XAA
2) add Option "ExaNoComposite" "true"
3) add Option "DRI" "false"

And please attach Xorg.0.log with crash.
Comment 3 Harald Nikolisin 2008-12-30 05:15:23 UTC
ok - I added AccelMethod XAA to my xorg.conf

- Now I don't see garbage output on the monitor if I'm logging in/out of an KDE session (there was always garbage for about 2 seconds with the Default setting EXA)

- I have a KDE 4.1 desktop with compositing effects enabled - now VLC (0.9.8a) does not work anymore - this is the console output when starting a video:
---------------------------------------------------------------------
[????????] x11 video output error: X11 request 140.19 failed with error code 11:
 BadAlloc (insufficient resources for operation)
X Error of failed request:  BadAlloc (insufficient resources for operation)
  Major opcode of failed request:  140 (XVideo)
  Minor opcode of failed request:  19 ()
  Serial number of failed request:  85
  Current serial number in output stream:  86
---------------------------------------------------------------------

- This forces me to switch off compositing effects on KDE 4.1 - after switching off, VLC works.
Besides that, the openGL applications are working again. 
With compositing on, for example the error output on console of kubrick was "OpenGL error detected after drawScene()".
Well but the performance of openGL programs are slightly worse in comparison to SuSE Linux 10.1/x.org 6.8 - and MILES AWAY from the windows performance (one can clearly see that with GoogleEarth).

- To see if the desktop or the virtual consoles are crashing I need about 2 weeks. I'll add a comment after that time.
Comment 4 Gordon Jin 2008-12-30 17:40:15 UTC
(In reply to comment #3)
> ok - I added AccelMethod XAA to my xorg.conf

> - I have a KDE 4.1 desktop with compositing effects enabled - now VLC (0.9.8a)
> does not work anymore - this is the console output when starting a video:

It's a known issue that composite + xv doesn't work with XAA -- that's one of the reasons why we switch from XAA to EXA.

> - To see if the desktop or the virtual consoles are crashing I need about 2
> weeks. I'll add a comment after that time.

ok, let's see if it's dup with bug#14464.
On the other side, if it's bug#17638, that's said to have been fixed in 2.6 rc1 release.
Comment 5 Harald Nikolisin 2009-01-11 06:26:04 UTC
Created attachment 21883 [details]
Xorg.0.log when only the virtual consoles crashed
Comment 6 Harald Nikolisin 2009-01-11 06:26:45 UTC
Created attachment 21884 [details]
Xorg.0.log when also the X-session itself freezed
Comment 7 Harald Nikolisin 2009-01-11 06:27:12 UTC
After 2 weeks of testing 2 crashes occur, both while logging into a KDE session.
1. First time the virtual consoles are gone (Xorg.0.log-allVirtualConsolesGone)
2. The X-session freezed, I had to shutdown the computer via remote login (Xorg.0.log-loginCrashedEverything).

At this time, I had the compositing of kwin4 enabled. After that I mostly switched off the compositing.
Comment 8 Harald Nikolisin 2009-01-14 12:03:44 UTC
after the crashes (5.January) I switched off kwin composition for a few days. In these period no crashes occur.
Since 2 days I reactived kwin composition - and I got now a new crash on login - all virtual consoles gone but I found myself at kdm login:

Jan 14 20:54:50 MYHOST kdm[28816]: X server for display :0 terminated unexpectedly

Excerpt of Xorg.0.log:
======================
(II) intel(0): Fixed memory allocation layout:
(II) intel(0): 0x00000000-0x0001ffff: ring buffer (128 kB)
(II) intel(0): 0x00020000-0x0061ffff: compressed frame buffer (6144 kB, 0x000000007f820000physical
)
(II) intel(0): 0x00620000-0x00620fff: compressed ll buffer (4 kB, 0x000000007fe20000 physical
)
(II) intel(0): 0x00621000-0x0062afff: HW cursors (40 kB, 0x000000007fe21000 physical
)
(II) intel(0): 0x0062b000-0x00632fff: logical 3D context (32 kB)
(II) intel(0): 0x00633000-0x00732fff: fake bufmgr (1024 kB)
(II) intel(0): 0x00733000-0x00733fff: overlay registers (4 kB, 0x000000007ff33000 physical
)
(II) intel(0): 0x00734000-0x00743fff: xaa scratch (64 kB)
(II) intel(0): 0x007bf000:            end of stolen memory
(II) intel(0): 0x01000000-0x01ffffff: back buffer (13440 kB) X tiled
(II) intel(0): 0x02000000-0x02ffffff: depth buffer (13440 kB) X tiled
(II) intel(0): 0x04000000-0x07ffffff: front buffer (53760 kB) X tiled
(II) intel(0): 0x08000000-0x09ffffff: classic textures (32768 kB)
(II) intel(0): 0x10000000:            end of aperture
(WW) intel(0): ESR is 0x00000001, instruction error
(WW) intel(0): Existing errors found in hardware state



Comment 9 Harald Nikolisin 2009-01-14 12:04:44 UTC
what does these message mean which I get frequently in syslog?

Jan 14 20:54:54 MYHOST kernel: [drm:i915_getparam] *ERROR* Unknown parameter 5
Comment 10 Julien Cristau 2009-01-15 22:17:51 UTC
> --- Comment #9 from Harald Nikolisin <harald.nikolisin@mnet-online.de>  2009-01-14 12:04:44 PST ---
> what does these message mean which I get frequently in syslog?
> 
> Jan 14 20:54:54 MYHOST kernel: [drm:i915_getparam] *ERROR* Unknown parameter 5
> 
it means your kernel is < 2.6.28. you can safely ignore it.
Comment 11 Harald Nikolisin 2009-01-27 14:24:53 UTC
after a long time of testing, I can say that I have frequently crashes of the  virtual consoles if I have Compositing effects in KDE 4.1 enabled.
It doesn't matter if I use XAA or EXA (Xorg 7.4, Intel driver 2.5)
Switching off Compositing effects in KDE prevents crashing, at least I had no problems.

The resumee is then: KWin Copositing NOT with Intel driver?

Comment 12 Michael Fu 2009-02-16 01:41:27 UTC

*** This bug has been marked as a duplicate of bug 17638 ***
Comment 13 qwang13 2009-02-18 01:39:41 UTC
(In reply to comment #11)
> after a long time of testing, I can say that I have frequently crashes of the 
> virtual consoles if I have Compositing effects in KDE 4.1 enabled.
> It doesn't matter if I use XAA or EXA (Xorg 7.4, Intel driver 2.5)
> Switching off Compositing effects in KDE prevents crashing, at least I had no
> problems.
> 
> The resumee is then: KWin Copositing NOT with Intel driver?
> 

We submit a back porting patch to Novell for compiz(Desktop effect) issue which caused by memory leak(see bug #19665). You can download the latest graphics package to have a try. 
The location is http://download.opensuse.org/repositories/X11:/XOrg/openSUSE_11.1/