Bug 19334 - [G41] missing drm support
[G41] missing drm support
Status: RESOLVED FIXED
Product: xorg
Classification: Unclassified
Component: Driver/intel
7.4 (2008.09)
All Linux (All)
: high critical
Assigned To: Eric Anholt
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-29 22:03 UTC by jixin.liu@cs2c.com.cn
Modified: 2009-01-14 17:08 UTC (History)
4 users (show)

See Also:


Attachments
Xorg log (25.57 KB, text/x-log)
2008-12-29 22:05 UTC, jixin.liu@cs2c.com.cn
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description jixin.liu@cs2c.com.cn 2008-12-29 22:03:39 UTC
The computer that it is G41 will hang when I user intel graphics driver to start. 
The driver version is 2.5.1  and  2.5.0 . 
because I test two driver to start computer

The Operating system environment is :
kernel is : 2.6.27.7
Xorg server is 1.5.3
drm is : 2.4.0 
mesa is : 7.2 

PCI info is :

lspci

00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)

lspci -nm

00:00.0 "0600" "8086" "2e30" -r03 "1019" "2691"
00:02.0 "0300" "8086" "2e32" -r03 "1019" "2691"
00:1b.0 "0403" "8086" "27d8" -r01 "1019" "2691"
00:1c.0 "0604" "8086" "27d0" -r01 "" ""
00:1d.0 "0c03" "8086" "27c8" -r01 "1019" "2691"
00:1d.1 "0c03" "8086" "27c9" -r01 "1019" "2691"
00:1d.2 "0c03" "8086" "27ca" -r01 "1019" "2691"
00:1d.3 "0c03" "8086" "27cb" -r01 "1019" "2691"
00:1d.7 "0c03" "8086" "27cc" -r01 -p20 "1019" "2691"
00:1e.0 "0604" "8086" "244e" -re1 -p01 "" ""
00:1f.0 "0601" "8086" "27b8" -r01 "1019" "2691"
00:1f.1 "0101" "8086" "27df" -r01 -p8a "1019" "2691"
00:1f.2 "0101" "8086" "27c0" -r01 -p8f "1019" "2691"
00:1f.3 "0c05" "8086" "27da" -r01 "1019" "2691"
01:00.0 "0200" "10ec" "8168" -r02 "1019" "8111"
Comment 1 jixin.liu@cs2c.com.cn 2008-12-29 22:05:47 UTC
Created attachment 21561 [details]
Xorg log
Comment 2 jixin.liu@cs2c.com.cn 2008-12-29 22:07:39 UTC
I checked Xorg log, found start drm failed!. please help me!
Comment 3 Gordon Jin 2008-12-29 22:54:12 UTC
The problem is G41 is not supported in current kernel.
First, you need agp support. Please add this patch: http://git.kernel.org/?p=linux/kernel/git/anholt/drm-intel.git;a=commit;h=07611cdc43893d51c10f3192a59450cce1de952f
Then, you need drm support if you want 3d. Unfortunately the drm patch is not available now. So you'll have to disable dri in xorg.conf.

I'll take this bug as requesting G41 drm support.
Comment 4 jixin.liu@cs2c.com.cn 2008-12-30 00:02:30 UTC
I tried it with you method,but failed. 
I have puted your patch into kernel before you give me. I geted it from internet. 
It is wrong that I disable dri method?
I xorg configure is :

# Xorg configuration created by system-config-display

Section "ServerLayout"
        Identifier     "single head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "intel"
        Option "DRI" "off"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

Comment 5 minskey 2009-01-09 01:29:51 UTC
I checked cs2c's libdrm code which is used. It is not libdrm 2.4.0. I didn't dig out which version it is since the code has no multi-thread protection in faked buffer manager. After merging libdrm 2.4.3 code related to pthread protection to their libdrm, G41 can work now for me.

Once I get confirmation from the customer, we could close this bug.
Comment 6 jixin.liu@cs2c.com.cn 2009-01-12 00:22:25 UTC
This Bug is resoluted.
Comment 7 Gordon Jin 2009-01-12 00:43:01 UTC
Jixin, is it working with DRI disabled or not? I thought DRI is still a problem.
Comment 8 minskey 2009-01-12 00:51:43 UTC
I recommend they disable DRI since they have to fix this issue before Jan 16. If enabling DRI, system can work for some time even I start 6 glxgear. But if I leave it for days system still hangs (I leave the system running with 6 glxgears last Friday, and when I came back today, system already hangs).
Comment 9 Gordon Jin 2009-01-13 18:58:52 UTC
I still don't understand why dri could work (at least basically) for your G41, because the upstream kernel doesn't have that support yet. Have you added additional G41 DRM enabling patches? You could check if the G41 pci id "0x2E32" added into your drm.
Comment 10 minskey 2009-01-14 02:03:53 UTC
(In reply to comment #9)
> I still don't understand why dri could work (at least basically) for your G41,
> because the upstream kernel doesn't have that support yet. Have you added
> additional G41 DRM enabling patches? You could check if the G41 pci id "0x2E32"
> added into your drm.
> 

I just mailed the m/b back to cs2c following their requirement. So, I cannot check it now.  But I remember that 6 glxgears could work smoothly for a while, I mean that the rendering is running smoothly so that I could not see flick or lagging from the gear rotation. If DRI had not worked, it could not happen. Besides, the glxinfo did indicate DRI is enabled.

 I guess that upstream developers probably say G41 doesn't work with GEM (maybe I am wrong), It could work if we use faked buffer manager. If you have G41 hardware, you can try disabling GEM and let faked memory manager work.  

  For jixin, could you please help us check it ? thanks in advance
Comment 11 jixin.liu@cs2c.com.cn 2009-01-14 17:08:41 UTC
I want to try it. But G41 mainboard is kaput. So I will return it to GreatWall.