Bug 19413 - [regression OGLC]Oglconform case/api-fogcoord fail
Summary: [regression OGLC]Oglconform case/api-fogcoord fail
Status: VERIFIED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915 (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: Eric Anholt
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: intel-3d-release
  Show dependency treegraph
 
Reported: 2009-01-05 17:33 UTC by liuhaien
Modified: 2009-07-02 20:51 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg.0.log (63.41 KB, text/plain)
2009-01-05 17:33 UTC, liuhaien
Details
xorg conf file (3.77 KB, text/plain)
2009-01-05 17:33 UTC, liuhaien
Details

Note You need to log in before you can comment on or make changes to this bug.
Description liuhaien 2009-01-05 17:33:09 UTC
Created attachment 21706 [details]
xorg.0.log

System Environment:
--------------------------
Libdrm_stable:		(master)c34539e8bb5568b1d6059abf139dd08e07e84eea
Mesa_stable:		(intel-2008-q4)b9921a9fb2bc937194eac7e80e31d30f81cb6bb1
Xorg:		7.2
Xserver_stable:	(server-1.6-branch)32e81074b967716865aef08b66ec29caf0fec2c5
Xf86_video_intel_stable:		(xf86-video-intel-2.6-branch)
                            fac43181af0ad59fa6d06e26d369d886ce221c10
GEM_kernel:       (drm-intel-2.6.28)72e2bfb03f46f7eef1ae8907593dd35e2c5603de


Bug detailed description:
-------------------------
startX, then run oglconfrom case/api-fogcoord, we will get failure with the latest code. we try to bisect and find below commit cause this issue:

425ede63089b1a13c9ef74d6b76b07501827fbb7 is first bad commit
commit 425ede63089b1a13c9ef74d6b76b07501827fbb7
Author: Eric Anholt <eric@anholt.net>
Date:   Wed Dec 31 00:02:43 2008 -0800

    intel: Add support for glBitmap as metaops using GL calls.

    This lets us avoid software fallbacks when clients forget to turn some state
    off (engine demo) or just do crazy things to test conformance (OGLC).

    This should probably be brought into mesa generic code so other drivers can
    make use of it.

    Bug #19016.
    (cherry picked from commit e1a92175542c6645c23cc78f2a4fcd36dd0235e6)

Reproduce steps:
----------------
1.xinit&
2. run oglconform/api-fogcoord
Comment 1 liuhaien 2009-01-05 17:33:35 UTC
Created attachment 21707 [details]
xorg conf file
Comment 2 liuhaien 2009-01-05 17:43:52 UTC
and the oglconfrom case/depthrange also get failure with the latest code due to the same commit.
Comment 3 liuhaien 2009-03-22 19:27:37 UTC
still fails against:
Libdrm:         (master)00d8e960ca665b7f0528438331f4d0ae77fbb4cc
Mesa:(mesa_7_4_branch)b009a32bf428192fef2dc4787d25f022a472854f          
Xserver:        (server-1.6-branch)60c161545af80eb78eb790a05bde79409dfdf16e
Xf86_video_intel:       (2.7)e2465249a90b9aefe6d7a96eb56a51fde54698a0
Kernel:       (for-airlied)a2e785c32b886dd7f0289d1cf15fc14e9c81bc01
Comment 4 Eric Anholt 2009-07-02 19:37:45 UTC
commit 8ae02a3919bf31bd33f86208472e100eedb58497
Author: Eric Anholt <eric@anholt.net>
Date:   Thu Jul 2 19:21:22 2009 -0700

    intel: Fall back on glBitmap with fog enabled.
    
    We would have to build the program with the appropriate fog mode, and
    also supply the fog coordinate if appropriate.
    
    Bug #19413.
Comment 5 liuhaien 2009-07-02 20:51:47 UTC
verified with below commits:
Libdrm:		(master)fbac5891b91c795de61f4d7cbc1a6799474364ad
Mesa:		(master)8ae02a3919bf31bd33f86208472e100eedb58497
Xserver:		(master)3525d140567e0ad5f0184e4b37893c47239e1628
Xf86_video_intel:		(master)4100abdf5d208bbcbb4ceabad0572c04221443c9
Kernel:       (drm-intel-next)1ae8c0a56eeb3ed358b78ccadd024d6b721f26bc


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.