Bug 19420 - Gnome PackaKit package description reflows badly
Summary: Gnome PackaKit package description reflows badly
Status: RESOLVED FIXED
Alias: None
Product: PackageKit
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-06 02:28 UTC by Dwayne Bailey
Modified: 2012-01-05 10:07 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dwayne Bailey 2009-01-06 02:28:17 UTC
Certain packages show badly reflowed package description text.  Even in the example given here:
http://www.packagekit.org/img/gpk-application-groups.png

There seems to be some reflow issue (why is the sentence starting on a new line?)

If you are on Fedora and examine translate-toolkit package then you will see a bad reflow that makes this information unreadable.

I'm not sure if this problem is caused by the yum backend which provides the data badly to the GUI which has to render it as best it can or of the GUI is doing its work here.

My suggestion is to leave the supplied information as is and allow some basic understanding of what should/shouldn't be reflowed so that it shows a good description to the user.

See bug https://bugzilla.redhat.com/show_bug.cgi?id=478970 that I raised against RPM to respect description layout in the original RPM
Comment 1 Dwayne Bailey 2009-01-06 06:09:29 UTC
Discovered Markdown: http://www.packagekit.org/pk-faq.html#markup
Comment 2 Dwayne Bailey 2009-01-06 06:38:50 UTC
I redid an RPM using Markdown to see what would display in gpk-application.  The package description is completely garbled i.e. although the markdown syntax is present the display is not doing Markdown. Is this a problem with the yum backend perhaps?
Comment 3 Richard Hughes 2009-01-08 06:04:50 UTC
You were correct to use markdown syntax. The GNOME tools have recently been converted to markdown (from some odd internal formatting engine) and so you need gnome-packagekit 0.4.1 to see the beautiful new rendering. There'll be a release today or tomorrow of 0.4.1 which I'll be uploading to rawhide soon. I've got RPM's for F10 if you want them.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.