Bug 19455 - [UXA] glxsnoop fails to display its front buffer
[UXA] glxsnoop fails to display its front buffer
Status: VERIFIED DUPLICATE of bug 19174
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
unspecified
Other Linux (All)
: medium normal
Assigned To: Eric Anholt
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-07 19:44 UTC by zhao jian
Modified: 2009-07-13 23:12 UTC (History)
0 users

See Also:


Attachments
xorg.conf (3.76 KB, text/plain)
2009-01-07 19:44 UTC, zhao jian
Details
xorg.0.log (52.23 KB, text/plain)
2009-01-07 19:45 UTC, zhao jian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zhao jian 2009-01-07 19:44:16 UTC
Created attachment 21780 [details]
xorg.conf

System Environment:
----------------------
Host:           gm45a
Arch:           i386
OSD:            Fedora release 10 (Cambridge)
Kernel:         2.6.28-release
Libdrm:          (master)c34539e8bb5568b1d6059abf139dd08e07e84eea
Mesa:            (intel-2008-q4)b9921a9fb2bc937194eac7e80e31d30f81cb6bb1
Xorg:           7.2
Xserver:         (server-1.6-branch)32e81074b967716865aef08b66ec29caf0fec2c5
Xf86_video_intel:    (xf86-video-intel-2.6-branch) 
                 21c2a0a75bec887413cddde46351b6d87469993f

Bug Description:
---------------------
I tested glxsnoop with UXA on gm45. I get the informationfrom the glxgearsby xwininfo. Then tun glxsnoop, it fails to diplay its front buffer. What's more, it also has the problem mentioned in other bugs that its display is at the top left of the screen out of the window. But in EXA these all go well.  

Reproduce Steps:
---------------------
1. enable UXA 
2. xinit&
3. gnome-session&
4. glxgears&
5. xwininfo
6. ./glxsnoop 0x2800002(Window ID of the application you want to test)
Comment 1 zhao jian 2009-01-07 19:45:04 UTC
Created attachment 21781 [details]
xorg.0.log
Comment 2 Gordon Jin 2009-01-08 01:01:22 UTC
let Eric to decide if it's dup with bug#19174.
Comment 3 Gordon Jin 2009-02-24 00:22:02 UTC
Eric, comments?
Comment 4 Eric Anholt 2009-02-25 10:43:42 UTC

*** This bug has been marked as a duplicate of bug 19174 ***
Comment 5 zhao jian 2009-07-13 23:12:53 UTC
Now its front buffer works well both in KMS and UMS. verified with 
Libdrm:         (master)3f3c5be6f908272199ccf53f108b1124bfe0a00e
Mesa:           (master)59155f70e701bc0b4fb816da991d6921f53b3bc7
Xserver:                (master)cc575a3ba4a52265e410b325c2291fe900a54f33
Xf86_video_intel:       (master)b74bf3f9a65af9e72921d4e9028d9d4d023f8bc6
Kernel:         (drm-intel-next)5019914ca3b7517b2d82db2e92e3f683ac48e535