Bug 19617 - nv driver fails to work with GeForce 9400 GT, PCI ID 10de:0641
Summary: nv driver fails to work with GeForce 9400 GT, PCI ID 10de:0641
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nVidia (open) (show other bugs)
Version: git
Hardware: Other All
: medium critical
Assignee: Aaron Plattner
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-16 12:09 UTC by Adam Williamson
Modified: 2010-08-09 13:24 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Williamson 2009-01-16 12:09:59 UTC
As stated in the summary, the nv driver - version 2.1.12 - fails to work with my new graphics card, a GeForce 9400 GT with PCI ID 10de:0641. On both Mandriva and Fedora, the system hangs at a black screen when X tries to run: it's not even possible to switch to a VT. So I can't give you any logs.

This is rather important, as it breaks Fedora 10 installation - see https://bugzilla.redhat.com/show_bug.cgi?id=480393 - because Fedora automatically tries to use the 'nv' driver during installation. So when booting the installer you just get the first few bits, then a black screen.
Comment 1 Adam Williamson 2009-01-16 13:35:32 UTC
Interestingly, I can confirm something that I saw in a similar report: if you first run X with the proprietary driver, *then* switch to nv, it works. But from a cold boot, it fails. So I concur with that reporter that there's some kind of initialization of the card that the proprietary driver does correctly, that then allows nv to work.
Comment 2 Adam Williamson 2009-01-24 12:07:02 UTC
Further: when booting clean to nv, Xorg.0.log is a 0-byte file, so no useful information there. Ben Skeggs is looking at this.
Comment 3 Adam Williamson 2009-01-24 14:29:41 UTC
The mmiotrace of the proprietary driver starting up, that Ben requested from me via email, can be found at:

http://www.happyassassin.net/extras/mydump.txt.lzma
Comment 4 Adam Jackson 2010-08-09 13:24:37 UTC
Should be working in 2.1.18


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.