Bug 19786 - [XAA] Xserver 1.5.3 w/ Intel 2.6.1 on GM45 crashes (lenovo x200)
[XAA] Xserver 1.5.3 w/ Intel 2.6.1 on GM45 crashes (lenovo x200)
Status: RESOLVED INVALID
Product: xorg
Classification: Unclassified
Component: Driver/intel
7.4 (2008.09)
x86-64 (AMD64) OpenBSD
: medium critical
Assigned To: Xorg Project Team
Xorg Project Team
: NEEDINFO
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-28 09:48 UTC by chris.kuethe
Modified: 2011-07-10 06:47 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg.conf (3.28 KB, text/plain)
2009-01-28 09:49 UTC, chris.kuethe
no flags Details
xdm.log (3.48 KB, text/plain)
2009-01-28 09:49 UTC, chris.kuethe
no flags Details
Xorg.0.log (18.19 KB, text/plain)
2009-01-28 09:50 UTC, chris.kuethe
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description chris.kuethe 2009-01-28 09:48:35 UTC
Program received signal SIGSEGV, Segmentation fault.
i965_batch_flush_notify (pScrn=0x20ca5d800) at
/usr/xenocara/driver/xf86-video-intel/src/i965_render.c:1604
1604        if (render_state->vertex_buffer_bo) {
(gdb) bt
#0  i965_batch_flush_notify (pScrn=0x20ca5d800) at
/usr/xenocara/driver/xf86-video-intel/src/i965_render.c:1604
#1  0x000000020ef9b0fa in intel_batch_flush (pScrn=0x20ca5d800,
flushed=0) at /usr/xenocara/driver/xf86-video-intel/src/i830_batchbuffer.c:214
#2  0x000000020efa7924 in I830BlockHandler (i=0, blockData=0x0,
pTimeout=0x7f7ffffdb698, pReadmask=0x9c5880) at
/usr/xenocara/driver/xf86-video-intel/src/i830_driver.c:2620
#3  0x00000000005036a5 in AnimCurScreenBlockHandler (screenNum=0,
blockData=0x0, pTimeout=0x7f7ffffdb698, pReadmask=0x9c5880) at
/usr/xenocara/xserver/render/animcur.c:199
#4  0x0000000000446962 in BlockHandler (pTimeout=0x7f7ffffdb698,
pReadmask=0x9c5880) at /usr/xenocara/xserver/dix/dixutils.c:383
#5  0x00000000004cfe7f in WaitForSomething (pClientsReady=0x203c80800)
at /usr/xenocara/xserver/os/WaitFor.c:223
#6  0x000000000043d3ef in Dispatch () at
/usr/xenocara/xserver/dix/dispatch.c:375
#7  0x000000000042ad8e in main (argc=1, argv=0x7f7ffffdb9b0,
envp=0x9c5660) at /usr/xenocara/xserver/dix/main.c:441


(gdb) bt full
#0  i965_batch_flush_notify (pScrn=0x20ca5d800) at
/usr/xenocara/driver/xf86-video-intel/src/i965_render.c:1604
       pI830 = 0x20f505100
       render_state = (struct gen4_render_state *) 0x0
#1  0x000000020ef9b0fa in intel_batch_flush (pScrn=0x20ca5d800,
flushed=0) at /usr/xenocara/driver/xf86-video-intel/src/i830_batchbuffer.c:214
       flags = 89137152
       pI830 = 0x20f505100
       ret = 256921856
#2  0x000000020efa7924 in I830BlockHandler (i=0, blockData=0x0,
pTimeout=0x7f7ffffdb698, pReadmask=0x9c5880) at
/usr/xenocara/driver/xf86-video-intel/src/i830_driver.c:2620
       flushed = 1
       pScreen = 0x20574a800
       pScrn = 0x20ca5d800
       pI830 = 0x20f505100
#3  0x00000000005036a5 in AnimCurScreenBlockHandler (screenNum=0,
blockData=0x0, pTimeout=0x7f7ffffdb698, pReadmask=0x9c5880) at
/usr/xenocara/xserver/render/animcur.c:199
       pScreen = 0x20574a800
       as = 0x200725e00
#4  0x0000000000446962 in BlockHandler (pTimeout=0x7f7ffffdb698,
pReadmask=0x9c5880) at /usr/xenocara/xserver/dix/dixutils.c:383
       i = 1
       j = 0
#5  0x00000000004cfe7f in WaitForSomething (pClientsReady=0x203c80800)
at /usr/xenocara/xserver/os/WaitFor.c:223
       i = 10245928
       waittime = {tv_sec = 599, tv_usec = 999000}
       wt = (struct timeval *) 0x7f7ffffdb8a0
       timeout = 89137152
       clientsReadable = {fds_bits = {0 <repeats 32 times>}}
       clientsWritable = {fds_bits = {-149584, 32639, 145745488, 2,
256, 0, 265010432, 2, 256, 0, 145748044, 2, 0, 0, -149072, 32639,
7804528, 0, 256, 0, 265010432, 2, 2, 0, 91531264,
   2, 244, 0, 0, 0, 145749002, 2}}
       curclient = 0
       selecterr = 443756366
       nready = 10245328
       devicesReadable = {fds_bits = {91531264, 2, 91531264, 2, 640,
0, 400, 0, 234020000, 2, 7828368, 0, 0, 0, 4976608, 0, 0, 0, 91531264,
2, 91531264, 2, 24505216, 2, 135906688, 2, 1,
   0, 640, 0, 4975858, 0}}
       now = 443756366
       someReady = 0
#6  0x000000000043d3ef in Dispatch () at
/usr/xenocara/xserver/dix/dispatch.c:375
       clientReady = (int *) 0x203c80800
       result = 10245728
       client = 0x1
       nready = 10245928
       icheck = (HWEventQueuePtr *) 0x9c54d0
       start_tick = 1
#7  0x000000000042ad8e in main (argc=1, argv=0x7f7ffffdb9b0,
envp=0x9c5660) at /usr/xenocara/xserver/dix/main.c:441
       i = 1
       j = 256921856
       k = 0
       error = 0
       xauthfile = 0x20f505100 ""
       alwaysCheckForInput = {0, 1}
Comment 1 chris.kuethe 2009-01-28 09:49:25 UTC
Created attachment 22311 [details]
xorg.conf
Comment 2 chris.kuethe 2009-01-28 09:49:44 UTC
Created attachment 22312 [details]
xdm.log
Comment 3 chris.kuethe 2009-01-28 09:50:01 UTC
Created attachment 22313 [details]
Xorg.0.log
Comment 4 Gordon Jin 2009-02-03 19:12:40 UTC
How to reproduce? Just starting X?

Are you able to try on Linux? Recent Linux kernel (2.6.28) makes GM45 quite stable on my side.

I'm not able to fix BSD specific bugs.

And please refer to http://intellinuxgraphics.org/how_to_report_bug.html. Thanks.
Comment 5 chris.kuethe 2009-02-03 20:30:54 UTC
This crash happens just starting X - the grey background loads and the xserver crashes.

Don't have any linux machines to test on, and I don't want to wipe out my production install.
Comment 6 Gordon Jin 2009-02-24 21:56:03 UTC
I'm not able to support OpenBSD. Linux is running fine on my 3 GM45 machines.
Comment 7 Wang Zhenyu 2009-03-12 09:09:01 UTC
Try to use EXA or UXA. XAA looks broken on 965 currently.
Comment 8 Jesse Barnes 2009-05-11 11:21:43 UTC
Adjusting severity: crashes & hangs should be marked critical.
Comment 9 Ian Romanick 2010-10-05 21:38:33 UTC
Are you still able to reproduce this bug with more recent versions of the driver?
Comment 10 chris.kuethe 2010-10-06 15:08:41 UTC
this can be closed. i haven't seen this in a long time.

On Tue, Oct 5, 2010 at 9:38 PM,  <bugzilla-daemon@freedesktop.org> wrote:
> https://bugs.freedesktop.org/show_bug.cgi?id=19786
>
> Ian Romanick <idr@freedesktop.org> changed:
>
>           What    |Removed                     |Added
> ----------------------------------------------------------------------------
>           Keywords|                            |NEEDINFO
>
> --- Comment #9 from Ian Romanick <idr@freedesktop.org> 2010-10-05 21:38:33 PDT ---
> Are you still able to reproduce this bug with more recent versions of the
> driver?
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 11 Chris Wilson 2011-07-10 06:47:58 UTC
It is unhelpful to keep these bugs open on known buggy versions of the drivers simply because the infrastructure to test fixes is lacking. Hopefully the situation will improve in the near future and we will be able to start work again on an updated userspace.