Bug 19807 - dbus-send can't send dict args
Summary: dbus-send can't send dict args
Status: RESOLVED MOVED
Alias: None
Product: dbus
Classification: Unclassified
Component: core (show other bugs)
Version: 1.5
Hardware: All All
: low enhancement
Assignee: D-Bus Maintainers
QA Contact: D-Bus Maintainers
URL:
Whiteboard:
Keywords: love
Depends on:
Blocks:
 
Reported: 2009-01-29 05:28 UTC by Tomas Pelka
Modified: 2019-08-16 06:39 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Pelka 2009-01-29 05:28:14 UTC
Description of problem:
Dbus-send unable to send dict arguments.

Version-Release number of selected component (if applicable):
dbus-1.1.2

How reproducible:
100%

Steps to Reproduce:
1. Send:
dbus-send --print-reply --dest=org.freedesktop.DBus --type=signal \
/org/freedesktop/DBus/Examples/Echo org.freedesktop.DBus.Hello \ dict:string:int32:"one",1,"two",2,"three",3

Expected results:
Message should be send without error.

Actual result:
process 13920: arguments to dbus_message_iter_open_container() were incorrect, assertion "(type == DBUS_TYPE_STRUCT && contained_signature == NULL) || (type == DBUS_TYPE_DICT_ENTRY && contained_signature == NULL) || (type == DBUS_TYPE_VARIANT && contained_signature != NULL) || (type == DBUS_TYPE_ARRAY && contained_signature != NULL)" failed in file dbus-message.c line 2356.
This is normally a bug in some application using the D-Bus library.
process 13920: dbus message iterator looks uninitialized or corrupted
process 13920: arguments to dbus_message_iter_append_basic() were incorrect, assertion "_dbus_message_iter_append_check (real)" failed in file dbus-message.c line 2239.
This is normally a bug in some application using the D-Bus library.
process 13920: dbus message iterator looks uninitialized or corrupted
process 13920: arguments to dbus_message_iter_append_basic() were incorrect, assertion "_dbus_message_iter_append_check (real)" failed in file dbus-message.c line 2239.
This is normally a bug in some application using the D-Bus library.
process 13920: dbus message iterator looks uninitialized or corrupted
process 13920: arguments to dbus_message_iter_close_container() were incorrect, assertion "_dbus_message_iter_append_check (real_sub)" failed in file dbus-message.c line 2414.
This is normally a bug in some application using the D-Bus library.
process 13920: arguments to dbus_message_iter_open_container() were incorrect, assertion "(type == DBUS_TYPE_STRUCT && contained_signature == NULL) || (type == DBUS_TYPE_DICT_ENTRY && contained_signature == NULL) || (type == DBUS_TYPE_VARIANT && contained_signature != NULL) || (type == DBUS_TYPE_ARRAY && contained_signature != NULL)" failed in file dbus-message.c line 2356.
This is normally a bug in some application using the D-Bus library.
process 13920: dbus message iterator looks uninitialized or corrupted
process 13920: arguments to dbus_message_iter_append_basic() were incorrect, assertion "_dbus_message_iter_append_check (real)" failed in file dbus-message.c line 2239.
This is normally a bug in some application using the D-Bus library.
process 13920: dbus message iterator looks uninitialized or corrupted
process 13920: arguments to dbus_message_iter_append_basic() were incorrect, assertion "_dbus_message_iter_append_check (real)" failed in file dbus-message.c line 2239.
This is normally a bug in some application using the D-Bus library.
process 13920: dbus message iterator looks uninitialized or corrupted
process 13920: arguments to dbus_message_iter_close_container() were incorrect, assertion "_dbus_message_iter_append_check (real_sub)" failed in file dbus-message.c line 2414.
This is normally a bug in some application using the D-Bus library.
process 13920: arguments to dbus_message_iter_open_container() were incorrect, assertion "(type == DBUS_TYPE_STRUCT && contained_signature == NULL) || (type == DBUS_TYPE_DICT_ENTRY && contained_signature == NULL) || (type == DBUS_TYPE_VARIANT && contained_signature != NULL) || (type == DBUS_TYPE_ARRAY && contained_signature != NULL)" failed in file dbus-message.c line 2356.
This is normally a bug in some application using the D-Bus library.
process 13920: dbus message iterator looks uninitialized or corrupted
process 13920: arguments to dbus_message_iter_append_basic() were incorrect, assertion "_dbus_message_iter_append_check (real)" failed in file dbus-message.c line 2239.
This is normally a bug in some application using the D-Bus library.
process 13920: dbus message iterator looks uninitialized or corrupted
process 13920: arguments to dbus_message_iter_append_basic() were incorrect, assertion "_dbus_message_iter_append_check (real)" failed in file dbus-message.c line 2239.
This is normally a bug in some application using the D-Bus library.
process 13920: dbus message iterator looks uninitialized or corrupted
process 13920: arguments to dbus_message_iter_close_container() were incorrect, assertion "_dbus_message_iter_append_check (real_sub)" failed in file dbus-message.c line 2414.
This is normally a bug in some application using the D-Bus library.
Error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Comment 1 Tomas Pelka 2009-01-29 05:29:25 UTC
I'm not sure, but it seems to be a dbus-send bug.
Comment 2 Simon McVittie 2011-04-07 10:10:51 UTC
I didn't even know dbus-send was meant to be able to send dicts. Looking at the code, it seems "dict" may secretly mean "dict entry" for dbus-send, so the right syntax might be array:dict:string:int32?

Using gdbus, qdbus or a Python script is probably better for non-trivial data structures.
Comment 3 Simon McVittie 2012-02-08 07:27:50 UTC
If someone wants this, patches welcome.
Comment 4 GitLab Migration User 2018-10-12 21:05:45 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/dbus/dbus/issues/16.
Comment 5 thanos 2019-04-22 11:55:55 UTC Comment hidden (spam)
Comment 6 Bernice Bode 2019-05-22 06:27:44 UTC
For any kind of bugs, my first priority is to recheck the code attentively. If I found some mistake then I get into the solution of that specific snippet. Sometimes I couldn't get the right solution so https://essay-writing-services.reviews/ always here for my help just like you to recommend codes.
Comment 7 Mimani 2019-06-24 08:52:19 UTC
Its such as you learn my thoughts! You appear to grasp a lot approximately this, like you wrote the guide in it or something. I believe that you simply could do with some percent to power the message home a little bit, however other than that, this is wonderful blog. https://bettafish.top/ An excellent read. I'll definitely be back.
Comment 8 Polly Lockman 2019-07-02 10:18:54 UTC
It is difficult for non-programmers to deduct the bug and your guide is making them enable to detect and debug. I am configuring the plugin on https://mentalitch.com/tips-i-would-like-to-know-when-i-write-my-first-assignment/ website in the post. I am pretty sure it will be more responsive.
Comment 9 Jeena 2019-07-30 12:18:30 UTC
I think it’s important to look at where you are in life and what you want people to associate your name and personal brand with. I am comfortable swearing and writing about controversial topics, for example, but there are certain things you’ll never find associated with my brand.
https://blog.loveawake.com/2019/05/15/childfree-dating-reason-why-men-%d1%81hoose-not-to-have-kids/
Comment 10 John Sullen 2019-08-15 11:59:39 UTC
If you once have written good essay, you may consider about rewriting it, saving the time for writing the essay from scratch. There are 5 most important writing tips which you should take into account if you need to rewrite it at its best https://primeessays.com/5-effective-tips.html
Comment 11 John Sullen 2019-08-16 06:39:49 UTC
Whiting a rhetorical analysis reguired to be stick to the essay structure and be grammatically correct. When you write a rhetorical essay, things come to conclusion, there may be some misunderstandings towards its writing. Read the following guideline and find out how to avoid these mistakes https://primeessays.com/rhetorica-analysis-conclusion.html


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.