Bug 19824 - [GM45 EXA] 2.6.1 regression: sigsev with dualhead configuration "Couldn't bind memory for BO front buffer"
Summary: [GM45 EXA] 2.6.1 regression: sigsev with dualhead configuration "Couldn't bin...
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.4 (2008.09)
Hardware: x86-64 (AMD64) All
: medium major
Assignee: Eric Anholt
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2009-01-30 02:24 UTC by Udo Rader
Modified: 2009-05-15 17:22 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
log showing the crash (14.92 KB, text/plain)
2009-01-30 02:24 UTC, Udo Rader
no flags Details
failing xorg.conf (2.61 KB, text/plain)
2009-01-30 02:28 UTC, Udo Rader
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Udo Rader 2009-01-30 02:24:18 UTC
Created attachment 22376 [details]
log showing the crash

Running further tests for #19412, I recently upgraded my intel driver to 2.6.1.

Now with that version I cannot even start X when I have configured an external monitor, may it be connected or not. X dies like this:

--------CUT-------
(EE) intel(0): Failed to pin front buffer: Cannot allocate memory

Fatal server error:
Couldn't bind memory for BO front buffer


Please consult the The X.Org Foundation support
         at http://qa.mandriva.com
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

(II) intel(0): xf86UnbindGARTMemory: unbind key 0
(II) intel(0): xf86UnbindGARTMemory: unbind key 1

Backtrace:
0: /etc/X11/X(xorg_backtrace+0x26) [0x4eb3b6]
1: /etc/X11/X(xf86SigHandler+0x3e) [0x47fa3e]
2: /lib64/libc.so.6 [0x7f5425d93ab0]
3: /usr/lib64/xorg/modules/drivers//intel_drv.so(gen4_render_state_cleanup+0x1c) [0x7f54241b235c]
4: /usr/lib64/xorg/modules/drivers//intel_drv.so [0x7f5424186c6d]
5: /etc/X11/X(AbortDDX+0x8d) [0x46777d]
6: /etc/X11/X(AbortServer+0x1d) [0x4f4bad]
7: /etc/X11/X(LogVMessageVerb+0) [0x4f52a0]
8: /usr/lib64/xorg/modules/drivers//intel_drv.so(i830_bind_all_memory+0x102) [0x7f542418eeb2]
9: /usr/lib64/xorg/modules/drivers//intel_drv.so [0x7f5424189038]
10: /usr/lib64/xorg/modules/drivers//intel_drv.so [0x7f542418a86a]
11: /etc/X11/X(AddScreen+0x1c6) [0x42e326]
12: /etc/X11/X(InitOutput+0x241) [0x468ed1]
13: /etc/X11/X(main+0x20e) [0x42ea3e]
14: /lib64/libc.so.6(__libc_start_main+0xe6) [0x7f5425d80446]
15: /etc/X11/X [0x42e079]

FatalError re-entered, aborting
Caught signal 11.  Server aborting
--------CUT-------

Having the external monitor as a clone of the panel, the driver does not fail.
Comment 1 Udo Rader 2009-01-30 02:28:01 UTC
Created attachment 22377 [details]
failing xorg.conf
Comment 2 Gordon Jin 2009-01-30 03:10:46 UTC
This seems similar to bug#17490. You can try decreasing Virtual setting. (If your laptop panel is 1920x1200, you can try set them as up-bottom so "1920 2250" is sufficient)

And you don't need screen1. You can refer to http://intellinuxgraphics.org/dualhead.html for how to write xorg.conf for dualhead.
Comment 3 Udo Rader 2009-01-30 06:31:11 UTC
thanks for your quick reply.

Yes indeed, changing the layout to up-bottom instead of left-right dualhead is working. So this is a bug in the driver, right?

And per my "screen1" section, yes I know, it is unnecessary for "plain" dualhead configurations. It is a remainder of some tests to set up a zaphod style dualhead configuration, but that failed as well & certainly is another story ;-)
Comment 4 Gordon Jin 2009-01-30 20:15:26 UTC
(In reply to comment #3)
> Yes indeed, changing the layout to up-bottom instead of left-right dualhead is
> working. So this is a bug in the driver, right?

So this is exactly bug#17490 and fixed in DRI2.

It should work if you use xf86-video-intel 2.6.x + xserver 1.6 + libdrm 2.4.4 + kernel 2.6.28.

*** This bug has been marked as a duplicate of bug 17490 ***
Comment 5 Udo Rader 2009-01-31 03:58:47 UTC
hmm, I don't think that it is a duplicate, here is what I've got running:

$ rpm -q lib64drm2
lib64drm2-2.4.4-1mdv2009.1
$
$ uname -a
Linux localhost 2.6.28.1-desktop-2mnb #1 SMP Fri Jan 23 14:26:25 EST 2009 x86_64 Intel(R) Core(TM)2 Duo CPU     T9400  @ 2.53GHz GNU/Linux
$
$ rpm -q x11-server-xorg
x11-server-xorg-1.5.99.3-1.20090110.11mdv2009.1

and the 2.6.0 version of the driver worked for me, so there must at least be a regression somewhere, alas reopening.
Comment 6 Gordon Jin 2009-01-31 04:14:46 UTC
Eric, so it's said to be a regression from 2.6.0 to 2.6.1.
Comment 7 Udo Rader 2009-02-01 01:38:11 UTC
I ran some additional tests on this and after changing from EXA to UXA made the bug go away as well, so looks like an EXA only problem.
Comment 8 Eric Anholt 2009-05-15 17:22:50 UTC
Reporter says it's fixed with moving to UXA.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.