Bug 19926 - KPackageKit crashes spontaneously with SIGABRT error
Summary: KPackageKit crashes spontaneously with SIGABRT error
Status: RESOLVED INVALID
Alias: None
Product: PackageKit
Classification: Unclassified
Component: client-library (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium major
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-03 02:37 UTC by Thomas Goettlicher
Modified: 2012-01-05 10:19 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
backtrace (2.70 KB, text/plain)
2009-02-03 02:37 UTC, Thomas Goettlicher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Goettlicher 2009-02-03 02:37:33 UTC
Created attachment 22515 [details]
backtrace

This bug was initially: https://bugzilla.novell.com/show_bug.cgi?id=470226
---

On starting up openSUSE 11.1 KPackageKit issues the following message:
A Fatal Error Occurred
The application KPackageKit (kpackagekit) crashed and caused the signal 6
(SIGABRT).  Past that, beats me what's going on.  Sorry...


Software Management says I have V0.3.11-1.12-i586 from repo-oss


Reproducible: Always

Steps to Reproduce:
1.Start KDED4 session
2.wait about a minute
3.
Actual Results:  
PackageKit fails - no user intervention that I know of

Expected Results:  
No crash?  I don't quite understand PackageKit's function - it launches only
because that's part of the original system installtion (that is, I didn't
deliberately install it).

This is a default installation of KDE4, part of an >update< from 10.3 to 11.1. 
I suspect some legacy files from 10.3 may be causing the problem.  Also, in
searching for similar bugs, the only hit on the string "SIGABRT" was an aide
bug - that's not installed on my system (based on check with software manager).
Comment 1 Jean-François Fortin Tam 2012-01-05 10:19:11 UTC
Hi there,
This bug report is very old and based on a version not supported anymore. By upgrading to a newer version of PackageKit you could receive bug fixes and new functionality. You may need to upgrade your Linux distribution to obtain a newer version of PackageKit.
Please feel free to reopen this bug if the problem still occurs with the latest version.


bug/show.html.tmpl processed on Mar 29, 2017 at 18:54:24.
(provided by the Example extension).