Bug 19953 - KPackageKit fails searching for Dolphin
Summary: KPackageKit fails searching for Dolphin
Status: RESOLVED DUPLICATE of bug 17750
Alias: None
Product: PackageKit
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-04 07:40 UTC by Jonathan Thomas
Modified: 2009-03-18 16:24 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Thomas 2009-02-04 07:40:19 UTC
I'm using a KPackageKit svn snapshot from 2008 12 11. (Based on kpackagekit 0.3.1) and PackageKit 0.3.13. This is all running on Kubuntu 9.04

Whenever I try to search for the "dolphin" package in KPackageKit, it always fails. At the bottom of the KPackageKit window the search status bar says "search failed", and I get a popup window that says: "The backend took too much time to process the synchronous request - you need to fork!"

Running the packagekitd in verbose mode offers some more specific errors:

jonathan@jonathan-desktop:~$ sudo /usr/sbin/packagekitd --verbose
TI:09:54:50     TH:0x8a20170    FI:egg-debug.c  FN:egg_debug_init,306
 - Verbose debugging 1 (on console 1)PK_VERBOSE
TI:09:54:50     TH:0x8a20170    FI:pk-conf.c    FN:pk_conf_init,187
 - using config file '/etc/PackageKit/PackageKit.conf'
TI:09:54:50     TH:0x8a20170    FI:pk-syslog.c  FN:pk_syslog_init,108
 - syslog fucntionality disabled
TI:09:54:50     TH:0x8a20170    FI:pk-main.c    FN:main,273
 - Log all transactions: 1
TI:09:54:50     TH:0x8a20170    FI:egg-debug.c  FN:egg_debug_set_logging,287
 - logging to /var/log/PackageKit
TI:09:54:50     TH:0x8a20170    FI:pk-main.c    FN:main,278
 - daemon shutdown set to 300 seconds
TI:09:54:50     TH:0x8a20170    FI:pk-main.c    FN:main,282
 - using default backend apt
TI:09:54:50     TH:0x8a20170    FI:pk-backend.c FN:pk_backend_set_name,440
 - Trying to load : apt
TI:09:54:50     TH:0x8a20170    FI:pk-backend.c FN:pk_backend_build_library_path,414
 - dlopening '/usr/lib/packagekit-backend/libpk_backend_apt.so'
TI:09:54:50     TH:0x8a20170    FI:pk-engine.c  FN:pk_engine_init,710
 - clearing download cache at /var/cache/PackageKit/downloads
TI:09:54:50     TH:0x8a20170    FI:pk-backend-apt.c     FN:backend_initialize,39
 - backend: initialize
TI:09:54:50     TH:0x8a20170    FI:pk-backend-dbus.c    FN:pk_backend_dbus_set_name,490
 - trying to activate org.freedesktop.PackageKitAptBackend
TI:09:54:54     TH:0x8a20170    FI:pk-security-polkit.c FN:pk_security_init,331
 - Using PolicyKit security framework
TI:09:54:54     TH:0x8a20170    FI:pk-file-monitor-gio.c        FN:pk_file_monitor_set_file,124
 - watching for changes: /etc/PackageKit/PackageKit.conf
TI:09:54:54     TH:0x8a20170    FI:pk-conf.c    FN:pk_conf_get_string,65
 - ProxyHTTP read error: Key file does not have key 'ProxyHTTP'
TI:09:54:54     TH:0x8a20170    FI:pk-conf.c    FN:pk_conf_get_string,65
 - ProxyFTP read error: Key file does not have key 'ProxyFTP'
TI:09:54:54     TH:0x8a20170    FI:pk-transaction-db.c  FN:pk_transaction_db_init,566
 - trying to open database '/var/lib/PackageKit/transactions.db'
TI:09:54:54     TH:0x8a20170    FI:pk-backend-dbus.c    FN:pk_backend_dbus_status_changed_cb,97
 - got signal
TI:09:54:54     TH:0x8a20170    FI:pk-backend.c FN:pk_backend_set_status,761
 - emiting status-changed running
TI:09:54:54     TH:0x8a20170    FI:pk-backend-dbus.c    FN:pk_backend_dbus_allow_cancel_cb,221
 - got signal
TI:09:54:54     TH:0x8a20170    FI:pk-backend.c FN:pk_backend_set_allow_cancel,1338
 - emit allow-cancel 0
TI:09:54:54     TH:0x8a20170    FI:pk-backend-dbus.c    FN:pk_backend_dbus_percentage_changed_cb,107
 - got signal
TI:09:54:54     TH:0x8a20170    FI:pk-backend.c FN:pk_backend_emit_progress_changed,597
 - emit progress 101, 101, 3737, 0
TI:09:54:54     TH:0x8a20170    FI:pk-backend-dbus.c    FN:pk_backend_dbus_status_changed_cb,97
 - got signal
TI:09:54:54     TH:0x8a20170    FI:pk-backend.c FN:pk_backend_set_status,761
 - emiting status-changed loading-cache
TI:09:54:54     TH:0x8a20170    FI:pk-engine.c  FN:pk_engine_network_state_changed_cb,685
 - emitting network-state-changed: online
TI:09:54:57     TH:0x8a20170    FI:pk-engine.c  FN:pk_engine_reset_timer,173
 - reset timer
TI:09:54:57     TH:0x8a20170    FI:pk-engine.c  FN:pk_engine_reset_timer,173
 - reset timer
TI:09:54:58     TH:0x8a20170    FI:pk-engine.c  FN:pk_engine_reset_timer,173
 - reset timer
TI:09:55:00     TH:0x8a20170    FI:pk-main.c    FN:pk_main_timeout_check_cb,135
 - idle is 1
TI:09:55:02     TH:0x8a20170    FI:pk-engine.c  FN:pk_engine_get_tid,263
 - GetTid method called
TI:09:55:02     TH:0x8a20170    FI:pk-transaction-id.c  FN:pk_transaction_id_load_job_count,87
 - job=66
TI:09:55:02     TH:0x8a20170    FI:pk-transaction-id.c  FN:pk_transaction_id_save_job_count,101
 - saving 67
TI:09:55:02     TH:0x8a20170    FI:pk-post-trans.c      FN:pk_post_trans_init,810
 - trying to open database '/var/lib/PackageKit/desktop-files.db'
TI:09:55:02     TH:0x8a20170    FI:pk-transaction-db.c  FN:pk_transaction_db_init,566
 - trying to open database '/var/lib/PackageKit/transactions.db'
TI:09:55:02     TH:0x8a20170    FI:pk-transaction-list.c        FN:pk_transaction_list_create,406
 - adding transaction 0x8a4d030, item 0x8a35b90
TI:09:55:02     TH:0x8a20170    FI:pk-engine.c  FN:pk_engine_get_tid,267
 - sending tid: '/67_bcddeebb_data'
TI:09:55:02     TH:0x8a20170    FI:pk-engine.c  FN:pk_engine_reset_timer,173
 - reset timer
TI:09:55:02     TH:0x8a20170    FI:pk-transaction.c     FN:pk_transaction_search_name,3400
 - SearchName method called: none, dolphin
TI:09:55:02     TH:0x8a20170    FI:pk-transaction.c     FN:pk_transaction_set_dbus_name,255
 - assigning :1.1526 to 0x8a4d030
TI:09:55:02     TH:0x8a20170    FI:pk-transaction-list.c        FN:pk_transaction_list_commit,457
 - marking transaction /67_bcddeebb_data as committed
TI:09:55:02     TH:0x8a20170    FI:pk-transaction-list.c        FN:pk_transaction_list_commit,467
 - emitting ::changed
TI:09:55:02     TH:0x8a20170    FI:pk-transaction-list.c        FN:pk_transaction_list_get_array,504
 - 1 transactions in list, 1 active
TI:09:55:02     TH:0x8a20170    FI:pk-engine.c  FN:pk_engine_transaction_list_changed_cb,189
 - emitting transaction-list-changed
TI:09:55:02     TH:0x8a20170    FI:pk-engine.c  FN:pk_engine_reset_timer,173
 - reset timer
TI:09:55:02     TH:0x8a20170    FI:pk-transaction-list.c        FN:pk_transaction_list_commit,472
 - running /67_bcddeebb_data as no others in progress
TI:09:55:02     TH:0x8a20170    FI:pk-transaction-list.c        FN:pk_transaction_list_run_item,272
 - schedule idle running /67_bcddeebb_data
TI:09:55:02     TH:0x8a20170    FI:pk-transaction-list.c        FN:pk_transaction_list_run_idle_cb,255
 - actually running /67_bcddeebb_data
TI:09:55:02     TH:0x8a20170    FI:pk-backend.c FN:pk_backend_set_current_tid,1607
 - setting backend tid as /67_bcddeebb_data
TI:09:55:02     TH:0x8a20170    FI:pk-backend.c FN:pk_backend_set_locale,1014
 - locale changed to C
TI:09:55:02     TH:0x8a20170    FI:pk-backend.c FN:pk_backend_set_role,1374
 - setting role to search-name
TI:09:55:02     TH:0x8a20170    FI:pk-backend.c FN:pk_backend_set_status,761
 - emiting status-changed setup
TI:09:55:02     TH:0x8a20170    FI:pk-store.c   FN:pk_store_set_bool,157
 - saving 0 for force
TI:09:55:02     TH:0x8a20170    FI:pk-store.c   FN:pk_store_set_bool,157
 - saving 0 for allow_deps
TI:09:55:02     TH:0x8a20170    FI:pk-store.c   FN:pk_store_set_bool,157
 - saving 0 for autoremove
TI:09:55:02     TH:0x8a20170    FI:pk-store.c   FN:pk_store_set_bool,157
 - saving 0 for enabled
TI:09:55:02     TH:0x8a20170    FI:pk-store.c   FN:pk_store_set_bool,157
 - saving 0 for trusted
TI:09:55:02     TH:0x8a20170    FI:pk-store.c   FN:pk_store_set_uint,136
 - saving 1 for filters
TI:09:55:02     TH:0x8a20170    FI:pk-store.c   FN:pk_store_set_uint,136
 - saving 0 for provides
TI:09:55:02     TH:0x8a20170    FI:pk-store.c   FN:pk_store_set_string,65
 - saving 'dolphin' for search
TI:09:55:03     TH:0x8a20170    FI:pk-backend-dbus.c    FN:pk_backend_dbus_time_check,312
 - too much time for sync method: 1000ms
TI:09:55:03     TH:0x8a20170    FI:pk-backend.c FN:pk_backend_error_code,1311
 - emit error-code internal-error, The backend took too much time to process the synchronous request - you need to fork!
TI:09:55:03     TH:0x8a20170    FI:pk-transaction.c     FN:pk_transaction_error_code_cb,494
 - emitting error-code internal-error, 'The backend took too much time to process the synchronous request - you need to fork!'
TI:09:55:03     TH:0x8a20170    FI:pk-backend.c FN:pk_backend_finished,1459
 - finished role search-name
TI:09:55:03     TH:0x8a20170    FI:pk-backend.c FN:pk_backend_set_allow_cancel,1338
 - emit allow-cancel 0
TI:09:55:03     TH:0x8a20170    FI:pk-inhibit.c FN:pk_inhibit_lock,105
 - emit lock 1
TI:09:55:03     TH:0x8a20170    FI:pk-engine.c  FN:pk_engine_inhibit_locked_cb,203
 - emitting locked 1
TI:09:55:03     TH:0x8a20170    FI:pk-transaction.c     FN:pk_transaction_allow_cancel_emit,395
 - emitting allow-cancel 0
TI:09:55:03     TH:0x8a20170    FI:pk-backend.c FN:pk_backend_set_status,754
 - emiting status-changed running
TI:09:55:03     TH:0x8a20170    FI:pk-transaction.c     FN:pk_transaction_status_changed_emit,413
 - emitting status-changed 'running'
TI:09:55:03     TH:0x8a20170    FI:pk-backend.c FN:pk_backend_set_status,761
 - emiting status-changed finished
TI:09:55:03     TH:0x8a20170    FI:pk-transaction.c     FN:pk_transaction_status_changed_emit,413
 - emitting status-changed 'finished'
TI:09:55:03     TH:0x8a20170    FI:pk-backend.c FN:pk_backend_finished,1509
 - adding finished 0x8a2e010 to timeout loop
TI:09:55:03     TH:0x8a20170    FI:pk-transaction.c     FN:pk_transaction_get_status,2249
 - GetStatus method called
TI:09:55:03     TH:0x8a20170    FI:pk-transaction.c     FN:pk_transaction_get_status,2249
 - GetStatus method called
TI:09:55:03     TH:0x8a20170    FI:pk-backend-dbus.c    FN:pk_backend_dbus_status_changed_cb,97
 - got signal
TI:09:55:03     TH:0x8a20170    FI:pk-backend.c FN:pk_backend_set_status,731
 - already set error, cannot process: status query
TI:09:55:03     TH:0x8a20170    FI:pk-backend-dbus.c    FN:pk_backend_dbus_percentage_changed_cb,107
 - got signal
TI:09:55:03     TH:0x8a20170    FI:pk-backend.c FN:pk_backend_set_percentage,616
 - already set error, cannot process: percentage 101
TI:09:55:03     TH:0x8a20170    FI:pk-backend.c FN:pk_backend_finished_delay,1432
 - emit finished 1
TI:09:55:03     TH:0x8a20170    FI:pk-engine.c  FN:pk_engine_reset_timer,173
 - reset timer
TI:09:55:03     TH:0x8a20170    FI:pk-transaction.c     FN:pk_transaction_finished_cb,684
 - backend was running for 1396 ms
TI:09:55:03     TH:0x8a20170    FI:pk-inhibit.c FN:pk_inhibit_unlock,144
 - emit lock 0
TI:09:55:03     TH:0x8a20170    FI:pk-engine.c  FN:pk_engine_inhibit_locked_cb,203
 - emitting locked 0
TI:09:55:03     TH:0x8a20170    FI:pk-transaction.c     FN:pk_transaction_finished_emit,425
 - emitting finished 'failed', 1396
TI:09:55:03     TH:0x8a20170    FI:pk-transaction-list.c        FN:pk_transaction_list_transaction_finished_cb,309
 - transaction /67_bcddeebb_data completed, marking finished
TI:09:55:03     TH:0x8a20170    FI:pk-transaction-list.c        FN:pk_transaction_list_transaction_finished_cb,317
 - emmitting ::changed
TI:09:55:03     TH:0x8a20170    FI:pk-transaction-list.c        FN:pk_transaction_list_get_array,504
 - 1 transactions in list, 0 active
TI:09:55:03     TH:0x8a20170    FI:pk-engine.c  FN:pk_engine_transaction_list_changed_cb,189
 - emitting transaction-list-changed
TI:09:55:03     TH:0x8a20170    FI:pk-engine.c  FN:pk_engine_reset_timer,173
 - reset timer
TI:09:55:03     TH:0x8a20170    FI:pk-backend-dbus.c    FN:pk_backend_dbus_allow_cancel_cb,221
 - got signal
TI:09:55:03     TH:0x8a20170    FI:pk-backend.c FN:pk_backend_set_allow_cancel,1331
 - already set error, cannot process: allow-cancel 1
TI:09:55:04     TH:0x8a20170    FI:pk-backend-dbus.c    FN:pk_backend_dbus_package_cb,128
 - got signal
TI:09:55:04     TH:0x8a20170    FI:pk-backend.c FN:pk_backend_package,816
 - already set error, cannot process: package dolphin;4:4.2.0-0ubuntu2;i386;Ubuntu
TI:09:55:05     TH:0x8a20170    FI:pk-transaction-list.c        FN:pk_transaction_list_is_consistent,570
 - checking consistency as length 1
0       search-name     running[0] committed[1] finished[1]
TI:09:55:05     TH:0x8a20170    FI:pk-engine.c  FN:pk_engine_get_seconds_idle,522
 - engine idle zero as 1 transactions in progress
TI:09:55:05     TH:0x8a20170    FI:pk-main.c    FN:pk_main_timeout_check_cb,135
 - idle is 0
TI:09:55:05     TH:0x8a20170    FI:pk-backend-dbus.c    FN:pk_backend_dbus_finished_cb,211
 - deleting dbus 0x8a22490, exit success
TI:09:55:05     TH:0x8a20170    FI:pk-backend.c FN:pk_backend_finished,1459
 - finished role search-name
TI:09:55:05     TH:0x8a20170    FI:pk-backend.c FN:pk_backend_finished,1470
 - already finished
TI:09:55:09     TH:0x8a20170    FI:pk-transaction-list.c        FN:pk_transaction_list_remove_item_cb,242
 - transaction /67_bcddeebb_data completed, removing
TI:09:55:09     TH:0x8a20170    FI:pk-transaction-list.c        FN:pk_transaction_list_remove_internal,182
 - remove transaction /67_bcddeebb_data, item 0x8a35b90
TI:09:55:09     TH:0x8a20170    FI:pk-transaction.c     FN:pk_transaction_finalize,3892
 - emitting destroy /67_bcddeebb_data
TI:09:55:09     TH:0x8a20170    FI:pk-inhibit.c FN:pk_inhibit_remove,194
 - cannot find item 0x8a4d030
TI:09:55:10     TH:0x8a20170    FI:pk-main.c    FN:pk_main_timeout_check_cb,135
 - idle is 6
^CTI:09:55:11   TH:0x8a20170    FI:pk-main.c    FN:pk_main_sigint_handler,149
 - Handling SIGINT
TI:09:55:11     TH:0x8a20170    FI:pk-backend-apt.c     FN:backend_destroy,51
 - backend: destroy
TI:09:55:11     TH:0x8a20170    FI:pk-backend.c FN:pk_backend_finalize,1712
 - parent_class->finalize
Comment 1 Jonathan Thomas 2009-03-18 16:24:12 UTC

*** This bug has been marked as a duplicate of bug 17750 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.