Bug 20041 - Mipmaping + texture from pixmap not working (DRI2 + Acer Aspire One)
Summary: Mipmaping + texture from pixmap not working (DRI2 + Acer Aspire One)
Status: CLOSED INVALID
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915 (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium enhancement
Assignee: Eric Anholt
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: intel-3d-release
  Show dependency treegraph
 
Reported: 2009-02-10 11:01 UTC by bob@o-hand.com
Modified: 2017-10-27 19:38 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
glxinfo that checks the GLX_BIND_TO_MIPMAP_TEXTURE_EXT fbconfig attribute (38.85 KB, text/x-csrc)
2009-02-10 11:01 UTC, bob@o-hand.com
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bob@o-hand.com 2009-02-10 11:01:46 UTC
Created attachment 22769 [details]
glxinfo that checks the GLX_BIND_TO_MIPMAP_TEXTURE_EXT fbconfig attribute

Sorry I don't have the driver version info to hand, but it corresponded to the moblin2 build as of ~2 weeks ago, run on an eee901.

At that time the driver was not reporting any fbconfigs whos GLX_BIND_TO_MIPMAP_TEXTURE_EXT attribute was 1 so Clutter took that to mean mipmapping + texture from pixmap wasn't available.

Attached is a modified glxinfo.c that reports the value of this attribute. I can confirm that ran against an Nvidia driver it did report 1 for a number of fbconfigs as expected.
Comment 1 bob@o-hand.com 2009-02-10 11:22:02 UTC
Actually I realised I tested on an Acer Aspire One not an eee901.

I just re-tested though with a image built yesterday and can confirm that the driver still reports 0 for all fbconfigs.

The OpenGL renderer string was: Mesa DRI Intel(R) 945GME GEM 20090114 2008Q4 release x86/MMX/SSE2
Comment 2 Eric Anholt 2009-02-10 17:23:54 UTC
This isn't supported.  It'll be a while.
Comment 3 Eugeni Dodonov 2011-08-23 12:51:08 UTC
As it has been 2 years since this bug was filled, is it still an issue today?
Comment 4 Elizabeth 2017-10-27 19:38:10 UTC
(In reply to Eugeni Dodonov from comment #3)
> As it has been 2 years since this bug was filled, is it still an issue today?
Closing. No answer form submitter for too long. Thanks.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.