Bug 20253 - dbus-daemon-launch-helper: fix build with libxml
dbus-daemon-launch-helper: fix build with libxml
Status: RESOLVED FIXED
Product: dbus
Classification: Unclassified
Component: core
1.2.x
Other All
: medium normal
Assigned To: Havoc Pennington
John (J5) Palmieri
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-22 12:05 UTC by Peter Korsgaard
Modified: 2013-06-06 12:03 UTC (History)
1 user (show)

See Also:


Attachments
launch-helper.patch (1.03 KB, patch)
2009-02-22 12:05 UTC, Peter Korsgaard
Details | Splinter Review
[PATCH] XML: hard depends on expat and delete libxml (17.35 KB, patch)
2013-06-06 08:02 UTC, Chengwei Yang
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Korsgaard 2009-02-22 12:05:47 UTC
Created attachment 23179 [details] [review]
launch-helper.patch

I know the libxml support is deprecated, but here goes:

dbus-daemon-launch-helper links with the trival config parser, which
doesn't provide bus_config_parser_check_doctype(), like the big parser does.
The libxml loader unfortunately wants to call it, so this breaks the build.

Fix it by including a dummy bus_config_parser_check_doctype() in the trivial
config parser.
Comment 1 Simon McVittie 2011-01-24 08:27:03 UTC
I'm curious, why do you use the libxml backend? If there's a good reason to keep it, we should apply fixes like these and ensure that it's regression-tested; if there isn't, we should just delete it.
Comment 2 Peter Korsgaard 2011-01-24 11:18:28 UTC
(In reply to comment #1)
> I'm curious, why do you use the libxml backend? If there's a good reason to
> keep it, we should apply fixes like these and ensure that it's
> regression-tested; if there isn't, we should just delete it.

Well, this is for buildroot (http://buildroot.net), which is a build system for small embedded systems. Libxml2 was supported in the past, so we provide the option to use this for situations where libxml2 is already needed for other packages and expat isn't (libxml2 seems to be more commonly used by other packages than expat these days).

But OK, if there's no interest in supporting it, then yeah, let's get rid of it completely. Libexpat is quite small anyway (~150kb).
Comment 3 Chengwei Yang 2013-06-06 08:02:15 UTC
Created attachment 80384 [details] [review]
[PATCH] XML: hard depends on expat and delete libxml
Comment 4 Simon McVittie 2013-06-06 12:03:29 UTC
1.7.4, thanks